Edytor ustawień

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Preferences Editor and the translation is 100% complete.

Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Wprowadzenie

Zestaw ustawień programu FreeCAD znajduje się w menu Edycja → Preferencje.

Funkcjonalność FreeCAD jest podzielona na różne moduły, z których każdy jest odpowiedzialny za działanie konkretnego Środowiska pracy. FreeCAD wykorzystuje również koncepcję zwaną late loading, co oznacza, że komponenty są ładowane tylko wtedy, gdy są potrzebne. Być może zauważyłeś, że gdy zmienisz Środowisko pracy na pasku narzędzi FreeCAD, to wszystkie jego komponenty zostaną załadowane w tym momencie. Dotyczy to również ustawień preferencji.

Bez załadowanego modułu, będziesz miał dostęp do dwóch sekcji konfiguracyjnych, odpowiedzialnych za ogólne ustawienia aplikacji i ustawienia ekranu. Jeśli znajdujesz się w określonym Środowisku pracy, jego preferencje pojawią się jako nowa sekcja, a obsługiwane formaty plików pojawią się jako nowa zakładka w sekcji Import-Eksport.

Kliknięcie przycisku Reset w lewym dolnym rogu ekranu preferencji ustawi wszystkie z opcji FreeCAD na ich wartości domyślne.

Ustawienie ogólne

Ta sekcja menu konfiguracji zawiera 6 zakładek: Ogólne, Dokument, Edytor, Okno wyjściowe, Makro i Jednostki.

Informacje ogólne

W zakładce Ogólne możesz wprowadzić następujące dane:

Nazwa Opis
Zmień język Wybierz język interfejsu użytkownika FreeCAD.
Rozmiar aktualnej listy plików Określić, ile plików powinno znajdować się na liście ostatnio używanych plików.
Włączenie kafelkowego tła Jeśli jest zaznaczone, tło głównego okna FreeCAD będzie domyślnie składać się z tych obrazów: Background.png

Opcja ta działa tylko wtedy, gdy zaznaczono opcje w Style sheet/No style sheet.

Obraz można zmienić poprzez dodanie folderów Gui/Images do lokalizacji

%APPDATA%/FreeCAD (na Windows),

$HOME/.FreeCAD (dla Linux) lub

$HOME/Library/Preferences/FreeCAD (dla MacOS).

Umieść tam plik nazwany background.png i odznacz/odznacz opcję, aby zobaczyć zmiany.

Styl arkusza Wybór motywu dla wyglądu programu. Arkusze stylów określają, jak wygląda interfejs użytkownika FreeCAD.
Rozmiar ikon paska narzędzi Wybór rozmiaru ikon na pasku narzędzi.
Po uruchomieniu załaduj utomatycznie moduł Wybór, jakie Środowisko pracy będzie używane bezpośrednio po uruchomieniu programu FreeCAD
Wlącz ekran powitalny przy uruchamianiu Gdy to pole wyboru jest zaznaczone, podczas uruchamiania wyświetlany jest ekran powitalny programu FreeCAD.

Obraz ekranu powitalnego można zmienić poprzez dodanie folderu Gui/Images w lokalizacji %APPDATA%/FreeCAD (gdzie %APPDATA% jest specyficznym dla użytkownika katalogiem aplikacji FreeCAD systemu operacyjnego). Umieść tam plik nazwany splash_image.png i uruchom ponownie FreeCAD, aby zobaczyć nowy ekran powitalny.

Włacz zawijanie wierszy Słowa zostaną zawinięte, gdy przekroczą dostępną przestrzeń poziomą w konsoli Pythona. Konsola jest wyświetlana za pomocą menu Widok → Panele → Konsola Python.

Preference General Tab 01.png

Dokument

W zakładce Dokument można wybrać następujące opcje:

Nazwa Opis
Utwórz nowy dokument w trakcie uruchamiania Jeśli opcja jest zaznaczona, FreeCAD utworzy nowy dokument po uruchomieniu.
Stopień kompresji podczas zapisu Specyfikacja poziomu kompresji dla plików {FCStd. Pliki FCStd} są plikami skompresowanymi w formacie ZIP. Dlatego możesz zmienić ich rozszerzenie {.FCStd na .zip} i otworzyć je za pomocą programu do archiwizacji ZIP.
Użyj cofnij/ponów w dokumentach Jeśli to pole jest zaznaczone, wszystkie zmiany w dokumentach są zapisywane tak, aby można je było cofnąć/odtworzyć.
Maksymalna ilość króków cofnij/ponów Określa, ile kroków Cofnij/Zmień powinno zostać zarejestrowanych (0-99).
Uruchomienie funkcji autoodzyskiwania przy starcie Jeśli jest dostępny plik odzyskiwania, FreeCAD automatycznie uruchomi funkcję odzyskiwania pliku w momencie jego uruchomienia. W ten sposób pliki mogą zostać odtworzone, jeśli wystąpi awaria.
Zapisz informacje autoodzyskiwania Określ, jak często będzie zapisywany plik odzyskiwania.
Zapisywanie miniatur do pliku projektu, przy zapisywaniu dokumentu Jeśli to pole jest zaznaczone, po zapisaniu dokumentu zostanie również zapisana miniaturka. Miniaturka będzie wyświetlana na przykład na liście ostatnio zapisanych plików Środowiska pracy Start.
Dodaj logo programu do wygenerowanej miniaturki. Jeśli to pole jest zaznaczone, logo programu FreeCAD FreeCAD-logo.svg zostanie dodane do miniaturki. Ta opcja działa tylko wtedy, gdy opcja Zapisywanie miniatur do pliku projektu jest aktywna.
Maksymalna liczba plików kopii zapasowych do zachowania podczas zapisywania dokumentu Jeśli to pole jest zaznaczone, pliki kopii zapasowej będą zapisywane podczas zapisywania dokumentu. Można określić, ile plików kopii zapasowych będzie przechowywanych. Zawierają one wcześniej zapisaną wersję dokumentu. Pierwszy plik kopii zapasowej będzie miał rozszerzenie .FCStd1, drugi .FCStd2 i tak dalej.
Wyłącz częściowe wczytywanie połączonych obiektów zewnętrznych. Włączyć częściowe załadowanie zewnętrznego dokumentu połączonego. Gdy jest to włączone, tylko obiekty referencyjne i ich zależności będą ładowane, gdy połączony dokument jest automatycznie otwierany razem z dokumentem głównym. Częściowo załadowany dokument nie może być edytowany. Kliknij dwukrotnie ikonę dokumentu w widoku drzewa, aby załadować go w całości. Bardziej szczegółowe objaśnienie funkcji można znaleźć na stronie Assembly3 documentation page
Zezwalaj na dublowanie etykiet obiektów w jednym dokumencie Jeśli to pole jest zaznaczone, obiekty mogą mieć tę samą etykietę/nazwę. Na przykład różne części lub elementy mogą mieć wtedy identyczną nazwę w obrębie tego samego dokumentu.
Nazwa autora Wszystkie powstające dokumenty otrzymają określoną nazwę autora. Pole autora należy pozostawić puste na wypadek gdy autor ma pozostać anonimowy. Jeżeli zaznaczona jest opcja Ustaw przy zapisie, pole Last modified by zostanie ustawione na określonego autora w trakcie zapisywania pliku. Informacje te można wyświetlić za pomocą menu Plik → Informacje o projekcie.
Nazwa firmy Wszystkie utworzone dokumenty otrzymają podaną nazwę firmy.
Licencja domyślna Wybór domyślnej licencji dla nowych dokumentów. W przypadku wstępnie zdefiniowanej licencji link URL licencji zostanie automatycznie ustawiony. Wybierz Inne, aby uzyskać licencję własną lub specjalną.
URL licencji Wskazanie adresu URL opisującego licencję wybraną w polu Licencja domyślna

Preference General Tab 02.png

Edytor

Ustawienia edytora preferencji mają wpływ na zachowanie edytora makr. Edytor ten można otworzyć za pomocą menu Makro → Makra... → Edycja/tworzenie.

Ustawienia kolorów i czcionek mają również wpływ na Konsola Pythona. Konsola ta jest uaktywniana za pomocą menu Widok → Panele → Konsola Pythona.

W zakładce Edytor można ustawić następujące parametry:

Name Description
Elementy wyświetlane Wybór czcionki kodu. Ustawienia kolorów i czcionki zostaną zastosowane do wybranego typu. Wynik można zobaczyć w polu Podgląd.
Rodzina Specyfikacja dla typu czcionek, które należy stosować dla wybranego kodu źródłowego.
Rozmiar Określenie rozmiaru czcionki, którą należy stosować dla wybranego kodu źródłowego.
Włacz numerowanie linii Jeżeli pole jest zaznaczone, to wiersze z kodem będą ponumerowane.
Rozmiar tabulacji Określenie długości tabulatora (ilość spacji). Jeśli wartość została ustawiona na przykład na 6, naciśnięcie Tab spowoduje przejście do znaku 7 lub 13 lub 19 itd. To ustawienie jest używane tylko wtedy, gdy wybrano przestrzegaj tabulacji.
Rozmiar wcięcia Określa ile spacji zostanie wstawionych po naciśnięciu klawisza Tab. To ustawienie jest używane tylko wtedy, gdy jest zaznaczona opcja Wstaw spacje.
Przestrzegaj tabulacji Jeśli opcja zostanie zaznaczona, naciśnięcie Tab spowoduje wstawienie tabulatora z rastrem zdefiniowanym przez rozmiar tabulacji.
Wstaw spacje Jeśli opcja zostanie zaznaczona, wciśnięcie klawisza Tab wprowadzi ilość spacji zdefiniowanych przez rozmiar wcięcia.

Preference General Tab 03.png

Okno wyjściowe

Preferencje wyjścia mają wpływ na sposób działania Widok raportu.

W zakładce Okno wyjściowe można zdefiniować, następujące opcje:

Nazwa Opis
Rejestruj wiadomości dziennika Jeśli to pole jest zaznaczone, zapisywane są również informacje z logów. Informacje te będą wyświetlane w panelu Widok raportu w kolorze ustawionym w opcji Wiadomości dziennika. Panel ten jest wyświetlany za pomocą menu Widok → Panele → Widok raportu.
Rejestruj ostrzeżenia Jeśli to pole jest zaznaczone, zapisywane są komunikaty ostrzeżeń. Będą one wyświetlane w panelu Widok raportu w kolorze ustawionym w opcji Ostrzeżenia.
Rejestruj komunikaty błędów Jeśli to pole jest zaznaczone, będą zapisywane komunikaty o błędach. Będą one wyświetlane w panelu Widok raportu w kolorze ustawionym w opcji Błędy.
Wyświetlanie widoku raportu z komunikatem o błędzie lub ostrzeżeniem Jeśli to pole jest zaznaczone, panel widoku raportu pojawi się automatycznie, jak tylko zostanie zarejestrowany błąd lub ostrzeżenie.
Zwykłe wiadomości Określa kolor czcionki dla normalnych wiadomości w panelu Widok raportu.
Wiadomości dziennika Określa kolor czcionki dla komunikatów dziennika w panelu Widok raportu.
Ostrzeżenia Określa kolor czcionki dla komunikatów ostrzeżeń w panelu Widok raportu.
Błędy Określa kolor czcionki dla komunikatów błędów w panelu Widok raportu.
Przekieruj wewnętrzne wiadomości Python do panelu Widok raportu Jeśli to pole jest zaznaczone, wewnętrzne wyjście Pythona zostanie przekierowane z konsoli Pythona do panelu widoku raportu. Konsola Pythona jest wyświetlana z poziomu menu Widok → Panele → konsola Python.
Przekieruj wewnętrzne błędy Python do panelu Widok raportu Jeśli to pole jest zaznaczone, wewnętrzne komunikaty o błędach Pythona zostaną przekierowane z konsoli Pythona do panelu Widok raportu.

Preference General Tab 04.png

Makro

Opcje te kontrolują pewne parametry pracy makrodefinicji.

W zakładce Makro można zdefiniować następujące opcje:

Nazwa Opis
Uruchom makro w środowisku lokalnym Jeśli pole jest zaznaczone, zmienne zdefiniowane przez makra są tworzone jako zmienne lokalne, w przeciwnym razie są to zmienne globalne Python.
Ścieżka katalogu makra Określenie ścieżki do plików makrodefinicji.
Rejestrowanie poleceń GUI Jeśli pole jest zaznaczone, nagrane makro będzie również zawierać polecenia interfejsu użytkownika.
Rejestruj jako komentarz Jeśli pole jest zaznaczone, nagrane makro będzie również zawierać polecenia interfejsu użytkownika, ale jako komentarze. Jest to przydatne, jeśli nie chcesz wykonywać widocznych akcji podczas uruchamiania makra, ale zobaczyć, co można zrobić w sposób widoczny.
Pokaż polecenia skryptu w konsoli python Jeśli pole jest zaznaczone, polecenia wykonywane przez skrypty makro są wyświetlane w konsoli Pythona. Konsola jest dostępna z poziomu menu Widok → Panele → konsola Python.

Preference General Tab 05.png

Jednostki

W tej zakładce można skonfigurować sposób wyświetlania jednostek.

W zakładce Jednostki możesz ustawić następujące parametry:

Nazwa Opis
System użytkownika Wybór systemu jednostek, który powinien być używany dla wszystkich części programu FreeCAD.
Ilość miejsc dziesiętnych Liczba miejsc po przecinku, która powinna być wyświetlana dla liczb i wymiarów w programie FreeCAD.
Minimalna część ułamka Minimalna wielkość ułamkowa cala, która powinna być wyświetlana. To ustawienie jest dostępne tylko wtedy, gdy używany jest system jednostek Building US (ft-in/sqft/cuft).

Preference General Tab 06.png

Ustawienia ekranu

Ta sekcja preferencji posiada dwie ogólne zakładki Widok 3D i Kolory, oraz dalsze zakładki w zależności od używanych stanowisk pracy.

Widok 3D

Ta zakładka jest dostępna zawsze i kontroluje pewne cechy charakterystyczne widoku 3D.

W zakładce Widok 3D można skonfigurować następujące opcje:

Nazwa Opis
Pokaż układ współrzędnych Jeśli to pole jest zaznaczone, zawsze będzie wyświetlany główny układ współrzędnych w prawym dolnym rogu ekranu po otwarciu pliku projektu.
Pokaż licznik klatek na sekundę Jeśli opcja jest zaznaczona, to czas potrzebny na ostatnią operację i wynik w postaci liczby klatek na sekundę zawsze będzie wyświetlany w lewym dolnym rogu ekranu, po otwarciu pliku projektu.
Pokaz kostkę do nawigacji 3D Jeśli opcja jest zaznaczona, kostka nawigacyjna będzie zawsze widoczna w wybranym narożniku ekranu, pod warunkiem załadowania pliku projektu.
Używaj bufora OpenGL Vertex dla obiektów Jeśli opcja jest zaznaczona, Vertex Buffer Objects (VBO) będzie używany. VBO jest funkcją OpenGL która oferuje procedury przesyłania danych o wierzchołkach (położenie, wektor normalny, kolor itp.) od karty graficznej. VBO oferuje znaczny wzrost wydajności, ponieważ dane znajdują się w pamięci graficznej, a nie w pamięci systemowej i dlatego mogą być renderowane bezpośrednio przez GPU. Więcej informacji na temat tła można znaleźć na tej witrynie.
Render Cache dostępne w wersji 0.19 Render Cache lub Render Acceleration jest wyjaśnione bardziej szczegółowo w Link#render-caching. Istnieją trzy opcje:
  • Auto' (domyślnie), niech Coin3D zdecyduje, w której pamięci buforować.
  • Distributed, włącz pamięć podręczną dla wszystkich węzłów głównych źródła widoku.
  • Centralized, wyłącz pamięć podręczną we wszystkich węzłach wszystkich źródeł widoków i buforuj tylko w węźle głównym wykresu sceny. Zapewnia to najszybszą wydajność renderowania, ale wolniejszą reakcję na wszelkie zmiany sceny.
Włącz animację Jeśli opcja jest zaznaczona, obroty mogą być animowane. Jeśli na przykład styl nawigacji 3D ustawi się na CAD i mysz zostanie przesunięta, gdy kółko przewijania i prawy przycisk myszy zostaną wciśnięte, części zostaną obrócone. Jeśli mysz porusza się podczas zwalniania np. prawego przycisku myszy, obrót będzie kontynuowany jako animacja. Aby zakończyć animację kliknij lewym przyciskiem myszy.
Nawigacja 3D Wybór zestawu ustawień nawigacji myszką. Aby zobaczyć, co definiuje każdy zestaw, wybierz zestaw i naciśnij przycisk Mouse....
Styl orbity Wybór stylu orbity obrotu. Podczas oglądania części w płaszczyźnie X-Y, gdy istota jest w trybie obrotu nawigacji 3D, różnica polega na tym: Jeśli wybrano Trackball, poruszanie myszą w poziomie spowoduje obrót części wokół osi Y. Jeżeli wybrano Turntable, część zostanie obrócona wokół osi Z.
Wygładzanie Wybór, czy i jakiego rodzaju multisample anti-aliasing będzie w użyciu.
Orientacja widoku w nowym dokumencie Wybór kierunku ustawienia kamery, w przypadku nowych dokumentów.
Powiększenie w nowym dokumencie Wpływa na początkowy poziom przybliżenia kamery w przypadku nowych dokumentów. Ustawiona wartość odpowiada średnicy kuli, która pasuje do widoku 3D. Domyślnie 100mm, to wymiar wygodny dla obiektów takich jak obudowy dla Arduino. Ustawia również pwstępny rozmiar elementów początku układu współrzędnych (płaszczyzny bazowe w nowym obiekcie PartDesign).
Przybliż kursor Jeśli to pole jest zaznaczone, operacje powiększania będą wykonywane w położeniu kursora myszki. W przeciwnym razie operacje powiększania będą wykonywane na środku bieżącego widoku. Krok powiększenia określa, w jakim stopniu będzie wykonywane powiększenie. Krok powiększenia równy 1 oznacza współczynnik 7,5 dla każdego kroku powiększenia.
Odwróć kierunek przybliżenia Jeśli opcja jest zaznaczona, kierunek wykonywania operacji powiększania zostanie odwrócony.
Wyłączenie gestu pochylenia na ekranie dotykowym Jeśli ta opcja jest zaznaczona, gest pochylania zostanie wyłączony w przypadku przybliżania uszczypnięciem (powiększanie dwoma palcami). Dotyczy to tylko profilu nawigacji myszką ustawionego na "Gesture".
Przyciąganie do kursora Jeśli to pole wyboru jest zaznaczone, do obrotu w 3D będzie wykorzystana aktualna pozycja kursora jako środek obrotu. W przeciwnym razie zawsze będzie używany środek ekranu.
Rozmiar znacznika Wybór wielkości wierzchołków (punktów) w Środowisku pracy Sketcher. Obszar możliwy do zaznaczenia punktów można dodatkowo powiększyć poprzez zwiększenie wartości Zwiększ promień (w zakładce Kolory).
Odległość po między oczami dla trybów stereo Określenie odległości między oczami używanej do projekcji stereo. Podana wartość jest współczynnikiem, który zostanie pomnożony przez rozmiar ramki konturu obiektu 3D, który jest aktualnie wyświetlany.
Włącz podświetlenie kolorem Jeśli opcja jest zaznaczona, podświetlenie jest włączone przy użyciu zdefiniowanego koloru. Podświetlenie jest używane do renderowania tylnych boków ścian (zazwyczaj nie widać ich w bryłach, chyba, że tniemy jedną z płaszczyzną przycięcia, lub jeśli ściany nie są poprawnie ustawione). OPcja jest aktywna tylko dla obiektów, których właściwość oświetlenia (na zakładce Widok) jest ustawiona na wartość Jedna strona. Jeśli opcja jest wyłączona, tylne strony ścian obiektów w trybie oświetlenia Jedna strona będą czarne.
Intensywnośc podświetlenia Określenie intensywności podświetlenia. To ustawienie jest aktywne tylko wtedy, gdy opcja Włącz podświetlenie kolorem jest zaznaczona.
Typ projekcji Wybór typu zastosowanej metody wyświetlania obrazu z kamery.

Preference Display Tab 01.png

Kolory

Ta karta jest zawsze dostępna.

W zakładce Kolory możesz sprecyzować następujące funkcje:

Nazwa Opis
Włącz podświetlania elementu wskazanego Jeśli to pole wyboru jest zaznaczone, wybór wstępny jest włączony i wskazany element zostanie podświetlony określonym kolorem. Preselekcja oznacza, że np. krawędzie w częściach zostaną podświetlone podczas wskazywania kursorem myszki, oraz że mogą zostać wybrane.
Włącz podświetlania elementu wybranego Jeśli to pole wyboru jest zaznaczone, podświetlenie wyboru jest aktywne i zostanie zastosowany określony kolor.
Promień obszaru wyboru Ustawia wielkość powierzchni do wybierania elementów w widoku 3D. Większa wartość ułatwia wybieranie elementów, ale może uniemożliwić wybór niektórych małych elementów.
Kolor podstawowy Jeśli opcja zostanie wybrana, tło części będzie miało wybrany kolor.
Kolor gradientu Jeśli opcja zostanie wybrana, tło dla części będzie miało wybrany gradient koloru.
Kolor pośredni Funkcja jest włączona tylko wtedy, gdy wybrano Kolor gradientu. Jeśli to pole jest zaznaczone, gradient koloru otrzyma wybrany kolor jako kolor pośredni.
Obiekt w trakcie edycji Wybór koloru tła dla obiektów w widoku drzewa, które są aktualnie edytowane.
Obiekt aktywny Wybór koloru tła dla aktywnych obiektów w widoku drzewa. Na przykład, jeśli w widoku drzewa znajduje się kilka elementów, a jedna część jest przełączona jako active body, otrzyma wybrany kolor tła w widoku drzewa.

Preference Display Tab 02.png

Kolory wyświetlanych elementów

Ta zakładka jest wyświetlana tylko wtedy, gdy aktualnie uzywasz Part lub PartDesign lub jeśli wcześniej korzystałeś z tych Środowisk pracy.

W zakładce Kolory części można zdefiniować, następujące opcje:

Nazwa Opis
Domyślny kolor kształtu Wybór domyślnego koloru dla nowych kształtów. Jeśli opcja Losowy kolor kształtu jest aktywna, zamiast wybranego koloru używany jest kolor losowy.
Domyślny kolor linii Wybór domyślnego koloru linii dla nowych kształtów.
Domyślna szerokość linii Definiuje domyślnej grubości linii dla nowych kształtów.
Domyślny kolor wierzchołków Wybór domyślnego koloru dla nowych wierzchołków.
Domyślny rozmiar wierzchołków Specyfikacja domyślnego rozmiaru dla nowych wierzchołków
Kolor ramki konturu Wybór barwy dla ramki konturu w widoku 3D.
Domyślny kolor tekstu Wybór domyślnego koloru tekstu dla adnotacji w dokumencie. Obecnie nie ma możliwości dodawania adnotacji do dokumentów. Opisy mogą być dodawane tylko przy użyciu konsoli Pythona przy pomocy tego polecenia:

obj=App.ActiveDocument.addObject("App::Annotation", "Label")

Konsole można aktywować w menu Widok → Panele → konsola Python.

Preference Display Tab 03.png

Widok siatki

Ta zakładka jest wyświetlana tylko wtedy, gdy aktualnie używasz Środowiska pracy Mesh lub gdy używałeś go wcześniej.

W zakładce Widok siatki można zdefiniować, następujące opcje:

Nazwa Opis
Domyślny kolor siatki Wybór domyślnego koloru dla nowo utworzonych siatek.
Domyślny kolor linii Wybór domyślnego koloru linii dla nowo utworzonych siatek.
Stopień przeźroczystości siatki Określenie domyślnej wartości przezroczystości dla nowo utworzonych siatek.
Stopień przeźroczystości linii Określenie domyślnej wartości przezroczystości dla nowo utworzonych linii siatek.
Rendering dwustronny Jeśli pole jest zaznaczone, dolna strona powierzchni będzie renderowana w ten sam sposób jak strona górna. Jeśli nie jest zaznaczone, zależy to od opcji Włącz podświetlenie kolorem (zobacz sekcję widok 3D). Użyty zostanie kolor podświetlenia lub kolor czarny.
Wyświetlanie ramki ograniczającej dla zaznaczonych lub wybranych siatek Jeśli to pole jest zaznaczone, zostanie wyświetlone żółte pole ograniczające dla zaznaczonych lub wybranych siatek.
Zdefiniuj wektor normalny dla wierzchołka Jeśli to pole jest zaznaczone, Cieniowanie Phong jest używane, w przeciwnym razie stosuje się cieniowanie płaskie. Cieniowanie określa wygląd powierzchni.

W przypadku cieniowania płaskiego nie określa się normalności powierzchni na punkt, co prowadzi do nierzeczywistego wyglądu zakrzywionych powierzchni, natomiast zastosowanie cieniowania Phong prowadzi do uzyskania gładszego wyglądu.

Kąt natarcia Kąt załamania to kąt progowy między dwiema ściankami. Można go ustawić tylko wtedy, gdy opcja Zdefiniuj wektor normalny dla wierzchołka jest używana.
Jeśli kąt nachylenia powierzchni czołowej ≥ kąt załamania, stosuje się cieniowanie ścian.
Jeśli kąt nachylenia powierzchni < kąt załamania, stosuje się gładkie zacienienie.

Mesh View Preferences.png

Konfiguracja dla importu i eksportu

Ustawienia Import-Export wpływają na sposób importowania i eksportowania plików do i z FreeCAD. Są one opisane na stronie Preferencje eksportu importu.

Preferencje Środowisk pracy

Ta sekcja jest niekompletna i wymaga podania stron z opisem preferencji, każdego podstawowego Środowiska pracy.


Preferencje dla bardziej popularnych stołów warsztatowych są linkowane poniżej. Niektóre stoły warsztatowe nie mają preferencji. Inne opcjonalne Środowiska pracy mogą nie być tutaj wymienione.

Zewnętrzne Środowiska pracy

Ta sekcja jest niekompletna i wymaga podania stron preferencji dla każdego zewnętrznego Środowiska pracy

.