Interface Customization/ja

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Interface Customization and the translation is 20% complete.

Outdated translations are marked like this.
Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

FreeCADのインターフェイスは現代的なQtツールキットを基盤としているため最先端の構成を備えています。ウィジット、メニュー、ツールバーやその他のツールは変更、移動、ワークベンチ間での共有が可能です。またキーボードショートカットを設定、変更したり、マクロを記録、再生したりすることもできます。カスタマイズ用ウィンドウはメニューのTools -> Customize で開くことができます。

Screenshot-customize.jpg

Customization tabs

Commandsタブではカテゴリーごとに分類された利用可能な全てのFreeCADコマンドを見ることができます。


Keyboardでは各FreeCADコマンドに関連付けられたキーボードショートカットを確認でき、必要な場合にはそれを変更したり任意のコマンドに新しいショートカットを割り当てることができます。もしあなたが特定のワークベンチを頻繁に使い、キーボードを使ってその操作をスピードアップしたいのであればぜひこの機能を利用してください。

ToolbarsタブとToolbox barsタブでは現在のツールバーを変更したり、あなた独自のカスタマイズしたツールバーを作成することができます。

Under the tab Worksbenches (Workbenches) the workbenches existing in FreeCAD are listed, on the left the currently passive, on the right the currently active workspaces. The status can be changed with the horizontal arrows.

File:UserdefSymbstrip.jpg

Under the tab Toolbars (Toolbars) on the left are the same command categories as under the map Commands. After clicking on a category the corresponding commands appear, which can be copied to the right side. Before you do this, select an active workspace to which you want to add an individual toolbar. First select a name for this toolbar with New (New...) before copying commands over to it. When this workspace is called later, this bar must be activated: View → Toolbars.

Remark: If "Global" (instead of a workspace) is selected on the right, the added toolbar can be activated in each workspace.


Macrosタブでは保存されたマクロを管理することができます。

Create your Toolbars for your macro Customize Toolbars

Since FreeCAD 0.16 a new tool is available that lets you manage your workbenches.

CustomizeWorkbenches.png

ワークフローの例として、Draft Workbenchのカスタムツールバーにも[線形測定]ツールを表示するとします。

  • FreeCADでは、トップメニューからTools -> Customizeを選択してください。
  • select the "Toolbars" tab
  • on the left side choose "Part" in the pull down menu
  • on the left side in the lower window scroll down to the "Measure Linear" entry and select it
  • on the right side choose "Draft" in the pull down menu
  • click on New... to create a new toolbar and choose a name for it
  • 右下のウィンドウで目的のツールバーを選択します(複数のツールバーがある場合にのみ必要)
  • 青い「右矢印」(中央の行の一番上のアイコン)をクリックすると、選択したエントリが選択したツールバーに追加されます。

Remarks

When selecting "Global" in the pull down menu on the right side you will create a toolbar which will be visible in all workbenches.

For adding an installed macro to a toolbar you must

  • select "Macros" in the pull down menu on the left side
  • have assigned menu text, icon (Pixmap) and so on using the Tools → Customize → Macros menu