Interface Customization

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Interface Customization and the translation is 20% complete.

Outdated translations are marked like this.
Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Como la interfaz de FreeCAD se basa en el moderno toolkit Qt, su diseño es de última generación. Los Widgets, menús, barras de herramientas y demás elementos se pueden modificar, mover o compartir entre los diversos entornos de trabajo. Se puede establecer métodos abreviados de teclado, cambiarlos, y se pueden grabar y reproducir macros. Para acceder a la ventana de personalización se usa el menú Herramientas -> Personalizar:

Screenshot-customize.jpg

La pestaña Comandos permite explorar todos los comandos de FreeCAD disponibles, organizados por categorias.

En Teclado, se pueden ver los atajos de teclado, o combinaciones rápidas de teclas, asociadas con cada comando de FreeCAD y, si se desea, modificar o asignar nuevas combinaciones a cualquier comando. Por ejemplo podrías utilizarlo si utilizas frecuentemente un entorno de trabajo concreto y deseas agilizar su uso con el teclado.

Las pestañas de Barras de herramientas y Toolbox bars permiten modificar las barras de herramientas existentes o crear tus propias barras de herramientas a medida.

Under the tab Worksbenches (Workbenches) the workbenches existing in FreeCAD are listed, on the left the currently passive, on the right the currently active workspaces. The status can be changed with the horizontal arrows.

File:UserdefSymbstrip.jpg

Under the tab Toolbars (Toolbars) on the left are the same command categories as under the map Commands. After clicking on a category the corresponding commands appear, which can be copied to the right side. Before you do this, select an active workspace to which you want to add an individual toolbar. First select a name for this toolbar with New (New...) before copying commands over to it. When this workspace is called later, this bar must be activated: View → Toolbars.

Remark: If "Global" (instead of a workspace) is selected on the right, the added toolbar can be activated in each workspace.


La pestaña Macros te permite manejar las Macros que tengas guardadas.

Create your Toolbars for your macro Customize Toolbars

Since FreeCAD 0.16 a new tool is available that lets you manage your workbenches.

CustomizeWorkbenches.png

Example

For an example workflow lets suppose we want to have the "Measure Linear" tool also show up in a custom toolbar in the Draft Workbench.

  • in FreeCAD choose Tools → Customize from the top menu
  • select the "Toolbars" tab
  • on the left side choose "Part" in the pull down menu
  • on the left side in the lower window scroll down to the "Measure Linear" entry and select it
  • on the right side choose "Draft" in the pull down menu
  • click on New... to create a new toolbar and choose a name for it
  • now select your destination toolbar in the right lower window (only needed if you have more than one toolbar)
  • by clicking on the blue "Arrow right" (top icon in the middle row) you will add your selected entry to the selected toolbar

Remarks

When selecting "Global" in the pull down menu on the right side you will create a toolbar which will be visible in all workbenches.

For adding an installed macro to a toolbar you must

  • select "Macros" in the pull down menu on the left side
  • have assigned menu text, icon (Pixmap) and so on using the Tools → Customize → Macros menu