Tutorial do Rascunho

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft tutorial and the translation is 2% complete.

Outdated translations are marked like this.
Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎中文(繁體)‎

Introduction

Este tutorial destina-se a introduzir o leitor ao fluxo de trabalho básico da Bancada Rascunho, que inclui a criação de perfis, o uso de planos de trabalho, bem como a criação de dimensões, texto e anotações. Este tutorial usa a notação '(X, Y, Z)' para denotar as coordenadas necessários para definir os pontos de um objecto.

This tutorial was originally written by Drei, and it was rewritten and illustrated by vocx.

This tutorial is meant to introduce the reader to the basic workflow of the Workbench Draft.svg Draft Workbench.

The reader will practice:

  • creation of lines, arcs, and polygons
  • the use of working planes
  • the creation of dimensions, text, and shapestrings
  • the creation of a technical drawing

This tutorial uses the notation (x, y, z) to denote the coordinates required to define points in an object. The default unit is millimeters mm.

00 Dr01 Draft Tutorial final.png

Final drawing including various Draft objects.


Requirements

  • FreeCAD versão 0.16 ou superior
  • O leitor sabe como usar as pestanas 'Dados' e Vistas para alterar as propriedades de um elemento se desejar

1. Open FreeCAD, create a new empty document with File → Std New.svg New.

1.1. Switch to the Draft Workbench from the workbench selector, or the menu View → Workbench → Draft.
1.2. Make sure you understand how to use the property editor, particularly the Data and View tabs to change the properties.
1.3. Since the Draft objects are planar shapes, they are better viewed from the top. Use Std ViewTop.svg View top to set the 3D view.
1.4. Although it is not used in this tutorial, the Draft grid is helpful to position geometrical elements. Use Draft SelectPlane.svg SelectPlane to set both the working plane and the grid, and then show and hide the grid with Draft ToggleGrid.svg Toggle grid.

Procedimento

É obrigatório garantir que a barra de ferramentas Rascunho" esteja disponível para usar este tutorial.

  1. Iniciar FreeCAD
  2. Se você não tiver aberto um documento novo FreeCAD (a maioria da janela do FreeCAD parece cinzenta-out), a partir do menu, clique em Arquivo > Novo ou clique no botão Criar uma nova Documento Document-new.svg.
  3. Ative o 'Projecto Workbench'
  4. Selecione o menu 'Edit'
  5. Clique em 'Preferências'
  6. Ir para 'Draft' e selecione o 'Grid e encaixando' 'guia'
  7. Verifique se o 'Show Projecto snap barra de ferramentas' está ativa

Note que você pode alterar a visibilidade da Grelha neste menu, no caso de você querer desactivá-la.

Usando Planos

Os planos são usados para restringir o comportamento das ferramentas Rascunho para um plano específico, evitando-se problemas com a localização de pontos e curvas em peças complexas. Os planos podem referenciar os eixos do sistema de coordenadas (XY, YZ, ...), ou podem utilizar uma superfície plana no documento como referência.

Most Draft objects are planar shapes so they are naturally based on a working plane. A working plane can be one of the main XY, XZ, and YZ global coordinate planes, or it can be a plane that is parallel to them with a positive or negative offset, or it can be a plane defined by the face of a solid object.

  1. Seleccione Draft SelectPlane.png Definir plano de trabalho. Pode se localizar dentro das 'ferramentas da Bancada Rascunho" ou dentro do Menu Rascunho na divisão 'Utilities'.
  2. Selec o plano XY

Before pressing the button, you can also change the value of the offset in millimeters, as well as the grid spacing, the main lines and snapping radius.

Linhas e arcos
  1. Seleccione Draft Arc.png Arco.
  2. Defina o centro em '(0, 0, 0)'
  3. Defina o "raio" a 30 mm
  4. O "Ângulo inicial" é 60,0 °
  5. A abertura é 60,0 °

Repetir o mesmo procedimento para um segundo arco com um raio de 25 mm, as outras propriedades permanecem inalteradas.

  1. Seleccione Draft Line.png Linha.
  2. Aproxime-se do 'Endpoint' de qualquer arco. Um ponto branco deverá aparecer, paralelamente a este ícone Snap Endpoint.png quando o cursor se aproxima do ponto de extremidade.
  3. Selecione o ponto final do outro arco.
  4. Repetir para o outro lado dos arcos.

01 Dr01 Draft Arc profile.png

Closed profile created by two arcs and two lines.


Fusing or compounding

Temos agora várias curvas que detalham um perfil, no entanto, ainda não é reconhecido como uma entidade única. É possível continuar a trabalhar com os elementos intactos, embora, neste caso, vamos fundi-las em um único objeto.

  1. Selecione um arco e uma linha enquanto pressiona a 'CTRL' chave
  2. Clique em Draft Upgrade.png Atualizar

6b. If you wish to maintain the parametric nature of the objects you may wish to create a compound instead.

6.1. Switch to the Part Workbench.
6.2. With these objects selected, click on Part Compound.svg Part Compound.
Planes, retângulos e círculos
  1. Clique Draft Rectangle.png Retângulo
  2. Defina o primeiro ponto '(-100, -60, 0)'
  3. Defina o segundo ponto sobre o '(140, 90, 0)'

7. We will draw a rectangular frame.

7.1. Press Draft Rectangle.svg Rectangle.
7.2. Enter the values of the first point (-100, -60, 0), and press Enter.
7.3. Make sure the Relative option is unchecked, as we will use absolute units. You may press R in the keyboard to quickly toggle this option on and off.
7.4. Enter the values for the second point (140, 90, 0), and press Enter.

O resultado é um 'Plano' . Suas propriedades podem ser modificados para remover o 'preenchimento' , alterando a sua 'Modo de exibição' para 'Wireframe' .

  1. Seleccione Draft Circle.png
  2. Defina o centro para '(0, 0, 0)'
  3. Defina o raio para 15 mm
Polígonos
  1. Seleccione Draft Polygon.png Polígono
  2. O ponto de centro está localizado na '(0, 0, 0)'
  3. Defina o raio para 50 mm
  4. Defina o número de lados para 6

Again, you may change the DataMake Face and ViewDisplay Mode properties in the property editor if you want.

The rectangle, the circle, the polygon, and most other objects created with the Draft Workbench share many data and view properties because they are derived from the same base class, Part Part2DObject.

02 Dr01 Draft Rectangle circle polygon.png

Rectangle, circle and polygon added.


Arrays

As matrizes são usadas para replicar um objecto várias vezes numa direcção, um eixo de revolução ou ao longo de um caminho.

  1. Selecione o 'fio' que foi criado anteriormente
  2. Clique Draft Array.png matriz
  3. Na aba dados do objeto, altere o tipo de matriz de 'orto' para 'polar'
  4. Mudança 'Número Polar' 1-3

Arrays are used to replicate an object several times in an orthogonal direction (X, Y, Z), around a revolution axis, or along a path.

10. We will create a polar array.

10.1. Select the Wire object that was previously created with the Draft Upgrade.svg Upgrade tool, or the Compound created with the Part Compound.svg Part Compound tool.
10.2. Press Draft PolarArray.svg PolarArray.
10.3. Adjust the polar angle to 360°, and press OK.

Old workflow

10.2. Press Draft Array.svg Array.
10.3. Go to the tree view, select the Array object, and then go to the property editor, and change the DataArray Type from ortho to polar.
10.4. Change DataNumber Polar to 4, and DataAngle to 360°.

The array object shows copies of the object around the origin.

03 Dr01 Draft PolarArray.png

Polar array of the small profile centered around the origin.


Adicionando Dimensões

Dimensões requerem um uso constante de Restrições de agarramento para selecionar adequadamente os pontos que se deseja dimensionar. A 'da barra de ferramentas de agarramento' é utilizado para alterar os pontos possíveis que podem ser seleccionados.

Linear dimensions work best when using the appropriate Draft Snap methods to select points and edges to measure. However, they can also be created by specifying absolute coordinates.

  1. Seleccione Draft Dimension.png Dimension
  2. Selecione o primeiro ponto. Este pode ser um elemento ou especificado por coordintes existente. Para este tutorial, o primeiro ponto será alwaysvbe '(0, 0, 0)'
  3. Selecione o segundo ponto. Aproxime-se do ponto médio da linha superior do polígono. Um ponto branco deverá aparecer ao lado deste ícone Snap Midpoint.png
  4. Mova o cursor para o local desejado da dimensão e clique sobre ele.
  5. Alterar o tamanho da fonte na guia 'View' e 6 mm

Repetir o processo para os arcos e os círculos.

13. Repeat the process for the circle located in the center. The first point of the measurement will still be the origin. To select the second point make sure Draft ToggleSnap.svg Toggle snap is active, and only Draft Angle.svg Angle as well. As you move the pointer to the top of the circle, the Draft Angle.svg Angle icon should appear; click to select this point. Then move the cursor to the right, and click to fix the dimension.

Remember to adjust the ViewFont Size, and other properties to see the dimension correctly.

04 Dr01 Draft Dimension.png

Dimensions that measure the vertical distance from the origin to the top of the circle, arcs, and polygon.


Anotações e Texto

Existe uma pequena diferença entre os dois: só é possível usar o segundo como um perfil para executar operações 3D.

Anotações
  1. Seleccione Draft Text.png texto
  2. Selecione o ponto de referência no 'Ver 3D' . Neste caso, o midoint do arco superior.
  3. Digite o texto e pressione 'Enter' . Repita o procedimento para o maior número de linhas de texto como você deseja introduzir.
  4. Pressione Enter
Texto
  1. Seleccione Draft ShapeString.png ShapeString
  2. Selecione o ponto de referência no 'Ver 3D' . Isso pode ser um ponto existente ou a localização atual do cursor.
  3. Digite o texto e pressione 'Enter'
  4. Defina o tamanho da fonte desejado
  5. Deixar rastreamento em 0 mm
  6. Selecione o 'caminho' para o arquivo fonte que você deseja usar

05 Dr01 Draft Text ShapeString.png

Text and ShapeString objects added.


To extrude letters and engrave them on to solids, see the Draft ShapeString tutorial.

Criando Blueprints

Para criar os modelos, é necessário criar um 'Desenho' com os elementos que você deseja usar. Por favor, leia o Drawing tutorial para uma descrição detalhada.

As it is now, the objects that we have created can be saved, exported to other formats like SVG or DXF, or printed.

If you wish, you may create a technical drawing to display these objects together with additional information like a frame.

Before doing anything, hide the Draft grid by pressing Draft ToggleGrid.svg Toggle grid.

16. Switch to the Workbench TechDraw.svg TechDraw Workbench.

16.1. Create a standard page by pressing TechDraw PageDefault.svg TechDraw PageDefault.
16.2. In the tree view select all objects created, except for the Page, and then press TechDraw ActiveView.svg TechDraw ActiveView. Press OK with the default options; it may take a few seconds to create the view in the page.
16.3. Selecting the Page object in the tree view will automatically display the Page in the main window. With the Page selected, go to the property editor, and change DataScale to 0.75.
16.4. Expand the Page object in the tree view to select the ActiveView object. With this view selected, go to the property editor, and change DataScale Type to Page.
16.5. Recompute the model by using Std Refresh.svg Refresh or pressing F5.
16.6. Hide the frames of the objects by pressing TechDraw ToggleFrame.svg TechDraw ToggleFrame.

Learn more about the TechDraw Workbench by reading the Basic TechDraw Tutorial.

06 Dr01 Draft TechDraw page.png

TechDraw page with a projection of the shapes created with the Draft Workbench.


TechDraw works best with objects that have a Part TopoShape. Since some objects from Draft, like Draft Texts and Draft Dimensions, don't have such "shapes", some operations of TechDraw don't work with these elements.

Tools like TechDraw ActiveView.svg TechDraw ActiveView, TechDraw DraftView.svg TechDraw DraftView, and TechDraw ArchView.svg TechDraw ArchView work by receiving an internal SVG image that is generated by internal Draft functions; therefore, TechDraw doesn't have much control about how these views are displayed. More integration of Draft and TechDraw is a work in progress.

Estamos agora a terminar com o fluxo de trabalho básico para o Projecto Módulo.

The Draft Workbench in many ways is similar to the Sketcher Workbench, as both are intended to produce 2D shapes. The main difference is in the way each workbench handles coordinate systems, and how the objects are positioned. In Draft, objects are freely positioned in the global coordinates system, usually snapping their points to a grid, or to other objects. In Sketcher, a "sketch object" defines a local coordinate system which serves as the reference for all geometrical elements within that sketch. Moreover, the sketch relies on "constraints", and a constraint solver, to define the final position of its points and thus its final shape.

  • The Sketcher Workbench is intended for 2D drawings that require precise relationships between its points. It does not rely on a grid, but on the logical connections that certain points and edges make with other points and edges. The Sketcher Workbench is mostly used together with the PartDesign Workbench for the creation of solid bodies.

Template:Tutorials navi/pt