Tutoriel de Dessin de Shapestring

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft ShapeString tutorial and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский • ‎Türkçe
Base ExampleCommandModel.png Tutoriel
Thème
Product design
Niveau
Débutant
Temps d'exécution estimé
30 minutes
Auteur(s)
r-frank et vocx
Version de FreeCAD
0.17 et suivantes
Fichier(s) exemple(s)
Draft_Shapestring_Text


Introduction

Ce tutoriel a été écrit à l'origine par Roland Frank († 2017, r-frank). Il a été réécrit et illustré par vocx.

Ce didacticiel décrit une méthode pour créer du texte 3D et l'utiliser avec des objets solides. Nous allons voir comment

Pour utiliser ShapeStrings à l'intérieur de l'atelier PartDesign, allez à la fin de ce didacticiel.

08 T04 Part ShapesString Extrude final cut.png

Maquette finale du texte gravé.


L'atelier Sketcher est utilisé brièvement pour tracer une ligne auxiliaire. Pour plus d'informations sur les outils de cet atelier, consultez

Installation

1. Lancez FreeCAD, créez un nouveau document vide avec Fichier → Std New.svg Nouveau et sélectionnez l'atelier Part.

1.1. Appuyez sur le bouton Std ViewIsometric.svg Vue isométrique ou appuyez sur 0 dans le pavé numérique de votre clavier, pour changer la vue à isométrique pour mieux visualiser les solides 3D.
1.2. Appuyez sur le bouton Std ViewFitAll.svg Tout afficher chaque fois que vous ajoutez des objets afin de faire un panoramique et un zoom sur Vue 3D afin que tous les éléments soient visibles dans la vue.
1.3. Maintenez Ctrl pendant que vous cliquez pour sélectionner plusieurs éléments. Si vous avez sélectionné quelque chose de mal ou souhaitez tout désélectionner, cliquez simplement sur un espace vide dans la Vue 3D.

Création de la forme de base

2. Insérer un cube primitif en cliquant sur Part Box.svg Cube.

2.1. Sélectionnez Cube dans la vue en arborescence.
2.2. Modifiez les dimensions dans l'onglet Data de l'éditeur de propriétés.
2.3. Mettez Width à 31 mm.

3. Créer un chanfrein.

3.1. Sélectionnez le bord supérieur (Edge6) sur la face avant du Cube dans la Vue 3D.
3.2. Appuyez sur Part Chamfer.svg Chamfrein.
3.3. Dans Chamfer edges Panneau des tâches, se rendre à Selection puis choisir Select edges. En tant que Fillet type, choisissez Constant length puis définissez Length à 5 mm.
3.4. Appuyez sur OK. Cela créera un objet Chamfer.
3,5. Dans la vue en arborescence, sélectionnez Chamfer, dans l'onglet View, changez la valeur de Line Width à 2.0.

01 T04 Part Cube base long.png

Objet de base créé à partir d'un cube et d'une opération de chanfrein.


Insertion du texte avec l'outil Dessin de ShapeString

4. Basculez vers l'atelier Draft.

4.1. Assurez-vous que rien n'est sélectionné dans vue en arborescence.
4.2. Établissez le plan de travail jusqu'à XY (haut) en cliquant sur Draft SelectPlane.svg Plan de travail et pressez View-top.svg Vue de dessus (XY).

5. Insérer le texte "FreeCAD".

5.1. Appuyez sur Draft ShapeString.svg ShapeString.
5.2. Remplacez X en 0 mm.
5.3. Remplacez Y en 0 mm.
5.4. Remplacez Z en 0 mm.
5,5. Ou appuyez sur Reset point.
5.6. Remplacez String en FreeCAD; remplacez Height en 5 mm; remplacez Tracking en 0 mm.
5.7. Assurez-vous que Font file pointe vers une police valide, par exemple /usr/share/fonts/truetype/dejavu/DejaVuSans.ttf. Appuyez sur les points de suspension ... pour ouvrir la boîte de dialogue du système d'exploitation pour trouver une police.
5.8. Appuyez sur OK. Cela créera un objet ShapeString.
5.9. Recalculez le document en appuyant sur Std Refresh.svg Rafraîchir.
5.10. Dans la vue en arborescence, sélectionnez ShapeString, dans l'onglet View, changez la valeur de Line Width en {{incode|2.0} }.
5.11. Dans la vue en arborescence, sélectionnez Chamfer, dans l'onglet View, changez la valeur de Visibility en false ou appuyez sur Espace sur le clavier. Cela masquera l'objet afin que vous puissiez mieux voir le ShapeString.
5.12. Pour voir la ShapeString ci-dessus, changez la vue en appuyant sur View-top.svg Vue de dessus (XY) ou 2 dans le clavier.
5.13. Pour restaurer la vue en isométrique, appuyez sur Std ViewIsometric.svg Vue isométrique ou 0 sur le clavier.

02 T04 Part ShapeString.png

Texte créé en tant que ShapeString, c'est-à-dire en tant que collection d'arêtes dans un plan.


Créer un texte 3D

6. Retour à l'atelier Part.

6.1. Dans la vue en arborescence, sélectionnez ShapeString, puis appuyez sur Part Extrude.svg Extrusion.
6.2. Dans le Panneau des tâches Extrusion allez dans Direction, choisissez Along normal; dans Length, définissez Along sur 1 mm; cochez également l'option Create solid.
6.3. Appuyez sur OK. Cela créera un objet Extrude.
6.4. Dans la vue en arborescence, sélectionnez Extrude, dans l'onglet View, changez la valeur de Line Width en {{incode|2.0} }.

03 T04 Part ShapeString Extrude.png

Texte créé sous forme de chaîne de formes et transformé en solide par extrusion.


Insérer l'esquisse pour le positionnement

Nous allons maintenant dessiner une simple esquisse qui sera utilisée comme géométrie auxiliaire pour positionner l'extrusion ShapeString.

7. Dans la vue en arboresence, sélectionnez Extrude et pressez Espace pour le rendre invisible.

8. Basculez vers l'atelier Sketcher.

9. Dans la arborescence, sélectionnez Chamfer, puis appuyez sur Espace sur le clavier pour le rendre visible.

9.1. Choisissez la face inclinée créée par l'opération de chanfrein (Face3).
9.2. Cliquez sur Sketcher NewSketch.svg Nouvelle esquisse. Dans la boîte de dialogue Sketch attachment, sélectionnez FlatFace, puis appuyez sur OK.
9.3. La vue doit s'ajuster automatiquement afin que la caméra soit parallèle au visage sélectionné.
9.4. Tracez une ligne horizontale dans une position générale sur le dessus du visage. La longueur n'est pas importante; nous sommes simplement intéressés par sa position.
9.5. Contraindre l'extrémité gauche à 2.5 mm de l'axe X local et de l'axe Y local, à l'aide de Sketcher ConstrainDistanceX.svg Contrainte de distance horizontale et Sketcher ConstrainDistanceY.svg Contrainte distance verticale.
9,6. Étant donné que l'esquisse n'est qu'un objet auxiliaire, nous n'avons pas besoin de le contraindre complètement. Vous pouvez le faire si vous le souhaitez en affectant une distance fixe, par exemple 20 mm, à nouveau avec Sketcher ConstrainDistanceX.svg Contrainte de distance horizontale.
9.7. Fermez l'esquisse.

04 T04 Part ShapeString support sketch.png

Ligne en cours de création avec l'esquisse, avec contraintes.


05 T04 Part ShapeString support sketch 3D.png

Ligne d'esquisse créée au-dessus de la face solide, à utiliser comme guide de référence pour positionner le texte extrudé.


Positionnement du texte 3D dans l'espace 3D

10. Dans la vue en arboresence, sélectionnez Extrude et pressez Espace pour le rendre visible.

11. Dans la vue en arboresence, sélectionnez Extrude, dans l'onglet Data de éditeur de propriétés, cliquez sur Placement afin que le bouton points de suspension ... apparaisse à droite.

11.1. Cochez l'option Apply incremental changes.
11.2. Remplacez Rotation par Rotation axis with angle; Axis en Z et Angle par 90 deg puis cliquez sur Apply. Cela appliquera une rotation autour de l'axe Z et remettra à zéro le champ Angle.
11.3. Remplacez Rotation par Rotation axis with angle; Axis en Y, and Angle par 45 deg, puis cliquez sur Apply. Cela appliquera une rotation autour de l'axe Y et remettra à zéro le champ Angle.
11.4. Cliquez sur OK pour fermer la boîte de dialogue.

12. Basculez à nouveau vers Atelier Draft.

12.1. Passez au style de dessin "Wireframe" avec View → Draw styleDrawStyleWireFrame.svg Wireframe ou appuyez sur DrawStyleWireFrame.svg Wireframe dans la barre d'outils de la vue. Cela vous permettra de voir les objets derrière d'autres objets.
12.2. Assurez-vous que la méthode Draft Snap "Snap to endpoint" est active. Cela peut être fait à partir du menu Draft → Snapping → Draft ToggleSnap.svg Toggle On/Off puis Snap Endpoint.svg Endpoint, ou en appuyant sur Draft ToggleSnap.svg ToggleSnap et Snap Endpoint.svg Snap endpoint dans la barre d'outils Snap.

13. Dans la vue en arborescence, sélectionnez Extrude.

13.1. Cliquez sur Draft Move.svg Déplacer.
13.2. Dans la Vue 3D, cliquez sur le coin supérieur gauche de l'objet Extrude (1), puis cliquez sur le point le plus à gauche de la ligne tracée avec l'esquisse (2).
13.3. Si Snap Endpoint.svg Accrochage terminaison est actif, dès que vous déplacez le pointeur près d'un sommet, vous devez voir qu'il s'y attache. exactement.
Remarque: si vous rencontrez des problèmes lors de l'accrochage aux sommets, assurez-vous que seule la méthode Snap Endpoint.svg Accrochage terminaison est activée . Le fait d'avoir plusieurs méthodes d'accrochage actives en même temps peut rendre difficile la sélection de la bonne fonction.
13.4. Le texte extrudé doit maintenant se trouver dans le corps de l'objet Fillet.

06 T04 Part ShapeString move.svg

La chaîne de forme extrudée doit être déplacée à la position de la ligne esquissée qui se trouve sur la face du corps de base.


07 T04 Part ShapesString Extrude in place.png

Chaîne de forme extrudée positionnée dans le Fillet.


Création de texte gravé

14. Revenez à l'Atelier Part.

14.1. Passez au style de dessin "Comme actuellement" avec Affichage → Style de représentationDrawStyleAsIs.svg Comme actuellement ou appuyez sur le DrawStyleAsIs.svg Comme actuellement bouton dans la barre d'outils de la vue. Cela montrera tous les objets avec l'ombrage et la couleur normaux.
14.2. Dans la Vue en arborescence, sélectionnez Sketch et appuyez sur Espace sur le clavier pour le rendre invisible.

15. Dans la Vue en arborescence, sélectionnez d'abord Chamfer puis Extrude.

15.1. Appuyez ensuite sur Part Cut.svg Soustraction. Cela créera un objet Cut. Ceci est l'objet terminé.
Remarque: l'ordre dans lequel vous sélectionnez les objets est important pour l'opération de découpe. L'objet de base est sélectionné en premier et l'objet soustractif arrive à la fin.
15.2. Dans la Vue en arborescence, sélectionnez Cut, dans l'onglet Affichage, changez la valeur de Line Width en 2.0.

08 T04 Part ShapesString Extrude final cut.png

Modèle terminé d'un cube avec filet avec du texte gravé créé à partir des opérations ShapeString, extrusion et soustraction bouléenne.


Gravure de texte 3D avec l'atelier PartDesign

Un processus similaire à celui décrit ci-dessus peut être effectué avec l'Atelier PartDesign.

  1. Créez d'abord le Draft ShapeString.svg Draft Formes à partir texte.
  2. Créez un PartDesign Body Tree.svg PartDesign Corps, rendez-le actif et ajoutez un solide de base en ajoutant des primitives ou en utilisant une esquisse et en l'extrudant avec PartDesign Pad.svg PartDesign Protrusion.
  3. Déplacez l'objet ShapeString dans le corps actif.
  4. Attachez l'objet ShapeString à l'une des faces du solide ou à un PartDesign Plane.svg PartDesign Plan de référence, en utilisant Part Attachment.svg Part Attachement .
  5. Créez maintenant un PartDesign Pad.svg PartDesign Protrusion ou un PartDesign Pocket.svg PartDesign Cavité à partir de ShapeString, afin de produire un additif ou une soustraction PartDesign Feature du corps de base, respectivement.

Voir le fil du forum How to use ShapeStrings in PartDesign.

Remarques