Entwurf FormZeichenfolge Tutorium

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft ShapeString tutorial and the translation is 98% complete.

Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский • ‎Türkçe

Base ExampleCommandModel.png Tutorial

Thema
Produktgestaltung
Niveau
Anfänger
Zeit zum Abschluss
30 Minuten
Autor
r-frank und vocx
FreeCAD version
0.17 and above
Beispieldatei(en)
Draft_Shapestring_Text


Einleitung

Dieses Tutorium wurde ursprünglich von Roland Frank (†2017, r-frank) geschrieben, und es wurde von vocx neu geschrieben und illustriert.

Dieses Tutorial beschreibt eine Methode zur Erstellung von 3D Text und dessen Verwendung bei Volumenobjekten. Wir werden diskutieren, wie man

Um FormZeichenfolgen innerhalb der PartDesign Arbeitsbereich zu verwenden, gehe zum Ende dieses Tutoriums.

08 T04 Part ShapesString Extrude final cut.png

Endgültiges Modell des gravierten Textes.


Der Skizzierer Arbeitsbereich wird kurzzeitig zum Zeichnen einer Hilfslinie verwendet. Weitere Informationen zu den Werkzeugen dieses Arbeitsbereichs findet man in

Einrichtung

1. Öffne FreeCAD, erstelle ein neues leeres Dokument mit Datei → Std New.svg Neu, und wechsle in den Part Arbeitsbereich.

1.1. Drücke die Std ViewIsometric.svg Ansicht isometrisch Schaltfläche oder drücke 0 auf dem Ziffernblock deiner Tastatur, um die Ansicht auf isometrisch zu ändern und die 3D Körper besser zu veranschaulichen.
1.2. Drücke die Std ViewFitAll.svg Ansicht alles einpassen Schaltfläche wenn Du Objekte hinzufügst, um die 3D Ansicht so zu schwenken und zu zoomen, dass alle Elemente in der Ansicht zu sehen sind.
1.3. Halte Ctrl gedrückt, währen Du klickst, um mehrere Elemente auszuwählen. Wenn Du etwas falsch ausgewählt hast oder alles abwählen willst, klickst Du einfach auf eine leere Stelle in der 3D Ansicht.

Erstelle die Grundform

2. Füge einen Grundekörper Würfel ein, indem Du auf Part Box.svg Quader klickst.

2.1. Wähle Würfel in der Baumansicht.
2.2. Ändere die Abmessungen im Datenreiter des Eigenschafteneditor.
2.3. Ändere Breite in 31 mm.

3. Erstelle eine Fase.

3.1. Wähle die obere Kante (Edge6) auf der Vorderseite des Würfel in der 3D Ansicht.
3.2. Drücke Part Chamfer.svg Fase.
3.3. Im Kanten anfasen Aufgabenpaneel gehe zu Auswahl, wähle Kanten wählen. Als Verrundungstyp wähle Konstante Länge, dann setze Länge auf 5 mm.
3.4. Drücke OK. Dies erzeugt ein Fasen Objekt.
3.5. In der Baumansicht, wähle Fase, im Ansicht Reiter ändere den Wert Linienbreite auf 2.0.

01 T04 Part Cube base long.png

Basisobjekt erzeugt aus einem Würfel und einer Fasenbearbeitung.


Einfügen der FormZeichenkette

4. Wechsle in die Entwurf Arbeitsbereich.

4.1. Stelle sicher, dass in der Baumansicht nichts ausgewählt ist.
4.2. Lege die Arbeitsebene auf XY (oben) fest, durch klicken auf Draft SelectPlane.svg Wähle Ebene und drücken von View-top.svg Oben (XY).

5. Füge den Text "FreeCAD" ein.

5.1. Drücke auf Draft ShapeString.svg Formzeichenfolge
5.2. Ändere X in 0 mm.
5.3. Ändere Y in 0 mm.
5.4. Ändere Z in 0 mm.
5.5. Oder drücke Punkt zurücksetzen.
5.6. Ändere Zeichenfolge in FreeCAD; ändere Höhe in 5 mm; ändere Nachverfolgung in 0 mm.
5.7. Stelle sicher, dass Schriftartdatei auf eine gültige Schriftart zeigt, z.B. /usr/share/fonts/truetype/dejavu/DejaVuSans.ttf. Drücke die Auslassungspunkte ..., um den Dialog des Betriebssystems zu öffnen und eine Schriftart zu finden.
5.8. Drücke OK. Dies wird ein FormZeichenfolge Objekt erzeugen.
5.9. Berechne das Dokument neu, indem du Std Refresh.svg Aktualisieren drückst.
5.10. Wähle in der Baumansicht die Option FormZeichenfolge, ändere im Reiter Ansicht den Wert von Linienbreite in 2.0.
5.11. Wähle in der Baumansicht Fase, in der Ansicht ändre im Reiter den Wert von Visibility in false oder drücke Space auf der Tastatur. Dies blendet das Objekt aus, sodass Du die Formzeichenfolge besser sehen kannst.
5.12. Um den FormZeichenfolge von oben zu sehen, ändere die Ansicht, durch drücken von View-top.svg Oben (XY), oder 2 in der Tastatur.
5.13. Um die isometrische Ansicht wiederherzustellen, drücke Std ViewIsometric.svg Isoemetrische Ansicht, oder 0 in der Tastatur.

02 T04 Part ShapeString.png

Text erstellt als ShapeString, d.h. als eine Sammlung von Kanten in einer Ebene.


Erstellen des 3D Volumentextes

6. Wechsle wieder in die Part Arbeitsbereich.

6.1. In der Baumansicht wähle ShapeString und drücke dann Part Extrude.svg Extrudieren.
6.2. Im Extrudieren Aufgabenpaneel gehe zu Richtung, wähle Entlang der Normalen; in Länge setze Entlang auf 1 mm; hake auch die Option Erzeuge Volumenkörper an.
6.3. Drücke OK. Dies wird ein Extrudieren Objekt erzeugen.
6.4. Wähle in der Baumansicht die Option Extrudieren, ändere im Reiter Ansicht den Wert von Linienbreite in 2.0.

03 T04 Part ShapeString Extrude.png

Text als ShapeString erstellt und durch Extrusion in einen Festkörper verwandelt.


Hilfsskizze zur Positionierung einfügen

Nun zeichnen wir eine einfache Skizze, die als Hilfsgeometrie zur Positionierung der ShapeString Extrusion verwendet wird.

7. Wähle in der Baumansicht die Option Extrudiren und drücke Space auf der Tastatur, um sie unsichtbar zu machen.

8. Wechsle in den Skizzierer Arbeitsbereich.

9. Wähle in der Baumansicht die Option Fase und drücke Space auf der Tastatur, um sie sichtbar zu machen.

9.1. Wähle die durch die Fasenoperation (Face3) erzeugte schräge Fläche aus.
9.2. Klicke auf Sketcher NewSketch.svg NeueSkizze. Wähle im Dialogfeld Skizzenanhang die Option FlatFace und drücke OK.
9.3. Die Ansicht sollte sich automatisch so einstellen, dass die Kamera parallel zur gewählten Fläche ist.
9.4. Zeichne eine horizontale Linie in einer üblichen Position oben auf der Fläche. Die Länge ist nicht wichtig; wir sind nur an ihrer Position interessiert.
9.5. Beschränke den linken Endpunkt mit 2.5 mm auf einen Abstand von der lokalen X Achse und von der lokalen Y Achse, indem Sketcher ConstrainDistanceX.svg BeschränkeAbstandX and Sketcher ConstrainDistanceY.svg BeschränkeAbstandY.
9.6. Da die Skizze nur ein Hilfsobjekt ist, brauchen wir sie nicht vollständig zu begeschränken. Du kannst dies tun, wenn du möchtest, indem du einen festen Abstand, sagen wir, 20 mm, wieder mit Sketcher ConstrainDistanceX.svg BeschränkeAbstandX.
9.7. Schließe die Skizze.

04 T04 Part ShapeString support sketch.png

Linie mit dem Skizzierer erstellt, mit Beschränkungen.


05 T04 Part ShapeString support sketch 3D.png

Skizzen Linie erstellt auf der Oberseite der Volumenkörperfläche, zur Verwendung als Referenz für die Positionierung des extrudierten Textes.


Positionierung des Volumentextes im 3D Raum

10. Wähle in der Baumansicht Extrudiren und drücke Space auf der Tastatur, um sie sichtbar zu machen.

11. Wähle in der Baumansicht die Option Extrudieren, klicke im Reiter Daten des Eigenschaften Editor auf den Platzierung Wert, so dass die Auslassungspunkte Schaltfläche ... rechts erscheint.

11.1. Hake die Option Inkrementelle Änderungen übernehmen an.
11.2. Ändere den Drehung in Rotationsachse mit Winkel; Achse in Z, und Winkel in 90 Grad, dann klicke auf Übernehmen. Dies wendet eine Rotation um die Z Achse an und setzt das Winkel Feld auf Null zurück.
11.3. Ändere den Drehung in DRehachse mit Winkel; Achse in Y, und Winkel in 45 Grad, dann klicke auf Übernehmen. Dies wendet eine Drehung um die Y Achse an und setzt das Feld Winkel auf Null zurück.
11.4. Klicke auf OK, um den Dialog zu schließen.

12. Wechsle wieder in die Entwurf Arbeitsbereich.

12.1. Wechsle zum Drahtgitter Zeichenstil mit Ansicht → Zeichen StilDrawStyleWireFrame.svg Drahtgitter, oder drücke DrawStyleWireFrame.svg Drahtgitter Schaltfläche in der Ansichtswerkzeugleiste. Damit kannst du die Objekte hinter anderen Objekten sehen.
12.2. Stelle sicher, dass die Schaltfläche Entwurf Fang die Methode "Am Endpunkt fangen" aktiv ist . Dies kann über das Menü Entwurf→ Fang → Draft ToggleSnap.svg Umschalten An/Auserfolgen, und dann Snap Endpoint.svg Entwurf Endpunkt, oder durch Drücken der Draft ToggleSnap.svg UmschaltenFang und Snap Endpoint.svg Fang Endpunkt Schaltflächen in der Fang Werkzeugleiste.

13. Wähle in der Baumansicht Extrudieren.

13.1. Klicke auf Draft Move.svg Bewegen
13.2. Klicke in der 3D Ansicht auf den oberen linken Eckpunkt des Extrudieren Objekts (1) und dann auf den äußersten linken Punkt in der mit dem Skizzierer gezeichneten Linie (2).
13.3. Wenn Snap Endpoint.svg Fang Endpunkt aktiv ist, sobald du den Zeiger in die Nähe eines Knotens bewegst, solltest du sehen, dass er sich genau an diesen anfügt.
Hinweis: Wenn du Probleme mit dem Einrasten an Knoten hast, stelle sicher, dass nur die Snap Endpoint.svg Fang Endpunkt Methode aktiviert ist. Wenn mehrere Fangmethoden gleichzeitig aktiv sind, macht es schwierig, das richtige Grundelement auszuwählen.
13.4. Der extrudierte Text sollte sich nun innerhalb des Körpers des Fillet Objekts befinden.

06 T04 Part ShapeString move.svg

Der extrudierte ShapeString sollte auf die Position der skizzierten Linie verschoben werden, die auf der Fläche des Grundkörpers liegt.


07 T04 Part ShapesString Extrude in place.png

Extrudierter ShapeString positioniert in der Verrundung.


Erstellen von graviertem Text

14. Wechsle zurück in die Part Arbeitsbereich.

14.1. Wechsle zu "Original" Zeichenstil Ansicht → ZeichenstilDrawStyleAsIs.svg Original, oder drücke die DrawStyleAsIs.svg Original Schaltfläche in der Ansichtswerkzeugleiste. Dies zeigt alle Objekte mit der normalen Schattierung und Farbe an.
14.2. Wähle in der Baumansicht die Option Skizze und drücke Space auf der Tastatur, um sie unsichtbar zu machen.

15. Wähle in der Baumansicht zuerst Fase und dann Extrudieren.

15.1. Drücke dann Part Cut.svg Schneiden. Dies wird ein Schnitt Objekt erzeugen. Dies ist das endgültige Objekt.
Hinweis: die Reihenfolge, in der du die Objekte auswählst, ist wichtig für den Schneidevorgang. Das Basisobjekt wird zuerst ausgewählt, und das subtrahierende Objekt kommt am Ende.
15.2. Wähle in der Baumansicht die Option Schnitt, ändere im Reiter Ansicht den Wert von Zeilenbreite auf 2.0.

08 T04 Part ShapesString Extrude final cut.png

Endgültiges Modell eines verrundeten Würfels, mit geschnitztem Text, der aus einer ShapeString, Extrude und boolschen Schnittoperationen erzeugt wurde.


Gravieren von 3D Text mit dem PartDesign Arbeitsbereich

Ein ähnlicher Ablauf wie oben beschrieben kann mit der PartDesign Arbeitsbereich durchgeführt werden.

  1. Erstelle die Draft ShapeString.svg Entwurf FormZeichenfolge zuerst
  2. Erstelle einen PartDesign Body Tree.svg PartDesign Körper, aktiviere ihn und füge einen Basis-Volumenkörper hinzu, indem du Primitive hinzufügst, oder verwende eine Skizze und extrudiere sie mit PartDesign Pad.svg PartDesign Polster.
  3. Bewege das ShapeString Objekt in den aktiven Körper.
  4. Hänge das ShapeString Objekt an eine der Flächen des Volumenkörpers oder an ein PartDesign Plane.svg PartDesign Ebene, unter Verwendung Part Attachment.svg /de|Part Bindung.
  5. Erstelle jetzt ein PartDesign Pad.svg PartDesign Polster oder ein 16px PartDesign Pocket aus der Formzeichenfolge, um eine additive bzw. subtraktive Grundelement des Grundkörpers zu erzeugen.

Siehe den Forumsbeitrag, How to use ShapeStrings in PartDesign.

Anmerkungen