Draft DXF

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft DXF and the translation is 92% complete.

Outdated translations are marked like this.
Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe

Draft DXF

Menu location
Datei → Export → Autodesk DXF 2D (*.dxf)
Workbenches
Draft
Default shortcut
Strg+E
Introduced in version
-
See also
FreeCAD und DXF Import, FreeCAD und DWG Import


Beschreibung

Siehe auch: FreeCAD und DXF Import und FreeCAD und DWG Import.

Diese Funktion öffnet eine DXF-Datei (Version 12 bis 2007) in ein neues Dokument.

Screenshot qcad.jpg

Qcad-Zeichnung nach DXF exportiert, die anschließend in FreeCAD geöffnet wird


Einleitung

Die folgenden DXF-Objekttypen werden derzeit unterstützt:

  • Linien
  • Polylinien und Lwpolylinien
  • Kreise
  • Kreisbögen
  • Ebenen (Ebenen mit Objekten werden in FreeCAD Groups konvertiert)
  • Texte und Mtexte
  • Maße
  • Blöcke (nur Geometrie. Texte, Maße und Attribute in Blöcken werden übersprungen)
  • Punkte introduced in version 0.13
  • Vorlaufe introduced in version 0.13

Andere DXF-Objekte werden derzeit nicht importiert, da kein entsprechendes FreeCAD-Objekt vorhanden ist. Sobald neue Funktionen implementiert werden, können weitere Objekttypen importiert werden.

Installieren

Note: Aus Lizenzgründen sind die DXF - Import-/Exportbibliotheken nicht mehr Bestandteil des FreeCAD-Quellcodes. Aus diesem Grund müssen sie von Dir, dem Benutzer, nach der Installation von FreeCAD installiert werden. Es gibt eine Möglichkeit, FreeCAD dies automatisch zu erlauben oder dies manuell durchzuführen.

Automatisch

Ab Version 0.15 müssen nur die Option Bearbeiten → Einstellungen → Import/Export → DXF/DWG → "FreeCAD das automatische Herunterladen der DXF-Bibliotheken erlauben" markieren, damit FreeCAD das Herunterladen und Installieren dieser Bibliotheken automatisch übernimmt. Bei älteren Versionen muss dies manuell ausgeführt werden.

Manuell

Bibliotheken müssen von https://github.com/yorikvanhavre/Draft-dxf-importer heruntergeladen werden. Es gibt eine sehr vollständige Schritt-für-Schritt-Anleitung Tutorial, die die notwendigen Schritte erklärt.

Importieren

Dies funktioniert genauso wie das Öffnen, aber es wird der Inhalt der DXF-Datei in das aktive Dokument eingefügt, anstatt ein neues Dokument zu erstellen.

Tutorial: Dxf Importer Install

Exportieren

Die exportierte DXF-Datei ist mit Autocad ab Version 12 und höher kompatibel. Sie sollte daher in allen Anwendungen geöffnet werden, die das DXF-Format unterstützen. Derzeit werden folgende FreeCAD-Objekte exportiert:

  • Linien und Drähte (Polylinien)
  • Kreisbögen und Kreise
  • Texte
  • Farben werden von den RGB-Farben des Objekts auf den AutoCAD-Farbindex (ACI) abgebildet. Schwarz wird immer "gemäss Ebene" sein
  • Ebenen werden aus Gruppennamen zugeordnet. Wenn Gruppen verschachtelt sind, gibt die niedrigste Gruppe den Ebenennamen an.
  • Masse, die mit "Standard" Dimstyle exportiert werden

Einstellungen

Die folgenden Parameter können im Preferences Editor im Menü Bearbeiten → Einstellungen → Import-Export festgelegt werden.

  • Importstil: Hier kann ausgewählt werden, wie Objekte aus der DXF-Datei in FreeCAD gezeichnet werden. Gewählt werden kann zwischen:
    • Keine: Dies ist der schnellste Weg. Es findet keine Konvertierung statt. Alle Objekte werden schwarz mit einer Breite von 2 Pixel (FreeCAD-Standard).
    • Standardfarbe und Linienbreite verwenden: Alle importierten DXF-Objekte übernehmen die aktuelle Linienbreite / Farbe aus der Entwurfsbefehlsleiste
    • Originalfarbe und Linienbreite: Objekte behalten die Farbe und Linienbreite bei (falls angegeben), die sie in der DXF-Datei haben
    • Farben, die der Linienbreite zugeordnet sind: Wenn diese Option ausgewählt ist, wird die unten stehende Option für die Zuordnungsdatei verwendet.
  • Farbzuordnungsdatei: Mit dieser Option kann eine Zuordnungsdatei angeben werden, die zum konvertieren von DXF-Farben in Farbe und Linienbreite verwendet wird, genau wie ein Plotstil in Autocad funktioniert. Die Zuordnungsdatei muss eine durch Tabulatoren getrennte Textdatei sein. Es gibt ein schönes kostenloses Dienstprogramm namens Plot Style Viewer, mit dem Autocad CTB- oder STB-Dateien (Plot Styles) in tabulatorgetrennte Zuordnungsdateien konvertiert werden können, die in FreeCAD verwendet werden können. Alternativ haben wir hier ein paar home-made mapping files hier.
  • Texte importieren: Hier kann festlegt werden, ob DXF-Texte und Bemaßungen importiert werden sollen. Viele Texte können die Arbeit in FreeCAD sehr erschweren. Daher wird diese Option möglicherweise manchmal verwendet werden.
  • Layoutobjekte importieren: Aktiviere diese Option, wenn ein Papierbereichsobjekt importieren werden soll. Sie werden im selben Dokument wie Modellbereichsobjekte zusammengeführt.

Scripting

Siehe auch: Draft API/de und FreeCAD Scripting Basics/de.

Elemente können durch die folgende Funktion nach DXF exportiert werden:

importDXF.export(objectslist, filename, nospline=False, lwPoly=False)

Beispiel:

import Draft, importDXF

Polygon1 = Draft.makePolygon(3, radius=500)
Polygon2 = Draft.makePolygon(5, radius=1500)

objects = [Polygon1, Polygon2]

importDXF.export(objects, "/home/user/Pictures/myfile.dxf")