View Issue Details

IDProjectCategoryView StatusLast Update
0000874PartDesignBugpublic2013-01-09 21:47
Reporterscopaev Assigned ToJriegel 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000874: Linear Pattern does not reference X,Y,Z correctly if part was made from the XZ, or YZ planes
DescriptionIn FCv013 - If Part was created on XY, the X,Y,Z check boxes (for direction to apply pattern in) follow the reference arrows on btm right of screen.

If Part was created on XZ, or YZ, the X,Y,Z check boxes are not referenced properly (choose X, part is copied in the Y or Z direction).
TagsNo tags attached.
FreeCAD Information

Activities

Jriegel

2012-11-13 20:12

administrator   ~0002510

The pattern works always in reference to the sketch of the underlaying object.
So x,y,z are missleading. I would probably remove x,y,z and require allways
selection of an edge or face..

Jriegel

2012-11-15 17:20

administrator   ~0002526

Mhh, there is no right solution to this. I would remove the x,y,z stuff
and let the user only use the selection for the direction.

Jriegel

2012-11-15 17:58

administrator   ~0002528

8a40df6c22a03b33d3a2b8b4446470df4d333727

rmoved x,y,z cause makes no sence. User can not determine the position and
orientation of the sketch. So only selection of a line or face makes sense.

logari81

2012-12-17 11:38

developer   ~0002649

The original idea was that X,Y,Z represent the Body Feature coordinate system. Until the Body feature is introduced, we just use the X,Y,Z of the untransformed very initial feature of a PartDesign feature. The logic was consistent even if it wasn't transparent to the users.

Another fix for this would be to leave only two options X,Y and refer to the sketch axes. However this solution would still be inconsistent with the polar pattern feature where we would also need a Z-axis, we could use the Z axis of the sketch. We can discuss about this.

I thing removing these options at all is not a proper solution.

Jriegel

2012-12-19 15:59

administrator   ~0002670

Even the coordinates due to the body object is hard to deal for the user.
The Body can be moved in the assembly and the X,Y,Z has again no meaning.
Also the base sketch is not visibly normally.
And if you have a recalculation in the history which move the sketch? Change
the angle, because it sits on a face which get moved?
The only thing makes sense to me would be a U,V coordinate system due to the sketch. Thats always defined.

In the Body we can allow to select the Body base coordinate system axis.

logari81

2013-01-04 13:13

developer   ~0002792

I am suggesting this solution:

http://ubuntuone.com/3vH81P9jAwIHqfN2QMA6ES

what do you think?

logari81

2013-01-09 21:46

developer   ~0002835

this should be fixed with commit 525cddaaf32e7e1fc2b07e56eada2a92e106aab9

Issue History

Date Modified Username Field Change
2012-11-08 13:01 scopaev New Issue
2012-11-13 20:12 Jriegel Note Added: 0002510
2012-11-13 20:12 Jriegel Status new => acknowledged
2012-11-15 17:20 Jriegel Note Added: 0002526
2012-11-15 17:58 Jriegel Note Added: 0002528
2012-11-15 17:58 Jriegel Status acknowledged => resolved
2012-11-15 17:58 Jriegel Fixed in Version => 0.13
2012-11-15 17:58 Jriegel Resolution open => fixed
2012-11-15 17:58 Jriegel Assigned To => Jriegel
2012-12-17 11:38 logari81 Note Added: 0002649
2012-12-17 11:38 logari81 Status resolved => feedback
2012-12-17 11:38 logari81 Resolution fixed => reopened
2012-12-19 15:59 Jriegel Note Added: 0002670
2013-01-04 13:13 logari81 Note Added: 0002792
2013-01-09 21:46 logari81 Note Added: 0002835
2013-01-09 21:47 logari81 Status feedback => closed
2013-01-09 21:47 logari81 Resolution reopened => fixed