View Issue Details

IDProjectCategoryView StatusLast Update
0003579SketcherFeaturepublic2018-10-06 14:43
ReporterchrisbAssigned Toabdullah 
PrioritylowSeverityfeatureReproducibilityhave not tried
Status closedResolutionwon't fix 
Product Version0.18 
Target VersionFixed in Version 
Summary0003579: Esc key should not leave Sketcher. It interferes with the Create tools
DescriptionCreate tools can be ended by pressing Esc, some modes like Polyline even need 2 Esc keypresses. One keypress too much exits Sketcher, sometimes unwanted.
Since a key for "Exit Skecther" can be configured Esc key should be removed here.
Forum discussion.
Tagsshortcuts

Activities

abdullah

2018-09-28 14:08

manager   ~0011868

It would appear to me that the perceived problem was already solved here:

https://forum.freecadweb.org/viewtopic.php?f=34&t=30643&start=20#p255406

Do we still know to strip the ESC from closing?

abdullah

2018-10-06 05:51

manager   ~0011941

The usage of ESC for closing dialogs is considered to be UI standard. See:
https://forum.freecadweb.org/viewtopic.php?f=34&t=30643&start=20#p259336

Issue History

Date Modified Username Field Change
2018-09-02 16:51 chrisb New Issue
2018-09-02 19:30 Kunda1 Tag Attached: shortcuts
2018-09-28 14:08 abdullah Note Added: 0011868
2018-10-06 05:50 abdullah Assigned To => abdullah
2018-10-06 05:50 abdullah Status new => assigned
2018-10-06 05:51 abdullah Status assigned => resolved
2018-10-06 05:51 abdullah Resolution open => won't fix
2018-10-06 05:51 abdullah Note Added: 0011941
2018-10-06 14:43 abdullah Status resolved => closed