View Issue Details

IDProjectCategoryView StatusLast Update
0003447PartDesignBugpublic2018-09-22 12:01
ReporterDeepSOICAssigned Towmayer 
PrioritynormalSeverityblockReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.17 
Target VersionFixed in Version0.18 
Summary0003447: False PartDesign migration request
DescriptionHaving a PD clone in a project outside of bodies causes false migration request. No further operations can be done unless one accepts the request. Accepting the request messes up project structure.

Forum: https://forum.freecadweb.org/viewtopic.php?f=3&t=28380
Steps To Reproduce1. Make Body.
2. Make PD Clone of body
3. Save the project and reopen it.
4. Activate Body, make sketch
-> BOOM, migration!

OR

1. open attached file
2. make PartDesign Sketch
Additional InformationEspecially nasty, because it appears only after the file is saved and reopen. Omitting step 3 doesn't cause migration pop-up.

OS: Linux Mint 18.1 Serena
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.13588 (Git)
Build type: None
Branch: master
Hash: 1e2b9758cc7f6872da018ee71983a82499866508
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedKingdom (en_GB)

OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13509 (Git)
Build type: Release
Branch: releases/FreeCAD-0-17
Hash: 0258808ccb6ba3bd5ea9312f79cd023f1a8671b7
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: Russian/RussianFederation (ru_RU)
Tagsmigration

Relationships

related to 0003509 closedwmayer Create MultiTransform Feature from existing Transform Feature forces document migration 

Issue History

Date Modified Username Field Change
2018-04-25 21:59 DeepSOIC New Issue
2018-04-25 21:59 DeepSOIC Tag Attached: migration
2018-04-25 21:59 DeepSOIC File Added: false-migration-trigger-test3.fcstd
2018-04-25 22:39 DeepSOIC Description Updated View Revisions
2018-04-25 22:39 DeepSOIC Steps to Reproduce Updated View Revisions
2018-04-25 22:39 DeepSOIC Additional Information Updated View Revisions
2018-09-03 08:16 normandc Relationship added related to 0003509
2018-09-22 12:01 wmayer Assigned To => wmayer
2018-09-22 12:01 wmayer Status new => closed
2018-09-22 12:01 wmayer Resolution open => fixed
2018-09-22 12:01 wmayer Fixed in Version => 0.18
2018-09-22 12:01 wmayer Note Added: 0011812