View Issue Details

IDProjectCategoryView StatusLast Update
0003341Part[FreeCAD] Bugpublic2018-10-13 10:22
ReporterKunda1 Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003341: Undoing is missing steps
DescriptionIf I put the mouse over the Undo icon, there is a tool tip with "Undo exactly one action".
Sometime when I click the Undo command it put my work back on a point where I was maybe at the beginning of my drawing
or on some place what actually is not my last action.

See Step to reproduce below.

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=26777
Steps To Reproduce1. Open a new drawing
2. Switch to PART workbanch
3. Create a cube (or whatever else)
4. Double click on the created cube
5. In the PROPERTY under BOX change the LENGTH and/or WIDTH (no matter what dimensions parameter you change)
6. The cube is re-dimensioned to the new value
7. Press the UNDO command
8. BINGO! the cube is deleted, your work is gone, looks like the last action was actually the "Create cube" command.
Additional InformationOS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6712 (Git)
Build type: Release
Branch: releases/FreeCAD-0-16
Hash: da2d364457257a7a8c6fb2137cea12c45becd71a
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

and

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13217 (Git)
Build type: Release
Branch: master
Hash: 89275766de909a5c1f36e962806dc7b4a0b0f47b
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)
Tagsundo
FreeCAD Information

Issue History

Date Modified Username Field Change
2018-02-07 23:23 Kunda1 New Issue
2018-02-07 23:23 Kunda1 Tag Attached: undo
2018-08-23 17:42 Kunda1 Target Version => 0.18
2018-10-13 10:22 wmayer Assigned To => wmayer
2018-10-13 10:22 wmayer Status new => closed
2018-10-13 10:22 wmayer Resolution open => fixed
2018-10-13 10:22 wmayer Fixed in Version => 0.18
2018-10-13 10:22 wmayer Note Added: 0012017