View Issue Details

IDProjectCategoryView StatusLast Update
0003339DraftBugpublic2018-11-09 00:26
Reporterstunts1990 Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86-64OSWindows 10 HomeOS Version1709
Product Version0.17 
Target VersionFixed in Version 
Summary0003339: Point Sizes different after undoing deletion
DescriptionWhen a point is deleted and the undo button is pressed, the point should be back in its original size. However when the undo button is pressed, the point ends up being smaller than what it was before the Deletion. This means that the undo button does not fully undo the last action and only partially completes what it was required to do as a smaller point back on the canvas indicates a partial restoration of the point that is some portion of the point went missing in the undo step.
Steps To ReproduceStart Up FreeCAD.
Press Ctrl+N to create a new drawing.
Left Click on Start and then left click on Draft to change the workbench to Draft.
Press 2 to change view to Top View.
Left Click on Create point object in the draft creation tools toolbox.
Left click on the canvas to place the point object on the canvas.
Press the delete key to delete the point object.
Press Ctrl+Z to undo the deletion
You may note that the point object did not restore back to its original size and is smaller than what it was prior to its deletion.
Additional InformationYou can see the difference in the point sizes in the image.
TagsDraft, undo

Activities

stunts1990

2018-02-07 07:20

reporter  

bug1.PNG (101,477 bytes)
bug1.PNG (101,477 bytes)

Kunda1

2018-02-07 16:22

administrator   ~0010929

Last edited: 2018-02-07 16:22

View 2 revisions

@stunts1990 thanks for the ticket. please open a forum thread to announce to community. BTW, please always add you Help > About FreeCAD > Copy to clipboard info when opening a ticket.

user2853

2018-02-08 00:25

  ~0010930

I cannot reproduce on
OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13247 (Git)
Build type: Release/Daily-PPA
Branch: master
Hash: 5022c8df5cef0690f2c8acff4bcebd82655a5f04
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)

Kunda1

2018-05-31 17:38

administrator   ~0011338

@stunts1990 please try to reproduce the issue using the bleeding edge 0.18dev version and report back ( https://github.com/FreeCAD/FreeCAD/releases/tag/0.18_pre )

Kunda1

2018-06-07 16:51

administrator   ~0011359

@stunts1990 please respond

Kunda1

2018-08-01 02:59

administrator   ~0011573

@stunts1990 ping

Kunda1

2018-08-08 20:14

administrator   ~0011609

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=30209

Kunda1

2018-08-08 20:41

administrator   ~0011611

@stunts1990 please follow the forum thread

wmayer

2018-10-04 07:43

administrator   ~0011911

The reported issue for true for 0.16 or older but not with 0.17 or later. So, since the bug reporter shows no reaction I vote for closing the ticket.

Kunda1

2018-10-17 20:38

administrator   ~0012056

@stunts1990 please respond or we will close this ticket

Kunda1

2018-10-17 20:39

administrator   ~0012057

Resolving this ticket for now.

Kunda1

2018-11-09 00:26

administrator   ~0012157

Closing ticket per wmayer's suggestion

Issue History

Date Modified Username Field Change
2018-02-07 07:20 stunts1990 New Issue
2018-02-07 07:20 stunts1990 File Added: bug1.PNG
2018-02-07 07:20 stunts1990 Tag Attached: Draft
2018-02-07 16:05 Kunda1 Tag Attached: undo
2018-02-07 16:22 Kunda1 Note Added: 0010929
2018-02-07 16:22 Kunda1 Note Edited: 0010929 View Revisions
2018-02-07 16:23 Kunda1 Product Version 0.18 => 0.17
2018-02-08 00:25 user2853 Note Added: 0010930
2018-05-31 17:38 Kunda1 Status new => feedback
2018-05-31 17:38 Kunda1 Note Added: 0011338
2018-06-07 16:51 Kunda1 Note Added: 0011359
2018-08-01 02:59 Kunda1 Note Added: 0011573
2018-08-08 20:14 Kunda1 Note Added: 0011609
2018-08-08 20:41 Kunda1 Note Added: 0011611
2018-10-04 07:43 wmayer Note Added: 0011911
2018-10-17 20:38 Kunda1 Note Added: 0012056
2018-10-17 20:39 Kunda1 Status feedback => resolved
2018-10-17 20:39 Kunda1 Resolution open => fixed
2018-10-17 20:39 Kunda1 Note Added: 0012057
2018-11-09 00:26 Kunda1 Status resolved => closed
2018-11-09 00:26 Kunda1 Note Added: 0012157