View Issue Details

IDProjectCategoryView StatusLast Update
0003082ArchBugpublic2018-08-26 15:21
Reporterwolfcastle Assigned Toyorik  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.01
Product Version0.16 
Target VersionFixed in Version0.17 
Summary0003082: Arch CutPlane - Error: tuple index out of range
DescriptionI have a slight problem with Arch CutPlane, I just wasted 4 hours getting it to work, but to no avail. I tried installing FreeCAD on two more machines, one of them being a 32 bit ubuntu 17.04. The problem persists now on all three machines.

In the attached drawing, when I select in the following order "axle" then "Rectangle001", and follow the instructions here https://www.freecadweb.org/wiki/Arch_CutPlane I get this error:

Traceback (most recent call last):
File "/usr/lib/freecad/Mod/Arch/ArchCutPlane.py", line 109, in previewCutVolume
cutVolume = ArchCommands.getCutVolume(FreeCADGui.Selection.getSelectionEx()[1].SubObjects[0], FreeCADGui.Selection.getSelectionEx()[0].Object.Shape)
IndexError: tuple index out of range
Running the Python command 'Arch_CutPlane' failed:
Traceback (most recent call last):
File "/usr/lib/freecad/Mod/Arch/ArchCutPlane.py", line 69, in Activated
panel=_CutPlaneTaskPanel()
File "/usr/lib/freecad/Mod/Arch/ArchCutPlane.py", line 88, in __init__
self.previewCutVolume(self.combobox.currentIndex())
File "/usr/lib/freecad/Mod/Arch/ArchCutPlane.py", line 109, in previewCutVolume
cutVolume = ArchCommands.getCutVolume(FreeCADGui.Selection.getSelectionEx()[1].SubObjects[0], FreeCADGui.Selection.getSelectionEx()[0].Object.Shape)
Steps To ReproduceIn the attached drawing, when I select in the following order "axle" then "Rectangle001", and follow the instructions here https://www.freecadweb.org/wiki/Arch_CutPlane the error occurs.
Additional InformationOS: Ubuntu 16.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6710 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: f8eca0f9311f07c125dd6742a607724c1fa0b77c
Python version: 2.7.12+
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Forum Thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=22933&p=178039
TagsArch
FreeCAD Information

Activities

wolfcastle

2017-06-14 13:45

reporter  

sample_1.fcstd (6,927 bytes)

Kunda1

2017-06-14 18:11

administrator   ~0009372

@wolfcastle please also associate the appropriate forum thread with this ticket. Thanks.

Kunda1

2017-06-14 18:31

administrator   ~0009374

Looks like @bejant can't reproduce your issue. Need more testers.

wolfcastle

2017-06-14 19:04

reporter   ~0009375

@kunda1,

As I mentioned in my edit: I can now reproduce the issue on 3 different machines, two Ubuntu 16.04 64bit and one Ubuntu 17.01 32 bit

So either I don't have the mental capacity (times three) to make a CutPlane, or there is something seriously wrong.

Kunda1

2017-06-15 11:57

administrator   ~0009376

@wolfcastle Hehe, sorry just trying to cut down on tracker bloat. I changed the status to confirmed, so no worries ;)

wolfcastle

2017-06-15 12:11

reporter   ~0009379

@kunda1 Pheeew, that takes a load of my chest ;-)

BTW the Ubuntu 17.01 32 bit was a fresh install on a VBox

user2853

2017-06-15 20:44

  ~0009390

Last edited: 2017-06-15 20:46

View 2 revisions

I can reproduce exactly (including the empty "PreviewCutVolume" shape being added to the tree, in
OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6706 (Git)
Build type: Release
Branch: releases/FreeCAD-0-16
Hash: f86a4e411ff7848dea98d7242f43b7774bee8fa0
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
The key is to select Rectangle001 in the tree. It works if you select a face of Rectangle001 in the 3D view. The tool becomes in-active if you Double click on the Rectangle001 face in 3D view (thus selecting to whole object)

In
OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11284 (Git)
Build type: Release
Branch: master
Hash: 1854d3de696cc51c769d82f19d7d2fb1e0ce787e
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0

Selecting Rectanle001 in the tree and running the command gives this error:
You must select a face from the second object (cut plane), not the whole object

So I think this is fixed in 0.17 but the documentation on the wiki needs to be updated to state that the cut plane face must be selected in the 3D view.
I'll try to do this this weekend.

Kunda1

2017-08-14 00:20

administrator   ~0009924

@sgrogan1 have the docs been updated?

user2853

2017-08-14 21:48

  ~0009936

It is now. I thought I'd already done this. Still feels like there is a UI improvement here but I don't have a suggestion.

Kunda1

2017-08-14 23:18

administrator   ~0009937

@yorik any ideas?

Kunda1

2017-08-17 02:01

administrator   ~0009939

yorik committed fix in https://github.com/FreeCAD/FreeCAD/commit/0adf582b1
c:FreeCAD:0adf582b1:

Issue History

Date Modified Username Field Change
2017-06-14 13:45 wolfcastle New Issue
2017-06-14 13:45 wolfcastle File Added: sample_1.fcstd
2017-06-14 13:45 wolfcastle Tag Attached: Arch
2017-06-14 18:11 Kunda1 Note Added: 0009372
2017-06-14 18:29 Kunda1 Additional Information Updated View Revisions
2017-06-14 18:31 Kunda1 Note Added: 0009374
2017-06-14 18:50 Kunda1 Tag Attached: #tobeclosed
2017-06-14 19:04 wolfcastle Note Added: 0009375
2017-06-15 11:53 Kunda1 Tag Detached: #tobeclosed
2017-06-15 11:57 Kunda1 Status new => confirmed
2017-06-15 11:57 Kunda1 Note Added: 0009376
2017-06-15 12:11 wolfcastle Note Added: 0009379
2017-06-15 20:44 user2853 Note Added: 0009390
2017-06-15 20:46 user2853 Note Edited: 0009390 View Revisions
2017-07-03 12:09 Kunda1 Tag Attached: #pending
2017-08-14 00:20 Kunda1 Note Added: 0009924
2017-08-14 21:48 user2853 Note Added: 0009936
2017-08-14 23:18 Kunda1 Note Added: 0009937
2017-08-17 02:01 Kunda1 Assigned To => yorik
2017-08-17 02:01 Kunda1 Status confirmed => resolved
2017-08-17 02:01 Kunda1 Resolution open => fixed
2017-08-17 02:01 Kunda1 Fixed in Version => 0.17
2017-08-17 02:01 Kunda1 Note Added: 0009939
2017-08-17 13:50 yorik Status resolved => closed
2018-08-26 15:21 Kunda1 Tag Detached: #pending