View Issue Details

IDProjectCategoryView StatusLast Update
0002846Project Tools & Websites[FreeCAD] Featurepublic2017-03-06 19:46
ReporterKunda1 Assigned Tokkremitzki  
PrioritynoneSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0002846: MantisBT Proposal: Default template for bug reports
DescriptionBelow is the text that I'm proposing would be available in every bug report page (http://freecadweb.org/tracker/bug_report_page.php). See attached screenshot of proposal. What I'm hoping is possible is that the default text could be placeholder text that will disappear once the user starts typing in the text field to enter their information. Here is an example of how to add placeholder text to a
<textarea>
(http://stackoverflow.com/questions/4168902/html-textarea-placeholder#10199101)
---------------------------------
Explain the details of the bug/feature/patch. Make sure to explain what you were doing when it happened. What you expected to happen. And what actually was the result.
Steps To ReproducePlease produce a step-by-step list (as detailed as possible) to help the devs and testers to reproduce your issue.
Ex.
1. Launch FreeCAD
2. Open Sketcher through the dropdown
3. Open a New Document: File > New
4. etc...
Result: Summarize the result you are seeing happening in FreeCAD
Additional InformationPlease paste the contents of Help > About Freecad > "Copy to clipboard"

If you are running a 'debug release' you can also publish a debugging backtrace. Please see: http://www.freecadweb.org/wiki/Debugging

If you have a file to share that is larger then what the FreeCAD bugtracker allows, you can upload the file to a cloud-based 3rd party service (like owncloud, dropbox etc...) and paste the link here.
Tagsbugtracker, webapps

Relationships

parent of 0002881 closedkkremitzki MantisBT refinements 
related to 0002470 closedkkremitzki MantisBT needs tables converted to UTF8 

Activities

Kunda1

2017-01-12 19:58

administrator  

Kunda1

2017-01-12 20:00

administrator   ~0007682

We could also mention somewhere in all this the @yorik forum thread on Bug submission guidelines http://forum.freecadweb.org/viewtopic.php?f=3&t=5236

yorik

2017-01-12 22:32

administrator   ~0007688

The problem is that this requires to modify the mantis source code... Which I'm not very keen to do because then everytime we upgrade, I have to make the changes again. But let's see how it goes with mantis2 first, maybe there are better customization options...

Kunda1

2017-01-12 23:33

administrator   ~0007692

> The problem is that this requires to modify the mantis source code... Which I'm not very keen to do because then everytime we upgrade, I have to make the changes again.

Understood. If that's the case, I'll open a ticket on MantisBT and see what they say.

Kunda1

2017-01-12 23:41

administrator   ~0007693

Upstream ticket: http://mantisbt.org/bugs/view.php?id=22187

yorik

2017-01-13 01:20

administrator   ~0007701

You're becoming the tracker master :)
This was a good occasion to have a look at the new mantis... Much better! I liked the "timeline" that is now on the "my view" page...

Kunda1

2017-01-13 01:30

administrator   ~0007703

Last edited: 2017-01-13 01:31

View 2 revisions

LOL.
Cool, yea I like the timeline as well! It shows tracker activity which is something I think is important for a tracker to have. It's taking MantisBT ages to get to where they are now. I think it's quite a departure from the low-tech 1.3.x UI and it feels ... well it's growing on me... nevertheless, I think they're going in the right direction. Especially with the file drag and drop interface and easier to view bug attachment files.

Kunda1

2017-01-13 20:32

administrator   ~0007727

Last edited: 2017-01-14 12:49

View 2 revisions

Apparently the upstream ticket is a dupe of http://mantisbt.org/bugs/view.php?id=14695
Edit: Upstream ticket re-opened since it wasn't a dupe but only related.

Kunda1

2017-01-14 22:27

administrator   ~0007772

@yorik mantisbt dev responded:
The way to achieve this is to have configuration opens that can be set in config_inc.php or the database (per project) that end up in the HTML place holder text, which provides the desired behavior automatically. Contributions via Github Pull Requests are welcome.

<shrug>

yorik

2017-01-14 22:35

administrator   ~0007773

Of course...

Kunda1

2017-01-16 19:49

administrator   ~0007821

Hopefully, this post for assistance on the forum[1] will call in the cavalry?!

[1] http://forum.freecadweb.org/viewtopic.php?f=8&t=19955

kkremitzki

2017-03-02 04:29

administrator   ~0008492

implemented in: https://github.com/FreeCAD/Homepage/pull/7/commits/a9e69bbdc694b37603738c86f832be369b46bb34

should be active now. let me know what you think.

Kunda1

2017-03-02 13:40

administrator   ~0008516

Looks awesome except that latest FF does not see the newlines within the multi-line javascript (even though it should https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Template_literals)
I'll file an upstream ticket with Mozilla.
Thanks again kkremitzki!

Kunda1

2017-03-02 13:53

administrator   ~0008517

Upstream FF bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1343853

Kunda1

2017-03-06 19:46

administrator   ~0008548

Change of plan... the text is now in the table headers on the report page. See https://freecadweb.org/tracker/bug_report_page.php

Thanks to @kkremitzki in c:FreeCAD:61244bcb0e72d3b2e581b066555b64371e8bdd44:

Issue History

Date Modified Username Field Change
2017-01-12 19:58 Kunda1 New Issue
2017-01-12 19:58 Kunda1 File Added: FC-Mantis-Bug-Reporting-Template.png
2017-01-12 20:00 Kunda1 Note Added: 0007682
2017-01-12 20:02 Kunda1 Tag Attached: wiki
2017-01-12 20:07 Kunda1 Tag Detached: wiki
2017-01-12 20:07 Kunda1 Tag Attached: bugtracker
2017-01-12 22:32 yorik Note Added: 0007688
2017-01-12 23:33 Kunda1 Note Added: 0007692
2017-01-12 23:41 Kunda1 Note Added: 0007693
2017-01-13 01:20 yorik Note Added: 0007701
2017-01-13 01:30 Kunda1 Note Added: 0007703
2017-01-13 01:31 Kunda1 Note Edited: 0007703 View Revisions
2017-01-13 12:19 yorik Relationship added related to 0002470
2017-01-13 12:19 yorik Tag Attached: webapps
2017-01-13 20:32 Kunda1 Note Added: 0007727
2017-01-14 12:49 Kunda1 Note Edited: 0007727 View Revisions
2017-01-14 22:27 Kunda1 Note Added: 0007772
2017-01-14 22:35 yorik Note Added: 0007773
2017-01-16 19:49 Kunda1 Note Added: 0007821
2017-01-29 19:45 Kunda1 Issue cloned: 0002881
2017-01-29 19:45 Kunda1 Relationship added parent of 0002881
2017-01-29 19:46 Kunda1 Summary Proposal: Default template for bug reports => MantisBT Proposal: Default template for bug reports
2017-02-16 11:53 Kunda1 Assigned To => kkremitzki
2017-02-16 11:53 Kunda1 Status new => assigned
2017-02-16 11:54 Kunda1 Additional Information Updated View Revisions
2017-02-20 20:57 kkremitzki Project FreeCAD => Project Tools & Websites
2017-03-02 04:29 kkremitzki Assigned To kkremitzki => Kunda1
2017-03-02 04:29 kkremitzki Status assigned => feedback
2017-03-02 04:29 kkremitzki Note Added: 0008492
2017-03-02 13:40 Kunda1 Note Added: 0008516
2017-03-02 13:53 Kunda1 Note Added: 0008517
2017-03-02 16:20 Kunda1 Status feedback => assigned
2017-03-06 19:46 Kunda1 Note Added: 0008548
2017-03-06 19:46 Kunda1 Assigned To Kunda1 => kkremitzki
2017-03-06 19:46 Kunda1 Status assigned => closed
2017-03-06 19:46 Kunda1 Resolution open => fixed