View Issue Details

IDProjectCategoryView StatusLast Update
0002624DraftBugpublic2018-03-08 11:08
ReporterwandererfanAssigned Towandererfan 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformAllOSOS Version
Product Version0.17 
Target Version0.17Fixed in Version 
Summary0002624: Draft Patterns Not Installed
Descriptionsrc/Mod/Draft/Resources/patterns is not copied to build directory by Cmake.
Steps To Reproducebuild FreeCAD - no patterns!
Additional Informationhttp://www.forum.freecadweb.org/viewtopic.php?f=9&t=16516&start=10#p130899
Tagspackaging

Activities

yorik

2016-07-15 00:46

administrator   ~0007191

They are actually part from the Draft_rc.py resource... So they are not meant to be installed. But that can change if needed of course.
Also, the idea is to abandon them and start using the DrawingPatterns module I started to develop in Drawing.

Kunda1

2017-03-24 15:16

administrator   ~0008697

@yorik since Drawing WB is planned to be deprecated.. should this move to TechDraw ?

yorik

2017-03-24 16:06

administrator   ~0008700

It doesn't really depends on any of them, so it doesn't matter i guess... It's more a packaging question

Kunda1

2017-05-10 13:24

administrator   ~0008936

@sgrogan I'd comment to the forum but the thread was locked. What's your take on this?

Kunda1

2017-11-28 04:45

administrator   ~0010490

@sgrogan1 ping

user2853

2018-01-02 22:43

  ~0010678

Wow, I just saw this now, sorry. I think it's a CMake question. These patterns were designed to be used from the Draft resource file, the DrawingPatterns are probably deprecated by PAT support in TechDraw? I could hack around this on Win and maybe Ubuntu, but not OSX.

If TechDraw can use these files, we should use CMake to copy them from the Draft sources to the TechDraw build and then install them.
@yorik
@wandererfan

wandererfan

2018-01-03 15:16

developer   ~0010685

TechDraw can still use SVG patterns as fill, so not really deprecated. Draft will still only be able to use the ones in the Resource file?

user2853

2018-01-03 21:10

  ~0010689

Yes, Draft/Drawing uses the resource file so they are "baked in". I have no idea if TechDraw can use the resources, but with CMake we could copy and install the files from the sources into the TechDraw/data directory. By deprecated I mean I think @yorik abandoned the DrawingPatterns module development. If I understand, PAT support in TechDraw accomplishes the same thing.

I'm not suggesting to remove .svg support, I'm an Inkscape fan, I'm just not sure how to handle it.

wandererfan

2018-01-05 00:12

developer   ~0010705

PAT does something similar, but SVG can make more complicated patterns.

I vote for copying source to data directory. Otherwise we need to rebuild a resource file to add new patterns.

yorik

2018-01-05 20:08

administrator   ~0010711

SVG patterns are more powerful than PAT, they can do a lot more than just drawing lines, you can virtually reuse any SVG fragment as a pattern. But the main problem is the lack of support for SVG in QT. There was some hope that QT5 would bring decent support but it didn't happen, so the DrawingPAtterns modules laid a bit abandonned...

I wouldn't discard SVG patterns idea, because they are really cool... But at the moment the PAT system in TD works much better.

About the svg files in Draft, TBH I hahve no good idea of what to do with them just yet. Maybe it's a good time to think a kind of universal, FreeCAD-wide pattern support structure?

user2853

2018-01-05 22:16

  ~0010720

@yorik, what do you think about just copying the .svg's to data/Mod/TechDraw with CMake as an intermediate solution, so they can be used by TechDraw. I think most of us that use them do it this way.

yorik

2018-01-06 22:33

administrator   ~0010725

@sgrogan1 yes this seems good for now, after that I can make Draft use that instead of the resource (no need to have both)

wmayer

2018-03-08 11:08

administrator   ~0011019

https://github.com/FreeCAD/FreeCAD/commit/be3b4d88814f1cc789f3401384e2937cbb8631a9

Issue History

Date Modified Username Field Change
2016-07-14 13:50 wandererfan New Issue
2016-07-14 13:50 wandererfan Status new => assigned
2016-07-14 13:50 wandererfan Assigned To => sgrogan
2016-07-15 00:46 yorik Note Added: 0007191
2017-03-24 15:16 Kunda1 Note Added: 0008697
2017-03-24 16:06 yorik Note Added: 0008700
2017-03-24 16:17 Kunda1 Tag Attached: packaging
2017-05-10 13:24 Kunda1 Note Added: 0008936
2017-11-28 04:45 Kunda1 Note Added: 0010490
2017-12-02 17:09 wmayer Project FreeCAD => Draft
2018-01-02 22:43 user2853 Note Added: 0010678
2018-01-03 15:16 wandererfan Note Added: 0010685
2018-01-03 21:10 user2853 Note Added: 0010689
2018-01-05 00:12 wandererfan Note Added: 0010705
2018-01-05 20:08 yorik Note Added: 0010711
2018-01-05 22:16 user2853 Note Added: 0010720
2018-01-06 22:33 yorik Note Added: 0010725
2018-03-08 11:08 wmayer Assigned To sgrogan => wandererfan
2018-03-08 11:08 wmayer Status assigned => closed
2018-03-08 11:08 wmayer Resolution open => fixed
2018-03-08 11:08 wmayer Note Added: 0011019