View Issue Details

IDProjectCategoryView StatusLast Update
0002383DrawingBugpublic2017-04-28 12:13
Reporteryanncad Assigned Toyorik  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.15 
Target VersionFixed in Version 
Summary0002383: Drawing lines missing or incorrect
DescriptionIn drawings created with default options of FreeCAD ("Show hidden lines"=False),
   - some lines are missing
   - some lines appear when they should be hidden

See attached example. In the attached screenshot, I highlighted in yellow zones where lines are incorrect or missing.

I know the drawing workbench is still in dev, but this is my main blocker for a production use of FreeCAD.
Steps To Reproduce1. create a part with medium complexity (with holes, curved shapes...)
2. make a drawing of it
3. observe the missing lines and/or incorrect lines
Additional InformationKeep up the good work with FreeCAD!
TagsOCC 7.1, OCC Bug, upstream

Relationships

related to 0001612 closedyorik Draft Projecting arcs to SVG gives wrong results under certain angles 
related to 0001697 closedyorik FreeCAD projection of edges fails 
related to 0002730 closedyorik FreeCAD Fillet are not showed in drawing 
related to 0002354 closedyorik Drawing Arcs missing in projections of revolved sketches 
child of 0001931 closedwmayer FreeCAD migration to OCCT 7.1 

Activities

appbannadee

2016-08-05 09:33

reporter   ~0007245

Last edited: 2016-08-05 09:34

View 2 revisions

i have got the same problem. Have you solve the problem?
please suggest me

wandererfan

2016-08-05 12:36

manager   ~0007249

Last edited: 2016-08-05 13:26

View 2 revisions

This is a duplicate of/related to: 0001612 and 0001697.

OCC bug report: https://tracker.dev.opencascade.org/view.php?id=25214

The only real fix is to use OCC 7.1 once it is available.

Sometimes rotating the part slightly before adding to the drawing helps. Sometimes it doesn't!

Kunda1

2017-01-09 22:22

administrator   ~0007589

OCC 7.1.0 has been available since Nov 25th 2016 (see https://www.opencascade.com/content/open-cascade-technology-710-available-download)

@wmayer seems this ticket is a child of 0001931

Kunda1

2017-01-27 01:58

administrator   ~0008009

Reminder sent to: yorik

@yorik please test with OCC 7.1

Kunda1

2017-01-30 13:47

administrator  

bug_highlight.PNG (105,448 bytes)
bug_highlight.PNG (105,448 bytes)

Kunda1

2017-01-30 13:47

administrator  

part1.FCStd (124,861 bytes)

Kunda1

2017-01-30 13:53

administrator   ~0008104

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20364

yorik

2017-01-30 15:19

administrator   ~0008106

Okay the problem is solved in OCC 7.1, all the edges marked on the image above appear correctly, and projecting shapes with no faces works. So I'm closing this issue...

Issue History

Date Modified Username Field Change
2015-12-30 14:24 yanncad New Issue
2015-12-30 14:24 yanncad File Added: bug_drawing.zip
2016-08-05 09:33 appbannadee Note Added: 0007245
2016-08-05 09:34 appbannadee Note Edited: 0007245 View Revisions
2016-08-05 12:36 wandererfan Note Added: 0007249
2016-08-05 13:26 wandererfan Note Edited: 0007249 View Revisions
2016-08-05 13:27 wandererfan Status new => feedback
2016-08-05 13:27 wandererfan Relationship added related to 0001612
2016-08-05 13:28 wandererfan Relationship added related to 0001697
2016-10-08 13:00 wandererfan Relationship added related to 0002730
2017-01-09 22:18 Kunda1 Tag Attached: OCC Bug
2017-01-09 22:18 Kunda1 Tag Attached: upstream
2017-01-09 22:22 Kunda1 Note Added: 0007589
2017-01-11 20:39 Kunda1 Relationship added child of 0001931
2017-01-14 01:17 Kunda1 Relationship added related to 0002354
2017-01-27 01:30 Kunda1 Tag Attached: OCC 7.1
2017-01-27 01:58 Kunda1 Note Added: 0008009
2017-01-27 01:59 Kunda1 Tag Attached: #pending
2017-01-27 01:59 Kunda1 Tag Attached: #tobeclosed
2017-01-30 13:47 Kunda1 File Added: bug_highlight.PNG
2017-01-30 13:47 Kunda1 File Added: part1.FCStd
2017-01-30 13:47 Kunda1 File Deleted: bug_drawing.zip
2017-01-30 13:47 Kunda1 Tag Attached: duplicate
2017-01-30 13:53 Kunda1 Note Added: 0008104
2017-01-30 15:19 yorik Note Added: 0008106
2017-01-30 15:20 yorik Status feedback => closed
2017-01-30 15:20 yorik Assigned To => yorik
2017-01-30 15:20 yorik Resolution open => fixed
2017-01-30 15:20 yorik Fixed in Version => 0.17
2017-01-30 15:44 Kunda1 Tag Detached: #pending
2017-01-30 15:44 Kunda1 Tag Detached: duplicate
2017-04-28 12:13 Kunda1 Tag Detached: #tobeclosed