View Issue Details

IDProjectCategoryView StatusLast Update
0002357FreeCADBugpublic2015-12-15 13:15
Reporterpeterl94Assigned Toian.rees 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformOSMac OS XOS Version10.10
Product Version 
Target VersionFixed in Version0.16 
Summary0002357: Creating bspline crashes FreeCAD on OS X
DescriptionSee http://forum.freecadweb.org/viewtopic.php?f=10&t=13468
and http://forum.freecadweb.org/viewtopic.php?f=9&t=13445

As far as I know, this is only an issue on OS X.

All I had to do to get the crash was go to the draft workbench start the bspline tool and pick the first point.

Attached is a back trace and breakpoint steps.
TagsNo tags attached.

Activities

peterl94

2015-12-10 02:12

developer  

gdb_session.txt (Attachment missing)

ian.rees

2015-12-14 09:11

developer   ~0006603

On a machine where I can reliably reproduce this crash (OSX 10.10, Xcode 7.2, Homebrew - will try to update details tomorrow), I tried making a build off commit 6cd92200 (same to the currently-last build uploaded by Peter, which doesn't exhibit this problem). My build had the BSpline bug.

Along the same lines, my home machine (details below, same OS and SDK as above but MacPorts) doesn't exhibit this problem even with the latest-and-greatest FreeCAD source. So, I think there's a change somewhere outside FreeCAD that's causing the problem

Home computer, no BSpline crash on current FreeCAD source:
OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6039 +1 (Git)
Build type: Debug
Branch: 20151212-export-amf
Hash: a7ebc6b92636850dcf5d6afb9a651efa0b30ba88
Python version: 2.7.11
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 6.8.0.oce-0.17

peterl94

2015-12-14 10:45

developer   ~0006604

Yeah, I created this issue too soon. This is not a FreeCAD bug, please close.

It has been fixed in OCCT master, and will be in the next release after 6.9.1

See http://tracker.dev.opencascade.org//view.php?id=26042

ian.rees

2015-12-14 19:33

developer   ~0006606

Good spotting on the OCC forum, that 7.0 release sounds like it'll be a good improvement!

For posterity: The issue is a combination of some code in OCC <= 6.9.1 and the newer Mac compilers. Fix is currently to build OCC using Xcode <7.

ian.rees

2015-12-14 19:33

developer   ~0006607

Bug is in OCC, not FreeCAD.

Issue History

Date Modified Username Field Change
2015-12-10 02:12 peterl94 New Issue
2015-12-10 02:12 peterl94 File Added: gdb_session.txt
2015-12-14 09:11 ian.rees Note Added: 0006603
2015-12-14 10:45 peterl94 Note Added: 0006604
2015-12-14 19:33 ian.rees Note Added: 0006606
2015-12-14 19:33 ian.rees Note Added: 0006607
2015-12-14 19:33 ian.rees Status new => closed
2015-12-14 19:33 ian.rees Assigned To => ian.rees
2015-12-14 19:33 ian.rees Resolution open => no change required
2015-12-15 13:15 yorik Fixed in Version => 0.16