View Issue Details

IDProjectCategoryView StatusLast Update
0001880DrawingFeaturepublic2017-02-07 13:23
Reportertriplus Assigned Towandererfan  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04
Product Version 
Target VersionFixed in Version 
Summary0001880: Show/hide drawing template structure
DescriptionAdditional blank set of standard drawing template sizes would not be needed if drawing template could be made in a way its structure could be turned on/off with drawing page property.

I did some quick experiments and for example adding style attribute visibility to drawing template can control individual SVG element visibility in QtSvg viewer. Custom code/tags could be alternative approach.
Additional InformationOrthographic projection tool probably should not use working space and title block information if drawing template structure would be set to off.

http://www.freecadweb.org/wiki/index.php?title=Drawing_templates
TagsNo tags attached.

Activities

triplus

2015-01-11 21:01

developer   ~0005617

Last edited: 2015-01-11 21:04

View 2 revisions

Some additional notes for future reference.

With QtSvg were DOM manipulation is not supported checking elementExists and deciding to show/hide its structure would probably be the way to do it:

http://doc-snapshot.qt-project.org/qt5-nosubdir/qsvgrenderer.html#elementExists
http://qt-project.org/forums/viewthread/19826

There could be a set of SVG ids FreeCAD would recognize if set in drawing template and a GUI tool/property editor to turn them on/off from inside FreeCAD. For example defining id:

freecad-drawing-border
freecad-titleblock

Note that there is an issue of pre-set working space/title block tags information left that does not change dynamically and its used by DW orthographic projection tool. After working on drawing templates i had a thought:

http://www.freecadweb.org/tracker/view.php?id=1856

Id for:

freecad-logo
freecad-projection

Would be quite nice. Default templates could have FreeCAD logo and symbols to define if a projection is either Third Angle (right) or First Angle (left) in it and user (or orthographic projection tool) could easily turn it on/off. The reason i didn't add FreeCAD logo or projection symbol to default set of ISO7200 templates was because user can't control (visibility) it from inside FreeCAD.

triplus

2015-01-11 21:23

developer   ~0005619

"Note that there is an issue of pre-set working space/title block tags information left that does not change dynamically and its used by DW orthographic projection tool."

http://www.freecadweb.org/wiki/index.php?title=Drawing_templates

Well probably "quite easy" to solve.

freecad-titleblock set to off -> DW orthographic projection tool shouldn't use <!-- Title block X1a Y1a X2a Y2a --> tag.

freecad-drawing-border set to off -> DW orthographic projection tool shouldn't use <!-- Working space X1 Y1 X2 Y2 --> tag.

ATM that would translate to having 5 to 6 blank A size drawing templates less in drop down menu.

triplus

2015-01-11 23:54

developer   ~0005625

Last edited: 2015-01-12 00:01

View 2 revisions

"freecad-drawing-border set to off -> DW orthographic projection tool shouldn't use <!-- Working space X1 Y1 X2 Y2 --> tag."

Well not quite true.

For optimal DW orthographic projection tool experience working space tag needs to be declared.

If it isn't declared (at least at the moment) DW orthographic projection tool doesn't automatically take the whole page width/height in the consideration instead it uses some pre-set values.

Maybe it could be extended like this:

<!-- Working space PW PH X1 Y1 X2 Y2 -->

PW = page width
PH = page hight

And if freecad-drawing-border is set to off -> DW orthographic projection tool should use PW and PH information if set to ON then X1 Y1 X2 Y2 information is used instead.

Kunda1

2017-02-01 23:09

administrator   ~0008153

@Jee-Bee writes in https://forum.freecadweb.org/viewtopic.php?f=10&t=20342&start=10#p157428
> In Pro-E i used this for sending drawings to laser cutting companies. where the last page was an 1:1 model without paper so they can use it as dxf

@Wandererfan responds:
> So this is about dxf (or svg,pdf,...) export, not display on screen or print out? That makes some sense.

Related Changesets

FreeCAD: master 18cd5b51

2017-02-02 01:30:56

WandererFan


Committer: Yorik van Havre Details Diff
Feature Request 1880 - hide Template Affected Issues
0001880
mod - src/Mod/TechDraw/Gui/QGISVGTemplate.cpp Diff File
mod - src/Mod/TechDraw/Gui/QGVPage.cpp Diff File
mod - src/Mod/TechDraw/Gui/ViewProviderDrawingView.cpp Diff File
mod - src/Mod/TechDraw/Gui/ViewProviderTemplate.cpp Diff File
mod - src/Mod/TechDraw/Gui/ViewProviderTemplate.h Diff File

Issue History

Date Modified Username Field Change
2014-12-28 18:40 triplus New Issue
2015-01-11 21:01 triplus Note Added: 0005617
2015-01-11 21:04 triplus Note Edited: 0005617 View Revisions
2015-01-11 21:23 triplus Note Added: 0005619
2015-01-11 23:54 triplus Note Added: 0005625
2015-01-12 00:01 triplus Note Edited: 0005625 View Revisions
2017-02-01 23:09 Kunda1 Note Added: 0008153
2017-02-07 13:22 wmayer Changeset attached => FreeCAD Master master 18cd5b51
2017-02-07 13:23 wmayer Status new => closed
2017-02-07 13:23 wmayer Assigned To => wandererfan
2017-02-07 13:23 wmayer Resolution open => fixed
2017-02-07 13:23 wmayer Fixed in Version => 0.17