View Issue Details

IDProjectCategoryView StatusLast Update
0001867DrawingFeaturepublic2017-03-27 17:30
Reportertriplus Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
PlatformLinuxOSUbuntuOS Version14.04
Product Version 
Target VersionFixed in Version 
Summary0001867: Use QtWebKit (QWebView) instead of QtSvg for DW drawing area
DescriptionECMA scripts and DOM manipulation would be possible/supported? Adding interactive support to DW drawing area would become quite easy?

What would be the obvious shortcomings? Has this ever been attempted before?

P.S. I know it was in a way decided to move away from SVG in "next" DW but would it be possible to reuse the work Luke did on adding support to "update" drawing when object is modified (back-end) and use QtWebKit (QWebView) for displaying the result and achieve interactive behaviour (front end). The reason i am asking this is i started using Drawing Dimensioning WB:

https://github.com/hamish2014/FreeCAD_drawing_dimensioning

And it is quite interactive with current DW. Using QtWebKit would make this easier?

Anyway Drawing Dimensioning WB:

- No parametric updating, if the drawing is updated the dimensions need to be redone

This is what Luke tackled in his DW and from this feature request point of view i was wondering if it would make sense and it would be possible to combine best of both worlds. Combine improved back-end from "next" DW with more capable SVG front-end QtWebKit.
TagsQt, Qt5

Relationships

child of 0002986 closedwmayer FreeCAD Port from Qt4 to Qt5 (Ongoing) 

Activities

yorik

2014-12-21 03:31

administrator   ~0005413

As far as I know, Luke's work uses heavily QtSVG. I don't know how easy it would be to adapt to QWebkit...

triplus

2015-04-24 10:27

developer   ~0006080

Last edited: 2015-04-24 10:29

View 2 revisions

Heads up for any future planing regarding using web stack provided by Qt in FreeCAD:

http://lists.qt-project.org/pipermail/development/2015-February/019893.html

ATM it looks like QtWebKit will probably be replaced by QtWebEngine:

https://wiki.qt.io/QtWebEngine

ATM distributions like Fedora or Debian are not willing to provide QtWebEngine by default:

http://www.phoronix.com/scan.php?page=news_item&px=QtWebEngine-Mess-Debian

Nothing is set in stone and i am sure mayor issues will be sorted out over time but in the future FreeCAD will use whatever Qt will provide at that time and it looks like QtWebKit won't be provided by Qt anymore.

Kunda1

2017-01-12 16:54

administrator   ~0007676

qtwebengine is available in Debian https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=832420;msg=46 as of 8-Jan-2017

Kunda1

2017-02-01 22:54

administrator   ~0008149

@yorik authorized closing this ticket in https://forum.freecadweb.org/viewtopic.php?f=10&t=20342#p157016

Issue History

Date Modified Username Field Change
2014-12-20 23:18 triplus New Issue
2014-12-21 03:31 yorik Note Added: 0005413
2015-04-24 10:27 triplus Note Added: 0006080
2015-04-24 10:29 triplus Note Edited: 0006080 View Revisions
2017-01-12 16:54 Kunda1 Note Added: 0007676
2017-01-24 15:33 Kunda1 Tag Attached: Qt
2017-01-24 15:33 Kunda1 Tag Attached: Qt5
2017-02-01 22:54 Kunda1 Note Added: 0008149
2017-02-01 22:54 Kunda1 Status new => closed
2017-02-01 22:54 Kunda1 Resolution open => won't fix
2017-03-27 17:30 Kunda1 Relationship added child of 0002986