View Issue Details

IDProjectCategoryView StatusLast Update
0001822DrawingBugpublic2017-08-21 06:17
Reporterlanciaux Assigned To 
PriorityhighSeverityminorReproducibilityunable to reproduce
Status closedResolutionno change required 
Product Version0.14 
Target VersionFixed in Version 
Summary0001822: Scale factor property in drawing page limited to one digit (sometime two)
DescriptionWhen I try to make a 2D sketch with measurements in 'Drawing Mod' I am often obliged to review all automatic scales of projected page views in additions of the ones in measurements because I am limited to 1 digit (sometimes 2 digits but I do not have found why).
Steps To ReproduceWhen you choose "insert orthogonal projection" you are faced in bottom dialog with a scale factor you could setup with as many digits you want (eg. 0,245) but after command got finished - every projected view in page is limited to a one digit scale factor (real 0,245 was applied but you read 0,2).

So you take your measurements and set scale factor to 0,2 ... which give bad projection ... it should have allowed all time me to set scale to 0,245000 (for example) !

Additional InformationIf this property was directly linked to preference draft "internal precision digits", I could understand but mine is '3'.

Scale factors should have their own "internal precision digits" because when setting up a 2D sketch from something having several meters ... how will you do ?


Tagsunits

Relationships

related to 0002866 closed FreeCAD Gui::InputField rounds values to 2 digits 
related to 0001688 closed Drawing Orthographic projection uses more digits behind decimal point for scale than shown in properties 

Activities

shoogen

2014-11-10 19:00

developer   ~0005302

> Scale factors should have their own "internal precision digits" because when setting up a 2D sketch from something having several meters.
If the relation of the size of the drawing and the size of the model is arbitrary, we should even allow to use the scientific notation or fractions.

wmayer

2014-12-04 12:55

administrator   ~0005356

The number of decimals can be set in the preferences under General > Units.

wmayer

2017-08-21 06:17

administrator   ~0009971

It's just a matter of setting the needed number of decimals in the settings.

Issue History

Date Modified Username Field Change
2014-11-10 18:07 lanciaux New Issue
2014-11-10 19:00 shoogen Note Added: 0005302
2014-12-04 12:55 wmayer Note Added: 0005356
2015-01-12 12:25 wmayer Relationship added related to 0001688
2015-01-12 12:25 wmayer Project FreeCAD => Drawing
2017-01-24 15:05 Kunda1 Tag Attached: units
2017-05-02 11:10 Kunda1 Relationship added related to 0002866
2017-08-21 06:17 wmayer Status new => closed
2017-08-21 06:17 wmayer Resolution open => no change required
2017-08-21 06:17 wmayer Note Added: 0009971