View Issue Details

IDProjectCategoryView StatusLast Update
0001688DrawingBugpublic2018-09-16 11:37
Reportermghansen256 Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
PlatformLinuxOSKubuntuOS Version14.04
Product Version0.14 
Target VersionFixed in Version 
Summary0001688: Orthographic projection uses more digits behind decimal point for scale than shown in properties
DescriptionAuto scale in orthographic projections uses more digits behind the decimal point than are shown and editable. Thus when copying these to other objects added to the drawing, they are not scaled and aligned correctly.
Steps To Reproduce1. Create a big part with a size of 528 mm.
2. Create a drawing sheet of A4 size.
3. Add an orthographic projection of the part, such that the long side of it is shown on the drawing. Auto scale should be around 0.37.
4. Add a dimension to the part and add that to the drawing.
5. Adjust position, rotation and scale of the dimension on the drawing as for the part, they may not align properly.
6. Manually change the scale of the orthographic projection to 0.38, and that of the dimension to 0.38, too. Now they align.
Additional InformationOS: Ubuntu 14.04.1 LTS
Word size: 64-bit
Version: 0.15.3875 (Git) <-- note that the 3875 may be incorrect since I have merges in my local checkout.
Branch: master
Hash: 259de90afe5293ba4d0524e98d9462a6b59bca22
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.7.0
Tagsunits

Relationships

related to 0001822 closed Scale factor property in drawing page limited to one digit (sometime two) 

Activities

mghansen256

2014-08-14 19:40

reporter   ~0004946

To be more accurate, auto scale will set 0.375 as scaling, but I can not enter that in the properties for the dimension.

shoogen

2014-08-15 07:52

developer   ~0004949

if you are using a version which is not publicly available you could use the command "merge-base HEAD origin/master" to get the hash
and "git rev-list --count `merge-base HEAD origin/master`" to obtain the version number before diverting from the blessed master.

Kunda1

2017-02-09 12:14

administrator   ~0008252

According to @wandererfan in https://forum.freecadweb.org/viewtopic.php?f=10&t=20342#p157399
> TechDraw uses global decimals setting
Context: TechDraw WB is the successor to the soon-to-be deprecated Drawing WB

Kunda1

2017-07-16 11:42

administrator   ~0009764

@wandererfan what's the fate of this ticket?

wandererfan

2017-07-18 15:58

manager   ~0009774

Drawing is still in the distribution, so I would say it stays as is.

wandererfan

2018-09-16 11:37

manager   ~0011752

Functionality available in TechDraw

Issue History

Date Modified Username Field Change
2014-08-14 18:45 mghansen256 New Issue
2014-08-14 19:40 mghansen256 Note Added: 0004946
2014-08-15 07:52 shoogen Note Added: 0004949
2015-01-12 12:25 wmayer Relationship added related to 0001822
2017-01-24 15:05 Kunda1 Tag Attached: units
2017-02-09 12:14 Kunda1 Note Added: 0008252
2017-07-16 11:42 Kunda1 Note Added: 0009764
2017-07-18 15:58 wandererfan Note Added: 0009774
2018-09-16 11:37 wandererfan Status new => closed
2018-09-16 11:37 wandererfan Resolution open => won't fix
2018-09-16 11:37 wandererfan Note Added: 0011752