View Issue Details

IDProjectCategoryView StatusLast Update
0000143TechDraw[All Projects] Generalpublic2017-01-30 08:54
Reporternormandc Assigned Towandererfan  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version[FreeCAD] 0.17 
Summary0000143: Allow moving of views graphically on the page
Descriptionallow moving of views graphically on the page by clicking on some kind of view borders (borders to "appear" when cursor overs them? or toggle on/off), vertical/horizontal align of views --> that I understand would be a major task and may not be seen for a long time

https://sourceforge.net/apps/phpbb/free-cad/viewtopic.php?f=3&t=510

Edit: https://forum.freecadweb.org/viewtopic.php?f=3&t=510
TagsNo tags attached.

Activities

Jriegel

2010-09-01 07:31

administrator   ~0000314

Would be a nice feature, but a lot of work....

Jriegel

2011-03-10 16:24

administrator   ~0000723

would be nice, but I have no time for it at the moment...

normandc

2016-07-18 14:58

manager   ~0007197

All things come to him who waits. :-D

This functionality is finally implemented in the new TechDraw workbench merged into 0.17. I suggest we wait for the official 0.17 release before closing this report...

yorik

2016-07-18 19:17

administrator   ~0007198

Last edited: 2016-07-18 19:17

View 2 revisions

As you wish, but usually we close bug reports when it's in master. So in my opinion we can close this one :)

6 years of waiting! :)

normandc

2016-07-18 19:19

manager   ~0007199

Last edited: 2016-07-18 19:20

View 2 revisions

Sure, but I was also waiting for a "TechDraw" project to be created before assigning this report to it rather than to "Drawing".

wandererfan has expressed the wish to wait some time (a week) before creating the project on Mantis and migrating the issues from Github.

Kunda1

2017-01-30 01:04

administrator   ~0008096

Resolving.
Ticket needs to mention which git commit this occurred in.
@wmayer please advise?

wmayer

2017-01-30 08:54

administrator   ~0008099

I don't know a specific commit. Also, I moved this ticket to TechDraw since it's implemented there and re-assigned it to wandererfan as he is the most active developer.

Issue History

Date Modified Username Field Change
2010-08-27 14:56 wmayer New Issue
2010-08-27 14:57 wmayer Reporter wmayer => normandc
2010-09-01 07:31 Jriegel Note Added: 0000314
2011-03-10 16:24 Jriegel Note Added: 0000723
2011-03-10 16:24 Jriegel Status new => acknowledged
2012-05-05 18:47 yorik Project FreeCAD => Drawing
2016-07-18 14:58 normandc Note Added: 0007197
2016-07-18 19:17 yorik Note Added: 0007198
2016-07-18 19:17 yorik Note Edited: 0007198 View Revisions
2016-07-18 19:19 normandc Note Added: 0007199
2016-07-18 19:20 normandc Note Edited: 0007199 View Revisions
2017-01-30 01:01 Kunda1 Description Updated View Revisions
2017-01-30 01:04 Kunda1 Note Added: 0008096
2017-01-30 01:04 Kunda1 Status acknowledged => resolved
2017-01-30 01:04 Kunda1 Fixed in Version => 0.17
2017-01-30 01:04 Kunda1 Resolution open => fixed
2017-01-30 01:04 Kunda1 Assigned To => Kunda1
2017-01-30 08:51 wmayer Project Drawing => TechDraw
2017-01-30 08:51 wmayer Category Feature => General
2017-01-30 08:54 wmayer Note Added: 0008099
2017-01-30 08:54 wmayer Status resolved => closed
2017-01-30 08:54 wmayer Assigned To Kunda1 => wandererfan