This page is a translated version of the page CompileOnWindows and the translation is 100% complete.

Cet article explique pas à pas comment compiler FreeCAD dans Windows.

A voir Compiler dans Windows avec Visual Studio 2013

Prérequis

Programmes requis

  • Git Il y a plusieurs solutions alternatives telles que GitCola, Tortoise Git, et d'autres.
  • CMake version 2.x.x or Cmake 3.x.x
  • Python >2.5 (Ceci n'est nécessaire que si vous n'utilisez pas le Libpack. Le Libpack est livré avec Python a partir de la version (2.7.x) et utilisé pour compiler et exécuter FreeCAD)

Code Source

De préférence utiliser Git

Pour créer une branche locale et télécharger le code source, vous devez ouvrir un terminal (invite de commande) et faites cd pour vous diriger vers le répertoire ou vous désirez placer le code source, puis tapez:

git clone https://github.com/FreeCAD/FreeCAD.git free-cad-code

Compiler

Sous Windows, le compilateur par défaut est M$ Visual Studio Express ou l'ensemble des versions 2008, 2012 ou 2013. Vous aurez aussi besoin d'installer la plate-forme Windows SDK pour obtenir les bibliothèques requises (par exemple windows.h), même si elles ne sont pas requises par les compilateurs (soit M$ Visual Studio Express ou autres).

Pour ceux qui ne veulent pas installer l'énorme Visual Studio uniquement pour avoir un compilateur, voir CompileOnWindows - Reducing Disk Footprint.

Note

Bien qu'il puisse être possible d'utiliser Cygwin ou MinGW gcc ils n'ont été jusque présent ni testés ni soutenus.


Libraires tierces

Vous aurez besoin de tous les librairies tierces pour compiler FreeCAD avec succès. Si vous utilisez les compilateurs M$ il est recommandé d'installer un FreeCAD LibPack, qui fournit toutes les bibliothèques nécessaires pour compiler FreeCAD dans Windows.

Programmes optionels

  • L'installateur NSIS Windows installer (note: formerly, WiX a été utilisé - nousfaisons maintenant une transition vers NSIS) - si vous voulez créer un MSI Installer

Chemin de Configuration Système

Dans votre système veillez définir les chemins corrects pour les programmes suivants:

  • git (non TortoiseGit, mais git.exe) il est nécessaire pour que Cmake mettre à jour correctement l'information "A propos de FreeCAD" dans le fichier de version.h qui permet à FreeCAD de signaler la bonne version "A propos de FreeCAD" à partir du menu Aide.
  • Optionnellement, vous pouvez inclure libpack dans votre chemin d'accès système. Ceci est utile si vous envisagez de construire de multiples configurations/versions de FreeCAD, vous devrez copier moins de fichiers comme expliqué plus loin dans le processus de construction.

Pour ajouter à votre chemin au système:

  • Menu Démarrer -> clic droit sur Ordinateur -> Propriétés -> Paramètres système avancés
  • Onglet Avancé -> Variables d'environnement ...
  • Ajouter path/to/GIT dans la variable d'environnement PATH
  • Chaque chemin doit être séparé par un point virgule ';'

Configuration avec CMake

The switch to CMake

Warning

Depuis FreeCAD version 0.9, nous avons cessé de fournir les fichiers .vcproj.

Actuellement, FreeCAD utilise le système de compilation CMake pour générer la construction et créer les fichiers qui seront utilisés avec les différents systèmes d'exploitation et compilateurs. Si vous voulez construire des versions antérieures de FreeCAD (0.8 et plus) voir Building older versions later in this article.

Nous avons changé parce qu'il était devenu de plus en plus pénible de maintenir des projets de plus de 30 fichiers et compiler pour x compilateurs. CMake nous donne la possibilité de soutenir d'autres IDE, comme Code::Blocks, Qt Creator et Eclipse CDT. Le compilateur principal est toujours M$ VC9 Express. Mais nous prévoyons pour plus tard un processus de compilation n'utilisant pas de compilateur propriétaire.

CMake

La première étape pour construire FreeCAD avec CMake est de configurer son environnement. Ilk y a deux moyens pour yarriver:

  • Utiliser le LibPack
  • Installer toutes les bibliothèques nécessaires et laisser CMake les trouver


Le processus suivant suppose que vous utilisez le LipPack. La deuxième option peut être discutable dans Options for the Build Process.

Configure CMake en utilisant GUI

  • Ouvrez l'environnement CMake GUI
  • Spécifiez le répertoire des sources
  • Spécifiez le répertoire de compilation
  • Cliquez sur Configure
  • Spécifiez le compilateur attaché à l'IDE que vous utilisez.


Cela va commencer la configuration et devrait échouer, car l'emplacement de FREECAD_LIBPACK_DIR est à l'arrêt.

  • Développez la catégorie FreeCAD et définir FREECAD_LIBPACK_DIR à l'emplacement correct
  • Vérifiez FREECAD_USE_EXTERNAL_PIVY
  • Vérifiez l'option FREECAD_USE_FREETYPE cela est nécessaire pour utiliser la fonctionnalité Draft WB's Shape String functionality
  • Cliquez sur Configurer à nouveau
  • Il ne devrait avoir aucune erreur
  • Cliquez sur Générer
  • Fermer CMake
  • Copiez le dossier libpack\bin dans le nouveau dossier de compilation que CMake a créé

Options pour le Procédé de Compilation

Le système de compilation CMake nous donne beaucoup plus de flexibilité au cours du processus de compilation. Ce qui veut dire nous pouvons activer et désactiver certaines fonctionnalités ou modules. Il y a une similitude au noyau compilation Linux. Vous avez beaucoup de commutateurs pour déterminer le processus de compilation.

Voici la description de certains de ces commutateurs. Ils seront très probablement modifiés dans le futur parce que nous voulons augmenter beaucoup plus la flexibilité de compiulation.


Link table
Nom de la Variable Description Défaut
FREECAD_LIBPACK_USE active ou désactiver l'utilisation du LibPack de FreeCAD Sur Win32 activé, autres désactivé
FREECAD_LIBPACK_DIR Chemin du LibPack Chemin des SOURCES de FreeCAD
FREECAD_BUILD_GUI Compile FreeCAD avec tous les modules Gui Actif
FREECAD_BUILD_CAM Compile le module CAM, expérimental! Inactif
FREECAD_BUILD_INSTALLER Crée le fichier projet pour l'installateur Windows. Inactif
FREECAD_BUILD_DOXYGEN_DOCU Crée les fichiers sources pour la documentation. Inactif
FREECAD_MAINTAINERS_BUILD Active tout ce qui est nécessaire lorsque vous faites une version Release. Inactif

Si vous compilez avec Qt Creator, allez voir Compiler avec Qt Creator, autre procédure Compiler avec Visual Studio 9 2008.

Compilation de FreeCAD

En fonction de votre configuration actuelle, le processus de compilation de FreeCAD sera légèrement différente. Cela est dû à des différences dans les versions du logiciel et des logiciels disponibles pour chaque système d'exploitation.


La procédure suivante crée une compilation dans l'environnement Windows Vista/7/8, pour XP un autre ensemble d'outils VS est nécessaire pour VS 2012 et 2013, qui n'a pas été testé avec succès sur les Libpacks actuelles. Pour cibler XP (x32 et x64 fois), il est recommandé d'utiliser VS2008 et Libpack FreeCADLibs_11.0_x86_VC9.7z

Compilation avec Visual Studio 12 2013

Assurez vous de spécifier Visual Studio 12 x64(ou un Compilateur-C que vous utilisez) comme compilateur utilisé par CMake avant de continuer.

  • Démarrez Visual Studio 12 2013 en cliquant sur l'icône du bureau créé lors de son installation.
  • Ouvrez le projet par:

Fichier -> Ouvrir -> Projet/Solution

  • Ouvrez le fichier FreeCAD_Trunk.sln dans le dossier CMake créé
  • Dans Configuration Solutions, en haut de la barre déroulante activez Release X64

Cette action peut prendre un certain temps en fonction de votre système

  • Build -> Build Solution
  • Cela va prendre un certain temps ...

Si vous ne recevez pas d'erreurs vous avez terminé. Quitter Visual Studio et lancez FreeCAD en double cliquant sur l'icône FreeCAD dans le dossier bin du répertoire de compilation.

Compiler avec Visual Studio 9 2008

Warning

Visual C++ Express 2008 ne supporte pas la compilation 64 bits. Il y a ici une solution de contournement


Avant de continuer assurez-vous de préciser Visual Studio 9 2008 pour le compilateur de CMake .

  • Ouvrez Visual Studio 9 2008 ou Visual C++ Express 2008
  • Fichier -> Ouvrir -> Projet/Solution
  • Ovrez FreeCAD_Trunk.sln dans le dossier de compilation que CMake a créé
  • Activez Release dans Solutions Configuration en haut de la barre déroulante
  • Compilation -> Solution de compilation du compilateur
  • Attendre jusqu’à ce que la compilation soit terminée (cette procédure va prendre un certain temps)

Après la compilation

  • Debug -> Start sans Debugging
  • Cliquez sur le menu popup sous Nom du fichier exécutable et choisissez Browse
  • Allez dans le répertoire \bin et choisissez FreeCAD.exe
  • Vous avez réussi !

Compiler avec Qt Creator

Installation et configuration de Qt Creator

  • Téléchargez et installez Qt Creator
  • Outils -> Options -> Editeur Texte -> Behavior tab:
    • File Encodings -> Default Encodings:
    • Set to: ISO-8859-1 /...csISOLatin1 (Certain caracteres créent une errors/warnings avec Qt Creator if left set to UTF-8. Cela semble pour corrigé.)
  • Tools -> Options -> Build & Run:
    • CMake tab
      • Fill Executable box with path to cmake.exe
    • Kits tab
      • Name: MSVC 2008
      • Compiler: Microsoft Visual C++ Compiler 9.0 (x86)
      • Debugger: Détection automatique ...
      • Qt version: None
    • General tab
      • Uncheck: Toujours compiler et déployer le projet
      • Uncheck: Toujours déployer le projet avant de l'exécuter

Importer un projet et compiler

  • File -> Open File or Project
  • Open CMakeLists.txt qui est dans le plus haut niveau de la source
  • Ceci démarre CMake
  • Choisissez créer le répertoire et cliquez sur suivant
  • Ensemble de générateurs de NMake Generator (MSVC 2008)
  • Cliquez sur Démarrer CMake. Suivez les instructions décrites ci-dessus pour configurer CMake à votre convenance.

Maintenant FreeCAD est construit

  • Build -> Build All
  • Ceci peut prendre du temps...

Une fois terminé, il peut être exécuté: Il y a 2 triangles verts en bas à gauche. Un est pour la mise au point. L'autre est pour l'exécution. Faites votre choix.

Compilation en ligne de commande

Ici un exemple de compilation en ligne de commande:

 rem @echo off
 rem   Build script, uses vcbuild to completetly build FreeCAD
 
 rem update trunc
 d:
 cd "D:\_Projekte\FreeCAD\FreeCAD_0.9"
 "C:\Program Files (x86)\Subversion\bin\svn.exe" update 
 
 rem  set the aprobiated Variables here or outside in the system
 
 set PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
 set INCLUDE=
 set LIB=
 
 rem Register VS Build programms
 call "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\vcvarsall.bat"
 
 rem Set Standard include paths
 set INCLUDE=%INCLUDE%;%FrameworkSDKDir%\include
 set INCLUDE=%INCLUDE%;C:\Program Files\Microsoft SDKs\Windows\v6.0A\Include
 
 rem Set lib Pathes
 set LIB=%LIB%;C:\Program Files\Microsoft SDKs\Windows\v6.0A\Lib
 set LIB=%LIB%;%PROGRAMFILES%\Microsoft Visual Studio\VC98\Lib
 
 rem Start the Visuall Studio build process
 "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\vcpackages\vcbuild.exe" "D:\_Projekte\FreeCAD FreeCAD_0.9_build\FreeCAD_trunk.sln" /useenv


Compiler une ancienne version

Utiliser LibPack

Pour obtenir plus facile la compilation de FreeCAD, nous offrons une collection de toutes les bibliothèques nécessaires. Elle s’appelle LibPack. Vous pouvez les trouver sur la page de téléchargement sur sourceforge.

Vous devez définir les variables d'environnement suivantes:

FREECADLIB = "D:\Wherever\LIBPACK"
QTDIR = "%FREECADLIB%"

Ajoutez "%FREECADLIB%\bin" et "%FREECADLIB%\dll" dans la variable système PATH. Gardez à l'esprit ce que vous devez remplacer "%FREECADLIB%" avec le nom du chemin, Windows ne remplace pas les variables d'environnement de façon récursive.

Répertoire setup dans Visual Studio

Certains chemin de recherche de Visual Studio ont besoin d'être réglés. Pour les modifier, utilisez le menuTools→Options→Directory

Includes

Add the following search path to the include path search list:

  •  %FREECADLIB%\include
  •  %FREECADLIB%\include\Python
  •  %FREECADLIB%\include\boost
  •  %FREECADLIB%\include\xercesc
  •  %FREECADLIB%\include\OpenCascade
  •  %FREECADLIB%\include\OpenCV
  •  %FREECADLIB%\include\Coin
  •  %FREECADLIB%\include\SoQt
  •  %FREECADLIB%\include\QT
  •  %FREECADLIB%\include\QT\Qt3Support
  •  %FREECADLIB%\include\QT\QtCore
  •  %FREECADLIB%\include\QT\QtGui
  •  %FREECADLIB%\include\QT\QtNetwork
  •  %FREECADLIB%\include\QT\QtOpenGL
  •  %FREECADLIB%\include\QT\QtSvg
  •  %FREECADLIB%\include\QT\QtUiTools
  •  %FREECADLIB%\include\QT\QtXml
  •  %FREECADLIB%\include\Gts
  •  %FREECADLIB%\include\zlib
Libs

Ajouter le chemin de recherche ci-dessous pour recherche le répetroire lib:

  •  %FREECADLIB%\lib
Executables

Ajouter le chemin de recherche ci-dessous pour les exécutables:

  •  %FREECADLIB%\bin
  • Le répertoire des binaires de TortoiseSVN , habituellement "C:\Program Files\TortoiseSVN\bin", cela est nécessaire pour lorsque SubWVRev.exe est utilisé pour extraire le numéro de version de Subversion.

Version de Python nécessaire

Lors de la compilation des scripts Python sont exécutées. Ainsi, l'interpréteur Python doit fonctionner sur l'OS. Utilisez une console pour le vérifier. Si la bibliothèque Python n'est pas correctement installée, vous obtiendrez un message d'erreur comme "Cannot find python.exe". Si vous utilisez le LibPack vous pouvez également utiliser la Python.exe dans le répertoire bin.

Specialement pour VC8

Lors de la compilation du projet avec VC8, vous devez modifier les informations de liaison pour la bibliothèque WildMagic, car vous avez besoin d'une version différente pour compiler avec VC6 et VC8. Les deux versions sont fournies dans LIBPACK/dll . Dans les propriétés du projet de AppMesh changez le nom de la bibliothèque wm.dl pour la version VC8. Prenez soin de le changer aussi dans Debug "et" Release configuration.

Compilation

Après vous avoir conformer à toutes ces conditions préalables à la compilation j'espère qu'un seul clic de souris sera suffisant dans VC

Après la Compilation

Après une compilation réussie: Pour rendre FreeCAD opérationnel dans l'environnement du compilateur vous devez copier quelques fichiers à partir du LibPack dans le dossier bin FreeCAD.exe

  • python.exe et python_d.exe de LIBPACK/bin
  • python25.dll et python25_d.dll de LIBPACK/bin
  • python25.zip de LIBPACK/bin
  • faire une copie de Python25.zip et renommez le en Python25_d.zip
  • QtCore4.dll de LIBPACK/bin
  • QtGui4.dll de LIBPACK/bin
  • boost_signals-vc80-mt-1_34_1.dll de LIBPACK/bin
  • boost_program_options-vc80-mt-1_34_1.dll de LIBPACK/bin
  • xerces-c_2_8.dll de LIBPACK/bin
  • zlib1.dll de LIBPACK/bin
  • coin2.dll de LIBPACK/bin
  • soqt1.dll de LIBPACK/bin
  • QtOpenGL4.dll de LIBPACK/bin
  • QtNetwork4.dll de LIBPACK/bin
  • QtSvg4.dll de LIBPACK/bin
  • QtXml4.dll de LIBPACK/bin

Lorsque vous utilisez un LibPack avec une version plus ancienne que Python 2.5, vous devez copier deux autres fichiers:

  • zlib.pyd et zlib_d.pyd de LIBPACK/bin/lib. Ceci est nécessaire pour que Python puisse ouvrir la bibliothèque dans le fichier compressé zip de Python.
  • _sre.pyd et _sre_d.pyd de LIBPACK/bin/lib. Ceci est nécessaire pour que Python puisse construire le système d'aide.

Si vous ne pouvez pas exécuter le programme en raison d'une erreur Python, il est plus que probable que l'un des fichiers zlib*.pyd est manquant.

Alternativement, vous pouvez copier tout le dossier bin de libpack dans le dossier bin de la compilation. Cela est plus facile, mais prend plus de temps et d'espace sur disque. Cela peut être substitué en créant des liens au lieu de copier les fichiers, voir CompileOnWindows - Réduire l'espace disque.

Suppléments

Si vous voulez compiler le code source de la documentation allez sur DoxyGen.

Pour créer et installer un paquet allez sur WIX.


Pendant la compilation des scripts Python sont exécutés. Donc, l'interpréteur Python doit fonctionner correctement.

Pour plus de détails lisez README.linux dans vos sources.

Tout d'abord vous devez construire le plugin Qt qui fournit tous les widgets personnalisés de FreeCAD nous avons besoin pour Qt Designer. Les sources sont situées en dessous

//src/Tools/plugins/widget//.

Jusqu'à présent, nous ne fournissons pas un makefile - mais vous devez l'appeler et la créer

qmake plugin.pro
Une fois fait, appelez construire et la bibliothèque sera créée 
//libFreeCAD_widgets.so//.

Pour rendre visible cette bibliothèque à Qt Designer vous devez copier le fichier

//$QTDIR/plugin/designer//.

References

< précédent: Tracker
suivant: CompileOnUnix >
Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe