This page is a translated version of the page Artwork and the translation is 100% complete.

Here is the artwork that has been created for FreeCAD. Feel free to reuse in other applications. If you would like to contribute with icons, please read the guidelines at the bottom of this page first.

Contents

Application Icons

The FreeCAD Icon

Freecad.svg Freecad16.svg


File Menu and Toolbar Icons

Document-new.svg Document-open.svg Document-save.svg Document-save-as.svg Document-print.svg Document-print-preview.svg Edit-cut.svg Edit-copy.svg Edit-paste.svg Edit-undo.svg Edit-redo.svg View-refresh.svg WhatsThis.svg System-log-out.svg


Edit Menu and Toolbar Icons

Edit-undo.svg Edit-redo.svg Edit-cut.svg Edit-copy.svg Edit-paste.svg View-refresh.svg Edit-select-box.svg Edit-select-all.svg Std Edit.svg Preferences-general.svg

Edit > Preferences Sub-menu Icons

Preferences-system.svg Preferences-general.svg Preferences-display.svg Preferences-arch.svg Preferences-draft.svg Preferences-import-export.svg Preferences-openscad.svg Preferences-part design.svg Preferences-raytracing.svg

View Menu Icons

Window-new.svg View-isometric.svg View-perspective.svg Std Tool1.svg View-measurement.svg

View > Standard Views Sub-menu and Toolbar Icons

View-zoom-all.svg View-zoom-selection.svg View-axometric.svg View-front.svg View-top.svg View-right.svg View-rear.svg View-bottom.svg View-left.svg View-rotate-left.svg View-rotate-right.svg

View > Draw Style Sub-menu and Toolbar Icons

DrawStyleAsIs.svg DrawStyleFlatLines.svg DrawStyleShaded.svg DrawStyleWireFrame.svg DrawStylePoints.svg

View > Stereo Sub-menu Icons

Std Tool1.svg

View > Zoom Sub-menu Icons

View-zoom-in.svg View-zoom-out.svg View-zoom-border.svg

View > Visibility Sub-menu Icons

View-unselectable.svg Part Measure Toggle All.svg Part Measure Clear All.svg

View > Workbench Sub-menu Icons

Workbench Arch.svg Workbench Complete.svg Workbench Draft.svg Workbench Drawing.svg Workbench FEM.svg Workbench Image.svg Workbench Mesh.svg Workbench Part.svg Workbench PartDesign.svg Workbench Points.png Workbench Raytracing.svg Workbench Reverse Engineering.png Workbench Robot.svg Workbench Sketcher.svg Workbench Start.svg Workbench Test.png Workbench Web.svg


Tools Menu Icons

Camera-photo.svg Applications-accessories.svg

Macro Menu and Toolbar Icons

Macro-record.svg Macro-stop.svg Std DlgMacroExecuteDirect.svg Macro-execute.svg Debug-start.svg Debug-stop.svg

Windows Menu Icons

Std WindowNext.svg Std WindowPrev.svg Std WindowTileVer.svg Std WindowCascade.svg

Help Menu Icons

Help-browser.svg Internet-web-browser.svg Applications-python.svg Freecad.svg WhatsThis.svg

Tree Icons, Overall GUI

Document.svg Tree Annotation.svg Tree Dimension.svg Tree Python.svg

Arch WB: Architecture Menu and Arch Tools Toolbar Icons

Arch Wall.svg Arch Structure.svg Arch Rebar.svg Arch Floor.svg Arch Building.svg Arch Site.svg Arch Window.svg Arch Roof.svg Arch Axis.svg Arch SectionPlane.svg Arch Space.svg Arch Stairs.svg Arch Panel.svg Arch Frame.svg Arch Add.svg Arch Remove.svg Arch Survey.svg

Arch WB: Architecture > Utilities Sub-menu Icons

Arch Component.svg Arch SplitMesh.svg Arch MeshToShape.svg Arch SelectNonManifold.svg Arch RemoveShape.svg Arch CloseHoles.svg Arch MergeWalls.svg Arch Check.svg IFC.svg Arch ToggleIfcBrepFlag.svg Arch 3Views.svg Arch Bimserver.svg Git.svg


Arch WB: Tree Icons

Arch Axis Tree.svg Arch Building Tree.svg Arch Cell Tree.svg Arch Floor Tree.svg Arch Frame Tree.svg Arch Panel Tree.svg Arch Rebar Tree.svg Arch Roof Tree.svg Arch SectionPlane Tree.svg Arch Site Tree.svg Arch Space Tree.svg Arch Stairs Tree.svg Arch StructuralSystem Tree.svg Arch Structure Tree.svg Arch Wall Tree.svg Arch Wall Tree Assembly.svg Arch Window Tree.svg

Draft WB: Draft Menu Icons

Draft Line.svg Draft Polyline.svg Draft Circle.svg Draft Arc.svg Draft Ellipse.svg Draft Polygon.svg Draft Rectangle.svg Draft Text.svg Draft Dimension.svg Draft BSpline.svg Draft Point.svg Draft ShapeString.svg Draft Facebinder.svg Draft BezCurve.svg


Draft Move.svg Draft Rotate.svg Draft Offset.svg Draft Trimex.svg Draft Upgrade.svg Draft Downgrade.svg Draft Scale.svg Draft PutOnSheet.svg Draft Edit.svg Draft WireToBSpline.svg Draft AddPoint.svg Draft DelPoint.svg Draft Shape2DView.svg Draft Draft2Sketch.svg Draft Array.svg Draft PathArray.svg Draft Clone.svg

Draft WB: Draft > Utilities Sub-menu Icons

Draft VisGroup.svg Draft Heal.svg Draft FlipDimension.svg Draft Construction.svg Draft Rotate.svg Draft Edit.svg Draft Apply.svg Draft SwitchMode.svg Draft AddToGroup.svg Draft SelectGroup.svg Draft SelectPlane.svg Snap Grid.svg

Draft WB: Draft > Wire Tools Sub-menu Icons

Draft Rotate.svg Draft Finish.svg Draft Lock.svg

Draft WB: Draft > Snapping Sub-menu and Toolbar Icons

Snap Lock.svg Snap Midpoint.svg Snap Perpendicular.svg Snap Grid.svg Snap Intersection.svg Snap Parallel.svg Snap Endpoint.svg Snap Angle.svg Snap Center.svg Snap Extension.svg Snap Near.svg Snap Ortho.svg Snap Dimensions.svg Snap WorkingPlane.svg

Draft WB: Draft Menu Icons

Draft Line.svg Draft Polyline.svg Draft Circle.svg Draft Arc.svg Draft Ellipse.svg Draft Polygon.svg Draft Rectangle.svg Draft Text.svg Draft Dimension.svg Draft BSpline.svg Draft Point.svg Draft ShapeString.svg Draft Facebinder.svg Draft BezCurve.svg

Draft WB: Draft Modification Tools Menu Icons

Draft Move.svg Draft Rotate.svg Draft Offset.svg Draft Trimex.svg Draft Upgrade.svg Draft Downgrade.svg Draft Scale.svg Draft PutOnSheet.svg Draft Edit.svg Draft WireToBSpline.svg Draft AddPoint.svg Draft DelPoint.svg Draft Shape2DView.svg Draft Draft2Sketch.svg Draft Array.svg Draft PathArray.svg Draft Clone.svg

Draft WB: Command Bar Icons

Draft SelectPlane.svg Draft Construction.svg Draft Apply.svg

Draft WB: Tree Icons

Draft Draft.svg

Drawing WB: Toolbar and Menu Icons

Document-new.svg Drawing-landscape.svg Drawing-landscape-new.svg Drawing-landscape-A0.svg Drawing-landscape-A1.svg Drawing-landscape-A2.svg Drawing-landscape-A3.svg Drawing-landscape-A4.svg Drawing-portrait-A4.svg Drawing-view.svg Drawing-orthoviews.svg Drawing-openbrowser.svg Drawing-annotation.svg Drawing-clip.svg Drawing-symbol.svg Document-save.svg

FEM WB: FEM Menu and Toolbar Icons

Fem FemMesh.svg Fem Material.svg Fem Analysis.svg Fem NewAnalysis.svg Fem Solver.svg Fem QuickAnalysis.svg Fem FemMesh createnodebypoly.svg Fem ConstraintFixed.svg Fem ConstraintForce.svg Fem ConstraintPressure.svg Fem-constraint-displacement.svg Fem ConstraintBearing.svg Fem ConstraintGear.svg Fem ConstraintPulley.svg Fem Result.svg Fem ResultDisplacement.svg Fem ResultStress.svg Fem AddFemMesh.svg Fem AddMaterial.svg Fem AddPart.svg Fem Purge results.svg Fem Frequency.svg Fem BeamSection.svg Fem ShellThickness.svg


Image WB: Toolbar Icons

Image-import.svg

Inspection WB: Inspection Menu Icons

Inspect pipette.svg

Meshes WB: Meshes Menu and Toolbar Icons

Mesh Import Mesh.svg Mesh Export Mesh.svg Mesh Mesh from Shape.svg Mesh Harmonize Normals.svg Mesh Flip Normals.svg Mesh boundary.svg Mesh Remove Components.svg Mesh Regular Solid.svg Mesh cut.svg Mesh Curvature Plot.svg

Meshes WB: Analyze Sub-menu Icons

Mesh pipette.svg

Meshes WB: Regular Solids Sub-menu Icons

Mesh Cone.svg Mesh Cube.svg Mesh Cylinder.svg Mesh Ellipsoid.svg Mesh Sphere.svg Mesh Torus.svg MeshFace.svg

Meshes WB: Tree Icons

Tree Mesh.svg Mesh Tree Curvature Plot.svg

OpenSCAD WB: OpenSCAD Menu and Toolbar Icons

OpenSCAD AddOpenSCADElement.svg OpenSCAD ReplaceObject.svg OpenSCAD RemoveSubtree.svg OpenSCAD Explode Group.svg OpenSCAD RefineShapeFeature.svg Part CheckGeometry.svg OpenSCAD IncreaseToleranceFeature.svg Part CreatePrimitives.svg Part Shapebuilder.svg Part Cut.svg Part Fuse.svg Part Common.svg Python.svg

OpenSCAD ColorCodeShape.svg OpenSCAD Hull.svg OpenSCAD MeshBooleans.svg OpenSCAD Minkowski.svg

Part WB: Part Menu Icons

Part Import.svg Part Export.svg Part CreatePrimitives.svg Part Shapebuilder.svg Part Shape from Mesh.svg Part Refine Shape.svg Part CheckGeometry.svg Part CrossSections.svg

Part WB: Part > Part Tools Menu Area and Toolbar Icons

Part Extrude.svg Part Revolve.svg Part Mirror.svg Part Fillet.svg Part Chamfer.svg Part RuledSurface.svg Part Loft.svg Part Sweep.svg Part Offset.svg Part Thickness.svg

Part WB: Part > Primitives Sub-menu, and Solids Toolbar Icons

Part Box.svg Part Cylinder.svg Part Sphere.svg Part Cone.svg Part Torus.svg Part CreatePrimitives.svg Part Shapebuilder.svg

Part WB: Part > Create Parametric Primitives Sub-menu and Toolbar Icons

Tree Part Plane Parametric.svg Tree Part Box Parametric.svg Tree Part Cylinder Parametric.svg Tree Part Cone Parametric.svg Tree Part Sphere Parametric.svg Tree Part Ellipsoid Parametric.svg Tree Part Torus Parametric.svg Tree Part Prism.svg Tree Part Wedge.svg Part Helix Parametric.svg Part Spiral Parametric.svg Part Circle Parametric.svg Part Ellipse Parametric.svg Part Point Parametric.svg Part Line Parametric.svg Part Polygon Parametric.svg

Part WB: Part > Part Boolean Sub-menu and Toolbar Icons

Part Booleans.svg Part Cut.svg Part Fuse.svg Part Common.svg

Part WB: Measure Menu and Toolbar Icons

Part Measure Linear.svg Part Measure Angular.svg Part Measure Clear All.svg Part Measure Toggle All.svg Part Measure Toggle 3d.svg Part Measure Toggle Delta.svg

Part WB: Tree Icons

Tree Part.svg Tree Part Plane Parametric.svg Tree Part Box Parametric.svg Tree Part Cylinder Parametric.svg Tree Part Cone Parametric.svg Tree Part Sphere Parametric.svg Tree Part Ellipsoid Parametric.svg Tree Part Torus Parametric.svg Tree Part Prism.svg Tree Part Wedge.svg

Part Design WB: Part Design Menu or Toolbar Icons

Sketcher NewSketch.svg Sketcher EditSketch.svg Sketcher LeaveSketch.svg Sketcher ViewSketch.svg Sketcher MapSketch.svg PartDesign Pad.svg PartDesign Pocket.svg PartDesign Revolve.svg PartDesign Groove.svg PartDesign Fillet.svg PartDesign Chamfer.svg PartDesign Draft.svg PartDesign Mirrored.svg PartDesign LinearPattern.svg PartDesign PolarPattern.svg PartDesign MultiTransform.svg PartDesign InternalExternalGear.svg WizardShaft.svg


Part Design Next WB:

PartDesign Additive Box.svg PartDesign Additive Cone.svg PartDesign Additive Ellipsoid.svg PartDesign Additive Loft.svg PartDesign Additive Pipe.svg PartDesign Additive Prism.svg PartDesign Additive Sphere.svg PartDesign Additive Torus.svg PartDesign Additive Wedge.svg PartDesign Body.svg PartDesign Body Create New.svg PartDesign Body Tree.svg PartDesign Boolean.svg PartDesign Chamfer.svg PartDesign CoordinateSystem.svg PartDesign Draft.svg PartDesign Fillet.svg PartDesign Groove.svg PartDesign Hole.svg PartDesign InternalExternalGear.svg PartDesign InvoluteGear.svg PartDesign Line.svg PartDesign LinearPattern.svg PartDesign Mirrored.svg PartDesign MoveTip.svg PartDesign MultiTransform.svg PartDesign Pad.svg PartDesign Plane.svg PartDesign Pocket.svg PartDesign Point.svg PartDesign PolarPattern.svg PartDesign Revolution.svg PartDesign Scaled.svg PartDesign ShapeBinder.svg PartDesign Subtractive Box.svg PartDesign Subtractive Cone.svg PartDesign Subtractive Cylinder.svg PartDesign Subtractive Ellipsoid.svg PartDesign Subtractive Loft.svg PartDesign Subtractive Pipe.svg PartDesign Subtractive Prism.svg PartDesign Subtractive Sphere.svg PartDesign Subtractive Torus.svg PartDesign Subtractive Wedge.svg PartDesign Thickness.svg PartDesignWorkbech.svg Tree PartDesign Pad.svg Tree PartDesign Revolution.svg


Plot WB: Plot Menu or Toolbar Icons

Save.svg Axes.svg Series.svg Grid.svg Legend.svg Labels.svg Positions.svg

Points WB: Points Toolbar and Menu Icons

Points Import Point cloud.svg Points Export Point cloud.svg PolygonPick.svg

Points WB: Points > Test Sub-menu Icons

Test1.svg

Raytracing WB: Raytracing Menu Icons

Raytrace NewPartSegment.svg Raytrace ResetCamera.svg Raytrace ExportProject.svg Raytrace Render.svg

Raytracing WB: Raytracing > Utilities Sub-menu Icons

Raytrace Export.svg Raytrace Camera.svg Raytrace Part.svg

Raytracing WB: Raytracing > New POV-Ray Project Sub-menu Icons

Raytrace New.svg

Raytracing WB: Raytracing > New LuxRender Project Sub-menu Icons

Raytrace Lux.svg

Raytracing WB: Raytracing Toolbar Icons Icons

Raytrace New.svg Raytrace Lux.svg Raytrace NewPartSegment.svg Raytrace Camera.svg Raytrace ExportProject.svg Raytrace Render.svg

Reverse Engineering WB: REEN Menu and Toolbar Icons

FitSurface.svg

Robot WB: Robot Menu and Toolbar Icons

Robot CreateRobot.svg Robot CreateTrajectory.svg Robot InsertWaypoint.svg Robot InsertWaypointPre.svg Robot Edge2Trac.svg Robot TrajectoryDressUp.svg Robot TrajectoryCompound.svg Robot SetHomePos.svg Robot RestoreHomePos.svg Robot Simulate.svg Robot Export.svg Robot SetDefaultOrientation.svg Robot SetDefaultValues.svg

Ship WB: Ship Design Menu and Toolbar Icons

Ship Load.svg Ship Module.svg Ship OutlineDraw.svg Ship AreaCurve.svg Ship Hydrostatics.svg

Ship WB: Ship Weights Menu and Toolbar Icons

FreeCAD-Ship-WeightIco.png FreeCAD-Ship-TankIco.png HydrostaticsIco.png

Sketcher WB: Sketcher Menu and Sketch Toolbar Icons

Sketcher NewSketch.svg Sketcher EditSketch.svg Sketcher LeaveSketch.svg Sketcher ViewSketch.svg Sketcher MapSketch.svg

Sketcher WB: Sketch > Sketcher Geometries Sub-menu and Toolbar Icons

Sketcher Point.svg Sketcher Line.svg Sketcher Arc.svg Sketcher Create3PointArc.svg Sketcher Circle.svg Sketcher Create3PointCircle.svg Sketcher Polyline.svg Sketcher Rectangle.svg Sketcher CreateTriangle.svg Sketcher CreateSquare.svg Sketcher CreatePentagon.svg Sketcher CreateHexagon.svg Sketcher CreateHeptagon.svg Sketcher CreateOctagon.svg Sketcher CreateSlot.svg Sketcher CreateFillet.svg Sketcher Trimming.svg Sketcher External.svg Sketcher AlterConstruction.svg

Sketcher WB: Sketch > Sketcher Constraints Sub-menu and Toolbar Icons

Constraint PointOnPoint.svg Constraint PointOnObject.svg Constraint Vertical.svg Constraint Horizontal.svg Constraint Parallel.svg Constraint Perpendicular.svg Constraint Tangent.svg Constraint EqualLength.svg Constraint Symmetric.svg Constraint Lock.svg Constraint HorizontalDistance.svg Constraint VerticalDistance.svg Constraint Length.svg Constraint Radius.svg Constraint InternalAngle.svg Constraint SnellsLaw.svg Constraint Lock Driven.svg Constraint HorizontalDistance Driven.svg Constraint VerticalDistance Driven.svg Constraint Length Driven.svg Constraint Radius Driven.svg Constraint InternalAngle Driven.svg Constraint SnellsLaw Driven.svg Constraint ToggleConstraint Driven.svg Constraint ToggleConstraint Driving.svg Sketcher ToggleConstraint.svg

Sketcher Constraints Icons Not Used

Constraint Concentric.svg Constraint ExternalAngle.svg Constraint PointOnEnd.svg Constraint PointOnMidPoint.svg Constraint PointOnStart.svg Constraint PointToObject.svg Constraint TangentToEnd.svg Constraint TangentToStart.svg

Sketcher WB: Sketch > Sketcher Accelerators Sub-menu and Toolbar Icons

Sketcher CloseShape.svg Sketcher ConnectLines.svg Sketcher SelectConstraints.svg Sketcher SelectOrigin.svg Sketcher SelectVerticalAxis.svg Sketcher SelectHorizontalAxis.svg

Sketcher WB: Combo View > Elements Icons

Sketcher Element Point StartingPoint.svg Sketcher Element Line StartingPoint.svg Sketcher Element Line EndPoint.svg Sketcher Element Line Edge.svg Sketcher Element Circle MidPoint.svg Sketcher Element Circle Edge.svg Sketcher Element Arc MidPoint.svg Sketcher Element Arc StartingPoint.svg Sketcher Element Arc EndPoint.svg Sketcher Element Arc Edge.svg

TechDraw WB:

Techdraw-new-default.svg Annotation.svg Dimension.svg Dimension Angle.svg Dimension Diameter.svg Dimension Horizontal.svg Dimension Length.svg Dimension Radius.svg Dimension Vertical.svg Hatch.svg LinkDimension.svg Page.svg Pages.svg PageTemplate.svg Preferences-techdraw.svg ProjBottom.svg ProjFront.svg ProjFrontBottomLeft.svg ProjFrontBottomRight.svg ProjFrontTopLeft.svg ProjFrontTopRight.svg ProjGroup.svg ProjLeft.svg ProjRear.svg ProjRight.svg ProjTop.svg Section.svg Symbol.svg View.svg


TechDraw WB: actions

Document-new.svg Drawing-draft-view.svg SaveSVG.svg Techdraw-annotation.svg Techdraw-clip.svg Techdraw-clipminus.svg Techdraw-clipplus.svg Techdraw-draft-view.svg Techdraw-hatch.svg Techdraw-landscape.svg Techdraw-landscape-A0.svg Techdraw-landscape-A1.svg Techdraw-landscape-A2.svg Techdraw-landscape-A3.svg Techdraw-landscape-A4.svg Techdraw-landscape-new.svg Techdraw-new-default.svg Techdraw-new-pick.svg Techdraw-openbrowser.svg Techdraw-portrait-A4.svg Techdraw-projgroup.svg Techdraw-symbol.svg Techdraw-toggleframe.svg Techdraw-view.svg Techdraw-viewsection.svg


Tree Icons

Tree Part.svg Tree Mesh.svg Tree Annotation.svg Tree Dimension.svg Tree Python.svg Tree Selectable.svg Tree Unselectable.svg


Other/General Icons

Emot icons

FreeCAD05 Tango Face-angel.svg FreeCAD05 Tango Face-blush.svg FreeCAD05 Tango Face-crying.svg FreeCAD05 Tango Face-devil-grin.svg FreeCAD05 Tango Face-glasses.svg FreeCAD05 Tango Face-grin.svg FreeCAD05 Tango Face-grin-braces.svg FreeCAD05 Tango Face-kiss.svg FreeCAD05 Tango Face-plain.svg FreeCAD05 Tango Face-sad.svg FreeCAD05 Tango Face-smile.svg FreeCAD05 Tango Face-smile-big.svg FreeCAD05 Tango Face-surprise.svg FreeCAD05 Tango Face-wink.svg


FreeCAD05 Tango Anaglyph.svg FreeCAD05 Tango Applications-games.svg FreeCAD05 Tango Applications-ristretto.svg FreeCAD05 Tango Dialog-error.svg FreeCAD05 Tango Dialog-warning.svg FreeCAD05 Tango Measure.svg FreeCAD05 Tango Process-stop.svg FreeCAD05 Tango Text-x-python.svg FreeCAD05 Tango Camera-photo.svg FreeCAD05 Tango Preferences-system.svg FreeCAD05 Tango Camera-video.svg FreeCAD05 Tango Applications-graphics.svg FC Christmas.svg

Splash screens

Splashscreen09.png

Splashscreen010.png

Splash011.png

Splashscreen012.png

Splash013.jpg

Freecadsplash14.png

Freecadsplash15.png

Freecadsplash016.png

Freecadsplash017.png


FreeCAD Icons by their location in source code

From \src\Gui\Icons

Accessories-text-editor.svg Add.svg Applications-accessories.svg Applications-python.svg Background.png Breakpoint.svg Bulb.svg Button down.svg Button invalid.svg Button left.svg Button right.svg Button up.svg Button valid.svg Camera-photo.svg Debug marker.svg Debug-start.svg Debug-stop.svg Delete.svg Document.svg Document-new.svg Document-open.svg Document-print.svg Document-properties.svg Document-save.svg Document-save-as.svg DrawStyleAsIs.svg DrawStyleFlatLines.svg DrawStylePoints.svg DrawStyleShaded.svg DrawStyleWireFrame.svg Edit Cancel.svg Edit-copy.svg Edit-cut.svg Edit-delete.svg Edit-edit.svg Edit OK.svg Edit-paste.svg Edit-redo.svg Edit remove.svg Edit-select-all.svg Edit-select-box.svg Edit-undo.svg Feature.svg Freecad.svg FreeCAD Doc.png Freecadsplash15.png Help-browser.svg Internet-web-browser.svg Macro-execute.svg Macro-record.svg Macro-stop.svg Material.svg Mouse pointer.svg Part Measure Clear All.svg Part Measure Toggle All.svg Preferences-display.svg Preferences-general.svg Preferences-import-export.svg Preferences-system.svg Process-stop.svg Spaceball button.svg SpNav-PanLR.svg SpNav-PanUD.svg SpNav-Roll.svg SpNav-Spin.svg SpNav-Tilt.svg SpNav-Zoom.svg Std ViewScreenShot.svg System-log-out.svg Tree Annotation.svg Tree Dimension.svg Tree Python.svg Utilities-terminal.svg View-axometric.svg View-bottom.svg View-front.svg View-fullscreen.svg View-isometric.svg View-left.svg View-measurement.svg View-perspective.svg View-rear.svg View-refresh.svg View-right.svg View-rotate-left.svg View-rotate-right.svg View-top.svg View-unselectable.svg View-zoom-all.svg View-zoom-border.svg View-zoom-fit.svg View-zoom-in.svg View-zoom-out.svg View-zoom-selection.svg Window-new.svg

The Background has been re-sized to a display width of 480 pixels:

Background.png

From \src\Gui\Icons\ClassBrowser

Const member.svg Member.svg Method.svg Property.svg Type class.svg Type enum.svg Type module.svg

From \src\Mod\Arch\Resources\icons

Arch Add.svg Arch Axis.svg Arch Axis Tree.svg Arch Building.svg Arch Building Tree.svg Arch Cell.svg Arch Cell Tree.svg Arch Check.svg Arch CloseHoles.svg Arch Fixture.svg Arch Floor.svg Arch Floor Tree.svg Arch Frame.svg Arch Frame Tree.svg Arch MergeWalls.svg Arch MeshToShape.svg Arch Panel.svg Arch Panel Tree.svg Arch Rebar.svg Arch Rebar Tree.svg Arch Remove.svg Arch RemoveShape.svg Arch Roof.svg Arch Roof Tree.svg Arch SectionPlane.svg Arch SectionPlane Tree.svg Arch SelectNonManifold.svg Arch Site.svg Arch Site Tree.svg Arch Space.svg Arch Space Tree.svg Arch SplitMesh.svg Arch Stairs.svg Arch Stairs Tree.svg Arch StructuralSystem.svg Arch StructuralSystem Tree.svg Arch Structure.svg Arch Structure Tree.svg Arch Survey.svg Arch ToggleIfcBrepFlag.svg Arch Wall.svg Arch Wall Tree.svg Arch Wall Tree Assembly.svg Arch Window.svg Arch Window Tree.svg IFC.svg Preferences-arch.svg

From \src\Mod\Arch\Resources\ui

ParametersDoorGlass.svg ParametersDoorSimple.svg ParametersWindowDouble.svg ParametersWindowFixed.svg ParametersWindowSimple.svg ParametersWindowStash.svg

From src\Mod\Assembly\Gui\Resources\icons\actions

Axle constraint.svg

From \src\Mod\Draft\Resources\Icons

Draft 2DShapeView.svg Draft AddPoint.svg Draft AddToGroup.svg Draft Apply.svg Draft Arc.svg Draft Array.svg Draft BezCurve.svg Draft BezSharpNode.svg Draft BezSymNode.svg Draft BezTanNode.svg Draft BSpline.svg Draft Circle.svg Draft Clone.svg Draft Construction.svg Draft Cursor.svg Draft DelPoint.svg Draft Dimension.svg Draft Dot.svg Draft Downgrade.svg Draft Draft.svg Draft Draft2Sketch.svg Draft Drawing.svg Draft Edit.svg Draft Ellipse.svg Draft Facebinder.svg Draft Finish.svg Draft FlipDimension.svg Draft Heal.svg Draft Line.svg Draft Lock.svg Draft Macro.svg Draft Move.svg Draft Offset.svg Draft PathArray.svg Draft Point.svg Draft Polygon.svg Draft Rectangle.svg Draft Rotate.svg Draft Scale.svg Draft SelectGroup.svg Draft SelectPlane.svg Draft ShapeString.svg Draft Snap.svg Draft SwitchMode.svg Draft Text.svg Draft Trimex.svg Draft Upgrade.svg Draft VisGroup.svg Draft Wipe.svg Draft Wire.svg Draft WireToBSpline.svg Preferences-draft.svg Snap Angle.svg Snap Center.svg Snap Dimensions.svg Snap Endpoint.svg Snap Extension.svg Snap Grid.svg Snap Intersection.svg Snap Lock.svg Snap Midpoint.svg Snap Near.svg Snap Ortho.svg Snap Parallel.svg Snap Perpendicular.svg Snap WorkingPlane.svg

From \src\Mod\Draft\Resources\Patterns

Concrete.svg Cross.svg Line.svg Simple.svg Square.svg

From \src\Mod\Drawing\Gui\Resources\Icons

Page.svg Pages.svg View.svg

From \src\Mod\Drawing\Gui\Resources\Icons\Actions

Document-new.svg Drawing-annotation.svg Drawing-clip.svg Drawing-landscape.svg Drawing-landscape-A0.svg Drawing-landscape-A1.svg Drawing-landscape-A2.svg Drawing-landscape-A3.svg Drawing-landscape-A4.svg Drawing-landscape-new.svg Drawing-openbrowser.svg Drawing-orthoviews.svg Drawing-portrait-A4.svg Drawing-symbol.svg Drawing-view.svg

From \src\Mod\Drawing\Templates

A3 Landscape.svg A3 Landscape ISO7200.svg A4 Landscape.svg A4 Landscape ISO7200.svg A4 Portrait ISO7200.svg

The following image is "A4_Simple.svg":

A4 Simple.svg

From \src\Mod\Fem\Gui\Resources\Icons\Actions

Fem AddFemMesh.svg Fem AddMaterial.svg Fem AddPart.svg Fem Analysis.svg Fem ConstraintBearing.svg Fem ConstraintFixed.svg Fem ConstraintForce.svg Fem ConstraintGear.svg Fem ConstraintPulley.svg Fem FemMesh.svg Fem FemMesh createnodebypoly.svg Fem Material.svg Fem NewAnalysis.svg Fem Result.svg Fem ResultDisplacement.svg Fem ResultStress.svg

From \src\Mod\Image\Gui\Resources\Icons

Image-import.svg

From \src\Mod\Mesh\Gui\Resources\Icons

Mesh boundary.svg Mesh cut.svg Tree Mesh.svg

From \src\Mod\Inspect\Gui\Resources\Icons

Inspect pipette.svg

From \src\Mod\Material\Gui\Resources\Icons

Preview-rendered.svg Preview-vector.svg

From \src\Mod\Mesh\Gui\Resources\Icons

Mesh boundary.svg Mesh Curvature Plot.svg Mesh cut.svg Mesh Export Mesh.svg Mesh Flip Normals.svg Mesh Harmonize Normals.svg Mesh Import Mesh.svg Mesh Mesh from Shape.svg Mesh pipette.svg Mesh Regular Solid.svg Mesh Remove Components.svg Mesh Tree Curvature Plot.svg Tree Mesh.svg

From \src\Mod\Mesh\Gui\Resources\Icons\RegularSolids

Mesh Cone.svg Mesh Cube.svg Mesh Cylinder.svg Mesh Ellipsoid.svg Mesh Sphere.svg Mesh Torus.svg

From \src\Mod\MeshPart\Gui\Resources\Icons\Actions

MeshFace.svg

From \src\Mod\OpenSCAD\Gui\Resources\Icons\

OpenSCAD AddOpenSCADElement.svg OpenSCAD ColorCodeShape.svg OpenSCAD Explode Group.svg OpenSCAD Hull.svg OpenSCAD IncreaseToleranceFeature.svg OpenSCAD MeshBooleans.svg OpenSCAD Minkowski.svg OpenSCAD RefineShapeFeature.svg OpenSCAD RemoveSubtree.svg OpenSCAD ReplaceObject.svg Preferences-openscad.svg

From \src\Mod\Part\Gui\Resources\icons\

Part Booleans.svg Part Box.svg Part Chamfer.svg Part CheckGeometry.svg Part Circle Parametric.svg Part Common.svg Part Cone.svg Part CreatePrimitives.svg Part CrossSections.svg Part Cut.svg Part Cylinder.svg Part Ellipse Parametric.svg Part Export.svg Part Extrude.svg PartFeature.svg Part Fillet.svg Part Fuse.svg Part Helix Parametric.svg Part Import.svg Part Line Parametric.svg Part Loft.svg Part Measure Angular.svg Part Measure Linear.svg Part Measure Step Active.svg Part Measure Step Done.svg Part Measure Toggle 3d.svg Part Measure Toggle Delta.svg Part Mirror.svg Part Offset.svg Part Point Parametric.svg Part Refine Shape.svg Part Revolve.svg Part RuledSurface.svg Part Section.svg Part Shapebuilder.svg Part Shape from Mesh.svg Part ShapeInfo.svg Part Sphere.svg Part Spiral Parametric.svg Part Spline Parametric.svg Part Sweep.svg Part Thickness.svg Part Torus.svg Preferences-part design.svg Tree Part.svg Tree Part Box Parametric.svg Tree Part Cone Parametric.svg Tree Part Cylinder Parametric.svg Tree Part Ellipsoid Parametric.svg Tree Part Plane Parametric.svg Tree Part Prism.svg Tree Part Sphere Parametric.svg Tree Part Torus Parametric.svg Tree Part Wedge.svg

From \src\Mod\PartDesign\Gui\Resources\icons\

PartDesign Chamfer.svg PartDesign Draft.svg PartDesign Fillet.svg PartDesign Groove.svg PartDesign Hole.svg PartDesign InternalExternalGear.svg PartDesign InvoluteGear.svg PartDesign LinearPattern.svg PartDesign Mirrored.svg PartDesign MultiTransform.svg PartDesign Pad.svg PartDesign Pocket.svg PartDesign PolarPattern.svg PartDesign Revolution.svg PartDesign Scaled.svg Tree PartDesign Pad.svg Tree PartDesign Revolution.svg

From \src\Mod\PartDesign\WizardShaft\

WizardShaft.svg

From \src\Mod\Path\Gui\Resources\icons

Path-Axis.svg Path-Comment.svg Path-Compound.svg Path-Copy.svg Path-Datums.svg Path-Dressup.svg Path-Drilling.svg Path-Hop.svg Path-Kurve.svg Path-LengthOffset.svg Path-LoadTool.svg Path-Machine.svg Path-Plane.svg Path-Pocket.svg Path-Post.svg Path-Profile.svg Path-Project.svg Path-Shape.svg Path-Stock.svg Path-Stop.svg Path-Toolpath.svg Path-ToolTable.svg Preferences-path.svg


From \src\Mod\Plot\resources\icons

Axes.svg Grid.svg Icon.svg Labels.svg Legend.svg Positions.svg Save.svg Series.svg

From \src\Mod\Points\Gui\Resources\icons

Points Export Point cloud.svg Points Import Point cloud.svg

From \src\Mod\Raytracing\Gui\Resources\icons

Preferences-raytracing.svg Raytrace Camera.svg Raytrace Export.svg Raytrace ExportProject.svg Raytrace Lux.svg Raytrace New.svg Raytrace NewPartSegment.svg Raytrace Part.svg Raytrace Render.svg Raytrace ResetCamera.svg

From \src\Mod\ReverseEngineering\Gui\Resources\icons\actions

FitSurface.svg

From \src\Mod\Robot\Gui\Resources\icons

The following icons have been re-sized upwards to a display width of 64 pixels:

Robot CreateRobot.svg Robot CreateTrajectory.svg Robot Edge2Trac.svg Robot Export.svg Robot InsertWaypoint.svg Robot InsertWaypointPre.svg Robot RestoreHomePos.svg Robot SetDefaultOrientation.svg Robot SetDefaultValues.svg Robot SetHomePos.svg Robot Simulate.svg Robot TrajectoryCompound.svg Robot TrajectoryDressUp.svg

From \src\Mod\Ship\Resources\icons

Ship AreaCurve.svg Ship Hydrostatics.svg Ship Instance.svg Ship Load.svg Ship Logo.svg Ship Module.svg Ship OutlineDraw.svg

From \src\Mod\Sketcher\Gui\Resources\icons

Constraint Concentric.svg Constraint EqualLength.svg Constraint ExternalAngle.svg Constraint Horizontal.svg Constraint HorizontalDistance.svg Constraint InternalAngle.svg Constraint Length.svg Constraint Parallel.svg Constraint Perpendicular.svg Constraint PointOnEnd.svg Constraint PointOnMidPoint.svg Constraint PointOnObject.svg Constraint PointOnPoint.svg Constraint PointOnStart.svg Constraint PointToObject.svg Constraint Radius.svg Constraint SnellsLaw.svg Constraint Symmetric.svg Constraint Tangent.svg Constraint TangentToEnd.svg Constraint TangentToStart.svg Constraint Vertical.svg Constraint VerticalDistance.svg Sketcher AlterConstruction.svg Sketcher AlterFillet.svg Sketcher CloseShape.svg Sketcher ConnectLines.svg Sketcher ConstrainCoincident.svg Sketcher ConstrainDistance.svg Sketcher ConstrainHorizontal.svg Sketcher ConstrainLock.svg Sketcher ConstrainParallel.svg Sketcher ConstrainVertical.svg Sketcher Create3PointArc.svg Sketcher Create3PointCircle.svg Sketcher CreateArc.svg Sketcher CreateCircle.svg Sketcher CreateFillet.svg Sketcher CreateHeptagon.svg Sketcher CreateHexagon.svg Sketcher CreateLine.svg Sketcher CreateOctagon.svg Sketcher CreatePentagon.svg Sketcher CreatePoint.svg Sketcher CreatePolyline.svg Sketcher CreateRectangle.svg Sketcher CreateSlot.svg Sketcher CreateSquare.svg Sketcher CreateText.svg Sketcher CreateTriangle.svg Sketcher DraftLine.svg Sketcher EditSketch.svg Sketcher Element Arc Edge.svg Sketcher Element Arc EndPoint.svg Sketcher Element Arc MidPoint.svg Sketcher Element Arc StartingPoint.svg Sketcher Element Circle Edge.svg Sketcher Element Circle MidPoint.svg Sketcher Element Line Edge.svg Sketcher Element Line EndPoint.svg Sketcher Element Line StartingPoint.svg Sketcher Element Point StartingPoint.svg Sketcher Element SelectionTypeInvalid.svg Sketcher External.svg Sketcher LeaveSketch.svg Sketcher MapSketch.svg Sketcher NewSketch.svg Sketcher ProfilesHexagon1.svg Sketcher SelectConstraints.svg Sketcher SelectHorizontalAxis.svg Sketcher SelectOrigin.svg Sketcher SelectVerticalAxis.svg Sketcher Sketch.svg Sketcher Trimming.svg Sketcher ViewSketch.svg

From \src\Mod\Sketcher\Gui\Resources\icons\small

Files in this folder cannot be uploaded due to the file extension.

From \src\Mod\Spreadsheet\Resources\icons

Spreadsheet.svg SpreadsheetController.svg SpreadsheetPropertyController.svg

From \src\Mod\Start\StartPage

ArchDesign.png Blank.png Complete.png Freecad-doc.png Mesh.png PartDesign.png Ship.png Web.png

The following images have been re-sized to a display width of 600 pixels:

ArchExample.png

Background.jpg

Banner.jpeg

Complete.jpg

PartDesignExample.png

ShipExample.png

From \src\Mod\Web\Gui\Resources\icons\actions

Web-browser.svg Web-home.svg Web-next.svg Web-previous.svg Web-refresh.svg Web-stop.svg Web-zoom-in.svg Web-zoom-out.svg

Guidelines

Introduction

A FreeCAD icon is composed of 6 elements which can be remembered easily using the awkward acronym "SALCHO": Stroke, Alignment, Lighting, Color, Highlighting, Outline

Here's a concrete, yet arbitrary example:

An icon that's taken all its vitamins
A The highlight color is used for this entire surface to indicate light falling from above
B The obligatory dark outline surrounds the icon shape to provide form contrast
C Just inside the outline, the highlight stroke (using the highlight color) provides contrast on dark backgrounds
D This face is primarily the base color, but a light gradient from highlight (top left) to base (bottom right) gives the impression of light falling from above left
E The highlight here is the base color (one tone down) to give the impression of this being the face furthest from the light
F This face is like D but goes from Base (top left) to Dark (bottom right), to indicate that this is the face furthest from the light

The following sections explain these elements in a more structured way.

Colors

[Obligatory] FreeCAD uses a palette adapted from the Tango palette. Each main color comes in 4 tones: Highlight, Base, Dark and Outline.

Example of a 4 tone color family (Chameleon)
A selection of some key colors. (See the palette for the full range)
Use the Yellow tones for tools that create objects.
Use the Blue tones for tools that modify objects
Use the Teal tones for view-related tools
Use the Red tones for Constraint related tools

Why limit myself to these colors?

Restricting the colors to a defined palette helps avoid heterogeneous iconography and improves readability when there are many icons.
How? Installing the palette is as easy as copying it into your Inkscape palette folder.

Grid & Stroke Width

[Obligatory] FreeCAD Icons are 64px*64px nominal size (Though I like to leave a 2px margin all around to prevent funky antialiasing things from happening on the image edge). When creating or editing an icon, make sure your document size is 64 x 64 with the units being px. This gives you 60px * 60px of useable space.

Stay inside the blue area and everything will work out just fine

It's also strongly recommended to apply at least one grid to the document that has a grid line every pixel and a major grid line every 2 pixels. Feel free to add other grids to help out, but you should have at least that one. You're strokes would then be aligned along the minor grid intersections. (See image)

Strokes should be no thinner than 2px, with rounded caps and corners in most cases. Strokes can be thicker, but aim for a multiple of two to minimise scaling fuzziness.

Orderly grid, all strokes 2px, perfection achieved

Why use this grid and stroke size?

For historical reasons, FreeCAD uses a 64px icon that then gets scaled down. Not ideal, but it adds character. As a result, keeping things aligned to a power of two grid with thicknesses that are powers of two helps to avoid or at least mitigate anti-aliasing issues upon rescaling.
How? Go to "File > Document Properties" and confirm the width, height and units of your page are correct. Then go to the "Grids" tab and click "New", setting the units to "px", "Spacing X" and "Spacing Y" to 1 and "Major grid line every" to 2

Outline

[Obligatory] Basing yourself on the main color of the icon, ensure that there is a dark outline (of 2px as mentioned earlier). This works in union with the highlight to ensure good form contrast on multiple background tones.

Wow, much clear, so contrast

Why is the outline needed?

The outline is the skeleton on which everything else hangs by adding form contrast. Using the Outline color or the Dark color depends on the situation, but without this line, the range of backgrounds on which the icon is visible gets drastically limited
How? Simply add an external stroke of 2px around every part of the icon that will be adjacent to the background color. In the case of a donut shape for example, you would also do the interior hole. Snap your path's nodes to the grid whenever possible, aiming for the minor grid intersections.

Highlight

[Strongly Advised] Using the Highlight color, add an internal stroke (again, 2px) to help make that outline pop. On dark backgrounds, it's this highlight that will be providing the form to the icon.

That highlight will save our socks on a dark background.

Why use the highlight?

The highlight works in unison with the outline to improve form contrast - especially on dark backgrounds. It is never a bad idea, but if you don't have the space (on a thin line for example) you can opt out of it provided you have ensured enough contrast between the main color and the outline
How? Just like the outline, simply trace a stroke of 2px around the internal side of the outline, snapping nodes to the grid when possible, aiming for the minor grid intersections.

Lighting

[Optional] As per Tango guidelines, if you're adding a gradient lighting effect, try to make it look like the light is coming from the top left. This is done by adding the highlight color up top left and the Base or Dark color bottom right (notice that I haven't played around trying to use a non-palette color)

Subtle but effective.

Why use lighting?

Lighting is just another way to tie icons together and ensure that there are varying levels of 'value' to improve their readability. Provided the outline and highlight are present though, it can be considered optional
How? Set the fill to be a linear or a radial gradient. (Available in the stroke and fill settings). Remember that using "F2" to set direct select, you can move the nodes of the gradient around to make sure they are at the right angle.

Closing Remarks

That's it - that's all there is to making sure that there's a unified look to all the icons. Remember: SALCHO Stroke, Alignment, Lighting, Color, Highlight, Outline

Here's a collection of tips to be able to check your work:

Checking Size

Inkscape has a super handy tool to check your icon at various sizes. Go to "View > Icon Preview..." and it'll show you previews of your icon resized to 16,24,32 and 64px!

Checking Your Outline

1. Put your icon on a big rectangle that is the same color as the darkest color in your icon.

2. Still looks OK? Great! Go to step 3. If not, see the frowny face

3. Do the same but this time using the lightest color.

4. Still looks OK? Great! Outlines and highlights have been used appropriately!

My icon is barely visible!

You have poor form contrast. Double check the outline and highlight, one of these is probably missing or improperly applied.

Checking Your Contrast

1. Get your icon and export it to either .png or .jpg, whichever you prefer

2. Open an image program and change it to grayscale. In GIMP for example you would go to "Image > Mode > Grayscale" (This is excellent for testing for color blind users)

3. Can you still clearly make out any internal details? Great! You have good contrast!

I can't make out all the wonderful detail!

The colors you've chosen have poor value contrast. Try using colors that are further apart in your 4 tone palette. i.e. A Highlight green beside a highlight yellow will be difficult to see, knock one of those colors down to Base or Dark.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano