This page is a translated version of the page Basic modeling tutorial and the translation is 100% complete.

Base ExampleCommandModel.png Tutorial

Topic
Introduction to modelling
Level
Beginner
Time to complete
15 minutes
Author
FreeCAD version
Example File(s)


This Basic Modeling Tutorial will show you how to model an iron angle. One thing to know is that FreeCAD is modular by design, and like for many other CAD software, there are always more than one way to do things. We will explore two methods here.

Before we begin

Keep in mind that FreeCAD is still in an early stage of development, so you might not be as productive as with another CAD application, and you will certainly encounter bugs, or experience crashes. FreeCAD now has the ability to save backup files. The number of those backup files can be specified in the preferences dialog. Don't hesitate to allow 2 or 3 backup files until you know well how to deal with FreeCAD.

Save your work often, from time to time save your work under a different name, so you have a "safe" copy to fall back to, and be prepared to the possibilty that some commands might not give you the expected results.

Modeling Techniques Intro

The first (and basic) technique of solid modeling is Constructive Solid Geometry (CSG). You work with primitive shapes like cubes, cylinders, spheres and cones to construct your geometry by combining them, subtracting one shape from the other, or intersecting them. These tools are part of the Part Workbench. You can also apply transformations on shapes, like applying rounds or chamfers on edges. These tools are also in the Part Workbench.

Then there are more advanced tools. You start by drawing a 2D profile which you'll either extrude or revolve.

So let's start by trying to do some iron feet for a table with these 2 methods.

1st Method - By Constructive Solid Geometry

  • Start with the Part Workbench Switch PartWorkbench.JPG.
  • If you haven't opened a new FreeCAD document (most of the FreeCAD window looks greyed-out), from the pull-down menu click File > New or click the Create A New Document tool Document-new.png.
  • Click on the Part Box.png Box button to create a box
  • Change its dimensions by selecting it either in the 3D space, or by clicking it in the Project tab to the left, then
  • Click on the Data tab at the bottom, and change values for Height, Length and Width to 750mm, 50 and 50 (see Fig. 1.1)
  • Create a second box the same way, but with values 750, 40 and 40mm. By default this box will be superimposed on the first one. (see Fig. 1.2)
  • You'll now subtract the second box from the first. Select the first shape first (named Box), then the second one (named Box001), the selection order is important! (Make sure that both shapes are selected in the Project tree. One thing to remember: in Inventor navigation mode, Ctrl + click does not work for multiple selection. Switch to either CAD or Blender selection.)
  • On the Part Workbench toolbar, click on the Part Cut.png Cut tool.
Fig. 1.1 The first box
Fig. 1.2 The second box on top of the first one, ready to be subtracted
Fig. 1.3 After the subtraction

You now have your first iron angle (Fig. 1.3). You'll notice that, in the Project tab on the left, both boxes have been replaced by a "Cut" object. Actually, they're not disappeared, but rather grouped under the Cut object. Click on the + in front of it, and you'll see that both boxes are still there, but greyed out (Fig. 1.4). If you click on either of them and hit the space bar, it will show up. The space bar toggles visibility of selected objects. (Fig. 1.5)

Don't want the angle oriented that way? You just need to change the placement of the Box001 shape. Select it, unhide it, and in the Data tab, click on the + in front of Placement, then expand the Position parameter, and change its X and Y coordinates. Hit Enter, hide the Box001 shape again, and your angle orientation is now different. (Fig. 1.5) You can even change either of your shapes dimensions, and the Cut object will be updated.

Fig. 1.4 The cut operation retains its original objects (the boxes)
Fig. 1.5 You can still make the original boxes visible

By the way, we can add rounds to the angle so it is more realistic, using the Part Fillet.png Fillet tool. (Fig. 1.6)

Fig. 1.6 The filleted edges

2nd Method - By extruding a profile

This method requires that you start by drawing a 2D profile. You need to activate the Draft workbench Switch DraftWorkbench.JPG.

  • If you haven't opened a new FreeCAD document (most of the FreeCAD window looks greyed-out), from the pull-down menu click File > New or click the Create A New Document tool Document-new.png.

Next we need to set the working plane. Depending on your FreeCAD version, you'll have right under the toolbar, on the right, a "None" button. Click it, and on the left will appear right after "active command": Select Plane Offset, then a text field and a series of buttons. Assuming you want to start your profile on the plan view, select XY. The "None" button will now show "Top" as active plane. See note.

Select the Draft Wire.png Wire (multiple-point line) tool, then start drawing a shape, using the text fields for X and Y positions. The "Relative" box should be checked, as well as the "Filled" box.

  • 1st point: 0,0
  • 2nd point: 50,0
  • 3rd point: 0,10
  • 4th point: -40,0
  • 5th point: 0,40
  • 6th point: -10,0
  • No 7th point, rather click on the "Close" button to close the profile. You should now have this profile, titled "Wire" in the Project tab:
Fig. 1.7 The base wire

Hit the zero key on the numpad to set the view to axonometric.

Activate the Part Workbench.

Click on the Part Extrude.png Extrude tool.

On the Tasks tab on the left, select the Wire object. Then enter the desired length, say 750mm. Leave the direction at Z. Click Apply. You should now have an Extrude object in the Project tab (fig. 1.8)

Fig. 1.8 The extruded object

This method has a minor caveat compared to the other one: to edit the shape, you need to edit the Wire, it's not as easy to do as the previous method.

And there are a few other ways to do it too! I hope these two examples get you started. You'll sure hit some snags along the way (I did when I first learned FreeCAD, and I do have 3D CAD experience), but don't hesitate to ask questions on the FreeCAD forum!


Note on Draft working plane button:

The label on your button may be different, depending on your version and also on what you were doing beforehand. The button label could read: "top", "front", "side", "None" or a Vector representation such as d(0.0,0.0,1.0). It can also be blank. For example:

Select Plane None
Select Plane Top
Select Plane View


The above instructions will work, no matter what label your button has.


Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎português • ‎русский