View Issue Details

IDProjectCategoryView StatusLast Update
0000458FreeCADBugpublic2017-03-20 11:38
Reporterluciol44Assigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.17 
Summary0000458: Problem fusing a cylinder with a torus (Probleme de fusion entre un cylindre et un tor)
DescriptionWhen I do a fuse between a cylinder and a partial torus, 3 times out of 4 the fuse doesn't work and generates random shapes

(Quand je fait un fusion entre cylindre et un tor partiel (pour modeliser un bar avec un coude), 3 fois sur 4 la fusion ne marche pas et genere des forme alleatoires.)
Additional InformationSee attached file, try to fuse the pieces

(Je joind un fichier. Tous les elements ne forme qu'une piece
Tester de les fusionner.)
Tagsbump, OCC Bug, unscheduled, upstream

Relationships

parent of 0001453 closedwmayer Use string representation for PropertyPlacement editor that presevers double precision 

Activities

2011-10-29 21:42luciol44New Issue
2011-10-29 21:42luciol44File Added: Rear_Rollbar.FCStd
2011-10-30 19:01yorikSummaryProbleme de fusion entre un cylindre et un tor => Problem fusing a cylinder with a torus (Probleme de fusion entre un cylindre et un tor)
2011-10-30 19:01yorikDescription Updated
2011-10-30 19:01yorikAdditional Information Updated

2011-10-29 21:42

 

Rear_Rollbar.FCStd (Attachment missing)

yorik

2011-10-30 19:03

administrator   ~0001195

Presque aucun des développeurs ne parle français. Il vaut mieux écrire en anglais, même avec une traduction automatique.

(None of the devs speaks english. Better to write in english, even using an automatic translation)

yorik

2011-10-30 19:07

administrator   ~0001196

There are a couple of modeling problems in the attached file... Some pieces don't coincide, and we saw recently that the OCC kernel has some deficiencies when dealing with torus. I'm not sure we can do much here. The best way would be to remodel, extruding a circle along a profile, for example.

Jriegel

2011-11-04 21:24

administrator   ~0001247

That kind of modeling will always lead to problems, cause you can not position the parts that exactly. Soon there will be a feature in PartDesign which allow you to extrude a profile along a sketched path. That will solve your problem..

normandc

2011-11-21 03:36

manager   ~0001331

Soon? As in v0.13? :-D

normandc

2011-11-21 03:57

manager   ~0001332

Last edited: 2011-11-21 03:59

(english version below)

Bonjour luciol44,

En attendant que la fonction de balayage d'un profil sur une trajectoire soit disponible dans l'interface graphique de FreeCAD (ce dont parlait Jriegel), il est possible de réaliser cette fonction à l'aide d'un script Python.

J'attache un fichier en exemple (rollbar_sweep.fcstd). Je te suggère de poster un message sur le forum francophone de FreeCAD : http://forum.freecadweb.org/viewforum.php?f=12

Où je pourrai t'expliquer au besoin ma procédure, ainsi que te donner mon script. Le script ne génère pas un balayage paramétrique, mais les esquisses utilisées le sont.

---
Hello luciol44,

While we wait for the sweep function of a profile through a sketched path to be added to FreeCAD's GUI (what Jriegel was talking about), it is already possible to do it with a Python script.

I'm attaching an example file (rollbar_sweep.fcstd). I suggest you post to the French FreeCAD forum: http://forum.freecadweb.org/viewforum.php?f=12

Where I'll explain how to do it, and paste my script. The script itself does not generate a parametric sweep, but the sketches are parametric.

2011-11-21 03:58normandcFile Added: rollbar_sweep.fcstd
2011-11-21 03:59normandcNote Edited: 0001332

2011-11-21 03:58

 

rollbar_sweep.fcstd (Attachment missing)

luciol44

2011-12-01 15:59

reporter   ~0001380

Bonjour Normanac,

J'ai telechargeé ton fichier et je n'arrive pas à l'ouvrir. Plantage de FreeCad.
quel version de FreeCad as tu? Je suis sur la 0.11.

Si non je suis quand même preneur pour ton script.

----
Hello Normanac,

I downloaded your file and I can not open it. FreeCAD crash.
What version of FreeCAD are you? I'm on 0.11.

If not I'm still a buyer for your script.

normandc

2011-12-02 00:31

manager   ~0001382

(english version below)

Bonjour Luciol44,

En même temps que mon précédent commentaire, je t'ai envoyé un courriel via l'interface de Sourceforge. Tu ne l'as pas reçu?

Je te recommande de poster dans le forum franco (lien plus haut), puisqu'un rapport de bogue n'est pas vraiment le bon endroit pour discuter. Ou envoie-moi un courriel à mon pseudo @users.sourceforge.net.

---
Hello Luciol44,

When I wrote my comment I sent you an email as well. Did you receive it?

I recommend you create a topic in the French forum (see link above) since a bug report page is not really the right place for discussion. Or send me an email to my username @users.sourceforge.net.

normandc

2011-12-02 02:02

manager   ~0001383

J'ai créé un sujet de discussion dans le forum, rendez-vous là-bas:

http://forum.freecadweb.org/viewtopic.php?f=12&t=1978

See above link to the topic I created on the French FreeCAD forum to continue the discussion.
2015-01-30 10:31shoogenTag Attached: OCC Bug

shoogen

2015-01-30 11:06

developer   ~0005748

http://tracker.dev.opencascade.org/view.php?id=25771
2015-01-30 12:29shoogenRelationship addedparent of 0001453

shoogen

2015-01-30 12:40

developer   ~0005749

I can't tell if the parts are properly aligned.

ickby

2015-02-10 10:03

developer   ~0005777

According to the occ guys this is indeed an alignment error. We need to have a look at the transformation precission used in freecad.

Sebastian, I vaguely remember that you have done something in this regard already, was it the precission of the numbers written in the python interpreter? Does this fix this issue? Or was this only a experiment?

shoogen

2015-02-10 14:39

developer   ~0005781

In the past FreeCAD made it very easy to damage a file due misalignment by rounding in the QSpinboxes or by limiting the numbers of significant digits in th python console output.
Werner a I addresses many of those issues before the 0.14 release.
This ticket and the posted example files predates those improvements.
Still, if have a object exactly placed you should not uses the property editor on the placement afterwards.
As i don't know how luciol44 aligned the objects in this file, I can't tell if the problem was solved.
Perhaps someone might try to align the pipe segments with Werner's align tool.
2017-01-15 04:46Kunda1Tag Attached: upstream

Kunda1

2017-01-16 08:54

manager   ~0007812

bumped the thread http://forum.freecadweb.org/viewtopic.php?f=12&t=1978 (Sorry for posting in english on the french forum)
2017-01-17 04:53normandcFile Added: Rear_Rollbar_normandc1.FCStd

normandc

2017-01-17 04:53

manager  

Rear_Rollbar_normandc1.FCStd (Attachment missing)

normandc

2017-01-17 04:55

manager   ~0007833

I aligned the parts together but didn't use the Edit --> Alignment tool, rather the Draft Move tool with centre snap activated along with some edits to parts Placement.

There was a 0.0001 degree difference between Torus_D and the Montant_D_2 cylinder's rotation. As well I had to remake a new torus to replace Torus_Haut_D as it wouldn't fuse no matter what.

With revised placements, the Fusion succeeds. I only made one side of the rollbar, but the other side should be the same.

Attached file Rear_Rollbar_normandc1.fcstd.

So I guess this bug could be considered fixed.

Checked on

OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6707 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: 5465bc47c95db45e0be85dc0e2872419efadce0f
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
2017-01-18 20:06Kunda1Tag Attached: unscheduled

Kunda1

2017-01-18 20:07

manager   ~0007864

Reminder sent to: wmayer, yorik

@wmayer and @yorik please weigh in
2017-01-21 02:18Kunda1Tag Attached: #pending
2017-01-27 02:25Kunda1Tag Attached: bump
2017-02-08 12:02wmayerStatusnew => closed
2017-02-08 12:02wmayerResolutionopen => fixed
2017-02-08 12:02wmayerFixed in Version => 0.17

Kunda1

2017-03-16 12:25

manager   ~0008641

@wmayer FYI, the upstream bug that shoogen opened (http://tracker.dev.opencascade.org/view.php?id=25771) and mentioned in this ticket (0001936:0005743) is still open. Does that have any further implications on this bug?
2017-03-20 11:38Kunda1Tag Detached: #pending

Issue History

Date Modified Username Field Change
2011-10-29 21:42 luciol44 New Issue
2011-10-29 21:42 luciol44 File Added: Rear_Rollbar.FCStd
2011-10-30 19:01 yorik Summary Probleme de fusion entre un cylindre et un tor => Problem fusing a cylinder with a torus (Probleme de fusion entre un cylindre et un tor)
2011-10-30 19:01 yorik Description Updated
2011-10-30 19:01 yorik Additional Information Updated
2011-10-30 19:03 yorik Note Added: 0001195
2011-10-30 19:07 yorik Note Added: 0001196
2011-11-04 21:24 Jriegel Note Added: 0001247
2011-11-21 03:36 normandc Note Added: 0001331
2011-11-21 03:57 normandc Note Added: 0001332
2011-11-21 03:58 normandc File Added: rollbar_sweep.fcstd
2011-11-21 03:59 normandc Note Edited: 0001332
2011-12-01 15:59 luciol44 Note Added: 0001380
2011-12-02 00:31 normandc Note Added: 0001382
2011-12-02 02:02 normandc Note Added: 0001383
2015-01-30 10:31 shoogen Tag Attached: OCC Bug
2015-01-30 11:06 shoogen Note Added: 0005748
2015-01-30 12:29 shoogen Relationship added parent of 0001453
2015-01-30 12:40 shoogen Note Added: 0005749
2015-02-10 10:03 ickby Note Added: 0005777
2015-02-10 14:39 shoogen Note Added: 0005781
2017-01-15 04:46 Kunda1 Tag Attached: upstream
2017-01-16 08:54 Kunda1 Note Added: 0007812
2017-01-17 04:53 normandc File Added: Rear_Rollbar_normandc1.FCStd
2017-01-17 04:55 normandc Note Added: 0007833
2017-01-18 20:06 Kunda1 Tag Attached: unscheduled
2017-01-18 20:07 Kunda1 Note Added: 0007864
2017-01-21 02:18 Kunda1 Tag Attached: #pending
2017-01-27 02:25 Kunda1 Tag Attached: bump
2017-02-08 12:02 wmayer Status new => closed
2017-02-08 12:02 wmayer Resolution open => fixed
2017-02-08 12:02 wmayer Fixed in Version => 0.17
2017-03-16 12:25 Kunda1 Note Added: 0008641
2017-03-20 11:38 Kunda1 Tag Detached: #pending