View Issue Details

IDProjectCategoryView StatusLast Update
0003012PartDesignBugpublic2017-04-16 19:59
ReporterrjpeekAssigned Tonormandc 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version0.17 
Target VersionFixed in Version 
Summary0003012: Deleting a feature from the tree does not propagate (update) the object properly.
DescriptionI've attach two file below. in the groove file, if you try to delete the groove feature from the tree, the groove is not being removed from Pocket (last feature). The same is true for the pocket file, deleting the pocket feature from the tree, the pocket is not removed from Pad001 (last feature).

Additional InformationOS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10807 (Git)
Build type: None
Branch: master
Hash: b32e9806e1b075c745c0c9692e81aea1dcab81e4
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
TagsNo tags attached.

Activities

2017-04-15 18:08rjpeekNew Issue
2017-04-15 18:08rjpeekFile Added: groove.fcstd
2017-04-15 18:08rjpeekFile Added: pocket.fcstd

rjpeek

2017-04-15 18:08

reporter  

groove.fcstd (14,324 bytes)
pocket.fcstd (14,328 bytes)

normandc

2017-04-16 19:59

manager   ~0008836

As explained in forum topic https://forum.freecadweb.org/viewtopic.php?f=19&t=21862&p=170038#p170038 this is not a bug but a lack of understanding of the PartDesign workflow. The topic explains why it happens and how to fix it.
2017-04-16 19:59normandcAssigned To => normandc
2017-04-16 19:59normandcStatusnew => closed
2017-04-16 19:59normandcResolutionopen => no change required

Issue History

Date Modified Username Field Change
2017-04-15 18:08 rjpeek New Issue
2017-04-15 18:08 rjpeek File Added: groove.fcstd
2017-04-15 18:08 rjpeek File Added: pocket.fcstd
2017-04-16 19:59 normandc Assigned To => normandc
2017-04-16 19:59 normandc Status new => closed
2017-04-16 19:59 normandc Resolution open => no change required
2017-04-16 19:59 normandc Note Added: 0008836