View Issue Details

IDProjectCategoryView StatusLast Update
0002948FreeCADBugpublic2017-04-28 19:17
ReporterBernardAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformMacBook ProOSOS-XOS Version10.11.6
Product Version0.16 
Target VersionFixed in Version 
Summary0002948: Ruled Surfaces get mixed up
DescriptionMinimalste Änderungen an den Dimensionen bzw. constraints zweier im Raum getrennter Sketche mit dazwischen aufgehängten ruled surfaces führen dazu, dass sich die zwischen den Sketchen aufgespannten ruled surfaces komplett verdrehen bzw. falsch zu den Kanten zugeordnet werden.
Steps To Reproduce2 Sketches erstellen in 2 verschiedenen Ebenen.
Kanten der Sketches in Part Design durch ruled surfaces verbinden.
Constraints bzw. Dimensionen der Sketches minimal verändern.
Schon kommen die verbundenen Kanten (d.h. die Flächen) teilweise komplett durcheinander d.h. die Kanten werden nicht mehr richtig zugeordnet bzw. die Richtung auch nicht.
Passiert nicht immer (z.B. habe ich das nicht beim einfachen Fall zweier verbundener 6-Ecke nachvollziehen können) aber ich habe ein Beispiel konstruiert, das ich beifüge.
Verändert man z.B. die eine Constraint im Sketch001 von 500 auf 510 mm, kommt das gesamte Konstrukt der verbundenen Kanten (ruled surfaces) durcheinander. Ich habe dazu ein Beispielbild vorher und nach Änderung beigefügt. Verändert man den Wert jedoch von 500 auf 490 bleibt alles korrekt!. Es hängt also irgendwie mit dem Vorzeichen zusammen.
Additional InformationIch bin völlig begeistert von FreeCAD und ein Neuling. In der Hoffnung zum Gelingen dieses wunderbaren Projekts beizutragen hier mein erster Bug Report mit der Bitte um Nachsicht, wenn ich nicht alles korrekt reportet oder zugeordnet habe.
TagsNo tags attached.

Relationships

duplicate of 0000922 assignedJriegel Topological Naming 

Activities

2017-03-06 10:14BernardNew Issue
2017-03-06 10:14BernardFile Added: Tent_example.FCStd
2017-03-06 10:14BernardFile Added: Tent_ok.pdf
2017-03-06 10:14BernardFile Added: Tent_error.pdf

Bernard

2017-03-06 10:14

reporter  

Tent_error.pdf (Attachment missing)
Tent_ok.pdf (Attachment missing)
Tent_example.FCStd (Attachment missing)

Kunda1

2017-03-06 19:50

manager   ~0008549

Please open a forum thread to discuss this with the FreeCAD community and link back to this thread. Also please paste Help > About FreeCAD > Copy to clipboard
2017-03-06 19:50Kunda1Statusnew => feedback

Bernard

2017-03-07 15:06

reporter   ~0008563

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6706 (Git)
Build type: Release
Branch: tag: 0.16.6706
Hash: f86a4e411ff7848dea98d7242f43b7774bee8fa0
Python version: 2.7.11
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 6.8.0.oce-0.17
2017-03-07 15:06BernardStatusfeedback => new

Bernard

2017-03-07 15:52

reporter   ~0008564

I also try to follow the rules:
1. Make sure that what you found is a bug.
In my opinion it is clearly a bug because minimal changes of sketcher dimensions dependant on the sign (+ or -) lead to completely different results (mismatch of ruled surfaces or no problem at all).

2. If you are unsure, discuss the problem on the forum first.
This is what I did now.

3. Make sure your bug can be reproduced.
I tried to make it very clear and posted an example for reproduction. In addition sometimes when I use undo it is re-constructed the right way, sometimes now. It may be a problem in the visualization?

4. Always include your FreeCAD version information.
I added this information see above.

5. Include all possible FreeCAD error messages.
I do not get any error messages on the report view and I post the python console information here and add it in the bug report (I just changed the dimension from 500 to 499 (if I change from 500 to 501 everything recomputes fine. If I use undo und redo sometimes it recomputes fine too, sometimes not. I cannot find a clear reason or dependancy):

Python 2.7.11 (default, Jan 22 2016, 16:30:50)
[GCC 4.2.1 Compatible Apple LLVM 6.0 (clang-600.0.57)] on darwin
Type 'help', 'copyright', 'credits' or 'license' for more information.
...
>>> import FreeCAD
>>> FreeCAD.open(u"/Users/bernardfrank/Desktop/Tent_example.FCStd")
>>> App.setActiveDocument("Tent_example")
>>> App.ActiveDocument=App.getDocument("Tent_example")
>>> Gui.ActiveDocument=Gui.getDocument("Tent_example")
>>> App.ActiveDocument.Sketch.setDatum(12,App.Units.Quantity('499.000000 mm'))
>>> App.ActiveDocument.recompute()
>>>

6. If possible, also check the terminal and the freecad log for error messages.
I was not able to launch freecad from the terminal: Error message: -bash: freecad: command not found.

kind regards,
Bernard

Kunda1

2017-03-08 13:48

manager   ~0008576

Thanks very much for the elaborate follow-up. 1 more thing is if you can link the forum thread to this ticket and vice-a-versa ?

Bernard

2017-03-08 15:17

reporter   ~0008577

Here is the direct link to the discussion of this bug in the forum:
https://forum.freecadweb.org/viewtopic.php?f=3&t=21146

Bernard

2017-03-09 15:12

reporter   ~0008590

I downloaded the already compiled version 0.17 and tried to reproduce the bug: The bug stays and the behaviour is similar.

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10460 (Git)
Build type: Release
Branch: (detached from 91c59c7)
Hash: 91c59c7910436c44ede608e29d9a90a287121a11
Python version: 2.7.13
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.1.0
2017-03-09 17:22Kunda1Relationship addedduplicate of 0000922

Kunda1

2017-03-09 17:24

manager   ~0008592

According to @ChrisB this is a dupe of 0000922
See https://forum.freecadweb.org/viewtopic.php?f=3&t=21146#p164404
@Bernard thanks for the ticket nonetheless and the effort you put in to it.
2017-03-09 17:24Kunda1Statusnew => resolved
2017-03-09 17:24Kunda1Resolutionopen => duplicate
2017-04-28 19:17Kunda1Statusresolved => closed

Issue History

Date Modified Username Field Change
2017-03-06 10:14 Bernard New Issue
2017-03-06 10:14 Bernard File Added: Tent_example.FCStd
2017-03-06 10:14 Bernard File Added: Tent_ok.pdf
2017-03-06 10:14 Bernard File Added: Tent_error.pdf
2017-03-06 19:50 Kunda1 Note Added: 0008549
2017-03-06 19:50 Kunda1 Status new => feedback
2017-03-07 15:06 Bernard Note Added: 0008563
2017-03-07 15:06 Bernard Status feedback => new
2017-03-07 15:52 Bernard Note Added: 0008564
2017-03-08 13:48 Kunda1 Note Added: 0008576
2017-03-08 15:17 Bernard Note Added: 0008577
2017-03-09 15:12 Bernard Note Added: 0008590
2017-03-09 17:22 Kunda1 Relationship added duplicate of 0000922
2017-03-09 17:24 Kunda1 Status new => resolved
2017-03-09 17:24 Kunda1 Resolution open => duplicate
2017-03-09 17:24 Kunda1 Note Added: 0008592
2017-04-28 19:17 Kunda1 Status resolved => closed