View Issue Details

IDProjectCategoryView StatusLast Update
0002850Path[FreeCAD] Bugpublic2017-04-29 12:17
ReportersebsteAssigned Tosliptonic 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSMint LMDEOS VersionBetsy
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0002850: PATH: Changed Tool parameters are not updated in operations
DescriptionIf an operation has been created, based on a tool in the tool table, and the tools properties are changed in the tool editor, the tool parameters in the existing operations are not changed.
Steps To ReproduceCreate a path job object
create tool controler or select tool in existing tool controler
add pocket operation
double click tool controler, to see cylindrical representation of tool
got to tool table editor
doubleclick the tool selected in the job
change diameter to extreme value, close tool editor

-> Paths remian unchanged and do not reflect the changed tool diameter
doubleclick on tool controller
-> cylindrical representation remains unchanged
TagsNo tags attached.

Activities

2017-01-13 21:19sebsteNew Issue

Kunda1

2017-01-13 21:37

manager   ~0007731

http://forum.freecadweb.org/viewtopic.php?f=3&t=2264

sebste

2017-01-13 21:42

reporter   ~0007732

OS: LMDE 2 Betsy
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9621 (Git)
Build type: Release
Branch: master
Hash: 89afaae5535cdc23aff53bcd3ef1d3a936580348
Python version: 2.7.9
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.0

Kunda1

2017-01-18 01:45

manager   ~0007861

Path sub-forum thread dedicated to this ticket is at http://forum.freecadweb.org/viewtopic.php?f=15&t=20001

sliptonic

2017-03-20 19:40

developer   ~0008663

Last edited: 2017-03-20 19:43

View 2 revisions

The behavior described here is really not a bug. The tool is copied to the local tooltable so changing the properties in the library will have no effect. In upcoming version, the integration between the tool controller and the tool is closer and the panel has an option to 'edit local tool' to change the properties. I'm closing this issue with FreeCAD Pull Request 628

2017-03-20 19:43sliptonicNote Edited: 0008663View Revisions

Kunda1

2017-04-29 12:17

manager   ~0008822

Closing per @sliptonic
See FreeCAD Pull Request 628 for commit details
2017-04-29 12:17Kunda1Assigned To => sliptonic
2017-04-29 12:17Kunda1Statusnew => closed
2017-04-29 12:17Kunda1Resolutionopen => fixed
2017-04-29 12:17Kunda1Fixed in Version => 0.17
2017-04-29 12:17Kunda1Target Version => 0.17

Issue History

Date Modified Username Field Change
2017-01-13 21:19 sebste New Issue
2017-01-13 21:37 Kunda1 Note Added: 0007731
2017-01-13 21:42 sebste Note Added: 0007732
2017-01-18 01:45 Kunda1 Note Added: 0007861
2017-03-20 19:40 sliptonic Note Added: 0008663
2017-03-20 19:43 sliptonic Note Edited: 0008663 View Revisions
2017-04-29 12:17 Kunda1 Assigned To => sliptonic
2017-04-29 12:17 Kunda1 Status new => closed
2017-04-29 12:17 Kunda1 Resolution open => fixed
2017-04-29 12:17 Kunda1 Fixed in Version => 0.17
2017-04-29 12:17 Kunda1 Note Added: 0008822
2017-04-29 12:17 Kunda1 Target Version => 0.17