SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/home/freecadweb/public_html/tracker/core.php' line 274

0002514: Links between sketches are not allowed within one part and between parts when sketch is not in body - FreeCAD Tracker
FreeCAD Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002514PartDesignBugpublic2016-04-17 20:422017-01-12 20:24
ReporterDeepSOIC 
Assigned Toickby 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS Version8.1
Product Version 
Target VersionFixed in Version0.17 
Summary0002514: Links between sketches are not allowed within one part and between parts when sketch is not in body
DescriptionLinks between sketches are not allowed within one part and between parts when sketch is not in body.
Sketches outside bodies can be useful in a ton of situations, mostly outside of PartDesign workbench.
Steps To Reproduce1. In sketcher workbench, make a new sketch, draw rectangle, close.
2. Deselect the new sketch, and create a new free-standing sketch
3. try to link an edge.
Says "Not allowed". Expected: "Hold Ctrl to allow any links".
4. PartDesign workbench, create a new
5. Move sketches into Part (by dragging them in tree view).
6. Try to link from one sketch to other.
"Not allowed" again. Expected: "Hold Ctrl to allow any links".
7. Create a new body, and create a sketch there (from within PartDesign)
8. Try to link to Sketch's edge. Now, finally, I see something like "hold Ctrl to allow", and it's linked.
Additional InformationOS: Windows 8.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.7399 (Git)
Build type: Release
Branch: master
Hash: 08df5cbc59182d2fac98565e2a2ac450d95f92ab
Python version: 2.7.8
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

See also: http://forum.freecadweb.org/viewtopic.php?p=122027&sid=acab9b1494f519a8cd9be10484450ff6#p122027 [^]
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0006987)
ickby (developer)
2016-04-18 06:36

The reason for this behavior is the legacy workflow: If a sketch is not inside a Part/Body it was assumed the workflow is the pre 0.17 one and there the links were not allowed for good reason. This can be prevented if we know that we have a new post 0.16 file. This way it should be ensured that in PArtDesign cross linking works only with bodies but that it works everywhere else as wished.

- Issue History
Date Modified Username Field Change
2016-04-17 20:42 DeepSOIC New Issue
2016-04-18 01:58 normandc Assigned To => ickby
2016-04-18 01:58 normandc Status new => assigned
2016-04-18 06:36 ickby Note Added: 0006987
2016-09-08 22:45 DeepSOIC Status assigned => resolved
2016-09-08 22:45 DeepSOIC Fixed in Version => 0.17
2016-09-08 22:45 DeepSOIC Resolution open => fixed
2017-01-12 20:24 wmayer Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker