View Issue Details

IDProjectCategoryView StatusLast Update
0002307PartDesignBugpublic2017-02-19 14:10
Reporterglosterva 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformDell PC i7OSWindowsOS Version7
Product Version0.15 
Target VersionFixed in Version 
Summary0002307: Polar Pattern does not work because it erroneously does not detect an intersection
DescriptionI select a feature, in this case a wedge formed by two arcs and two line segments connecting them, padded to be 1 mm thick. I click on the Polar Pattern button, and it goes into the Polar Pattern editing mode. In this mode it shows the additional pieces it is supposed to create in red, and increasing or decreasing the total number appears to do what it is supposed to. I increase the total number to 8. The message at the top says "7 transformed shapes do not intersect support". (A similar message appears for all the different numbers.)

There is a cylinder in the middle that the wedge *does* intersect with. I try a variety of ways of getting it to intersect, either meeting right at the edge or significantly overlapping with the cylinder. When I click OK, a Polar Pattern object is added to the model's object list on the left, but, presumably because of the error, the additional pieces do not appear.
Steps To ReproduceOpen the file. Select Part Design. Select the wedge object (Pad001). Click the Polar Pattern button or PartDesign->PolarPattern menu item. It shows no message yet, but it is still in an error condition. Click to increase the number of occurrences and the message will appear.
Additional InformationThe PolarPattern Parameters dialog area looks nothing like the dialog shown in the documentation here:

http://www.freecadweb.org/wiki/index.php?title=PartDesign_PolarPattern
TagsPolarPattern

Relationships

Activities

thehoodedfoot

2015-10-28 13:12

reporter   ~0006506

Last edited: 2017-02-19 14:05

View 2 revisions

I can confirm a similar error on version 0.16, git 5234, running on 64-bit
Funtoo Linux. It can be reproduced by entering the part design workbench,
drawing a 1mm x 1mm sketch from the origin and then generating a 1mm pad to
create a 1mm cube. If the polar pattern feature is then selected and the pad
is revolved through 360 degrees with 4 occurrences, the expected result should
be a 2mm x 2mm x 1mm pad. However, the result is an L-shape, with the message
'One transformed shape does not intersect support'.

per @thehoodedfoot in 0002307:0008364 this comment is not valid.

Sam

2016-03-20 18:45

reporter   ~0006918

Just letting you know I see this same issue here:

OS: Ubuntu 15.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6623 (Git)
Build type: None
Branch: master
Hash: 9d617ce4c8a0d65155c6b2d4bbff273519b6e573
Python version: 2.7.10
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

ezzieyguywuf

2016-05-10 00:42

developer   ~0007075

Is there a file that's supposed to be attached to this bug?

nickoe

2016-12-01 19:59

reporter  

1001.png (61,899 bytes)
1001.png (61,899 bytes)

nickoe

2016-12-01 19:59

reporter  

1001.fcstd (6,952 bytes)

nickoe

2016-12-01 20:00

reporter   ~0007502

I think I see the same problem. I have attached the 1001.{fcstd,png}. Note the warning.

poserge

2016-12-02 16:26

reporter   ~0007506

I would suggest PartDesign objects don't intersect with Part objects? In .17 version they are clearly separated, but I'm not sure about .16

normandc

2016-12-29 00:05

manager   ~0007555

nickoe, the error in the file you attached (1001.fcstd) is normal. Transformation tools work on PartDesign features and all the occurrences need to intersect the support. In your file, Pad (the cylinder) is not fused to the Cube, because the sketch was not mapped to a face on the Cube. Thus it is an invalid use of the tool.

thehoodedfoot's cooment is a different bug entirely.

Unfortunately, glosterva never provided a file, and his description is too vague to try to reproduce. IMO we should close this bug as invalid.

Kunda1

2017-01-11 22:57

manager   ~0007660

@glosterva please provide a sample file to test

@thehoodedfoot please open a separate bug
@Sam which issue are you confirming? OP's or thehoodedfoot's?

Kunda1

2017-02-18 12:20

manager   ~0008347

Last edited: 2017-02-18 12:20

View 2 revisions

ping
@glosterva
@thehoodedfoot
@Sam

thehoodedfoot

2017-02-19 10:38

reporter   ~0008364

Further to the ping by Kunda1, I must state that I was incorrect in my understanding of the polar pattern feature, and that I mistakenly assumed that any intersecting features would merge. Further reading of the linear pattern documentation shows that this is not the intended or expected behaviour, and I therefore report my comment 6506 as invalid/closed.

Kunda1

2017-02-19 14:10

manager   ~0008366

per @normandc advice 0002307:0007555 I'm resolving this bug as 'unable to reproduce'

Issue History

Date Modified Username Field Change
2015-10-25 22:00 glosterva New Issue
2015-10-28 13:12 thehoodedfoot Note Added: 0006506
2016-03-20 18:45 Sam Note Added: 0006918
2016-05-10 00:42 ezzieyguywuf Note Added: 0007075
2016-12-01 19:59 nickoe File Added: 1001.png
2016-12-01 19:59 nickoe File Added: 1001.fcstd
2016-12-01 20:00 nickoe Note Added: 0007502
2016-12-02 16:26 poserge Note Added: 0007506
2016-12-29 00:05 normandc Note Added: 0007555
2017-01-11 22:57 Kunda1 Note Added: 0007660
2017-01-11 22:57 Kunda1 Status new => feedback
2017-01-29 14:56 Kunda1 Tag Attached: split ticket
2017-02-18 12:20 Kunda1 Note Added: 0008347
2017-02-18 12:20 Kunda1 Note Edited: 0008347 View Revisions
2017-02-19 10:38 thehoodedfoot Note Added: 0008364
2017-02-19 14:05 Kunda1 Note Edited: 0006506 View Revisions
2017-02-19 14:06 Kunda1 Tag Detached: split ticket
2017-02-19 14:06 Kunda1 Tag Attached: PolarPattern
2017-02-19 14:06 Kunda1 Tag Attached: #pending
2017-02-19 14:10 Kunda1 Status feedback => resolved
2017-02-19 14:10 Kunda1 Resolution open => unable to reproduce
2017-02-19 14:10 Kunda1 Note Added: 0008366
2017-02-19 14:10 Kunda1 Tag Detached: #pending