View Issue Details

IDProjectCategoryView StatusLast Update
0002271FreeCADBugpublic2017-03-25 00:43
Reporterwmayer 
Assigned Tosgrogan 
PrioritylowSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.17Fixed in Version0.17 
Summary0002271: FreeCAD documentation can't be loaded on Debian/Ubuntu
Descriptionhttp://forum.freecadweb.org/viewtopic.php?f=3&t=12532&sid=460c147280f6840f05e03240a926cc03
Tagspackaging

Relationships

related to 0002984 assignedsgrogan Update the debian folder in FreeCAD 

Activities

2015-09-20 08:04wmayerNew Issue

normandc

2016-03-06 16:32

manager   ~0006886

Debian Policy states:
"Additional documentation included in the package should be installed under /usr/share/doc/package. If the documentation is packaged separately, as package-doc for example, it may be installed under either that path or into the documentation directory for the separate documentation package (/usr/share/doc/package-doc in this example). However, installing the documentation into the documentation directory of the main package is preferred since it is independent of the packaging method and will be easier for users to find."
https://www.debian.org/doc/debian-policy/ch-docs.html

The PPA package follows the Debian policy, so contrary to what you say in that topic Werner, this is not a packaging issue, because FreeCAD is not looking for the file in the correct place.

Prior topic: http://forum.freecadweb.org/viewtopic.php?f=3&t=10606&start=10#p85466

normandc

2016-03-10 12:05

manager   ~0006900

Note to myself: check content of debian/freecad-doc.docs and freecad-doc.doc-base.

wmayer

2016-03-10 18:28

administrator   ~0006902

I tested this with a local build on Ubuntu 12.04 and Windows and there the documentation comes up. So, the help files themselves are correct.

Afterwards I updated my FreeCAD installation from ppa and also installed the doc. There it doesn't work. When I look at the path name inside the Synaptic GUI then it gives the correct path according to the Debian policy:
/usr/share/doc/freecad-doc/

However, FreeCAD expects it to be under /usr/lib/freecad/doc instead. This is an indication that not the freecad-doc.docs and freecad-doc.doc-base are wrong but in the "rules" file something is missing.

And in fact in the rules file there should be added a further line to the extra_flags:
-DCMAKE_INSTALL_DOCDIR="/usr/share/doc/freecad-doc" \

I couldn't test it but this should be the way how to fix it.
2016-03-11 22:10wmayerStatusnew => closed
2016-03-11 22:10wmayerAssigned To => wmayer
2016-03-11 22:10wmayerResolutionopen => fixed
2016-03-11 22:10wmayerFixed in Version => 0.16

normandc

2016-04-14 04:14

manager   ~0006961

Last edited: 2016-04-14 04:14

View 2 revisions

I'm sorry, this is not fixed for me. I just built a test deb 0.16.6700 package for trusty, with the extra_flags line added to debian/rules as per comment above. I installed freecad-doc package, and upon hitting F1 I get an error window stating
(translated to English):

"FreeCAD help files not found (/usr/share/doc/freecad-doc/freecad.qhc). You may have to install the FreeCAD documentation package."

OS: Ubuntu 14.04.4 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6700 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: 7b925d11aa69ac405b423635adb1e2833f18a817
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.0
(very old version of OCC because package was built with pbuilder in a chroot environment from the Ubuntu repo available libraries)

2016-04-14 04:14normandcStatusclosed => feedback
2016-04-14 04:14normandcResolutionfixed => reopened
2016-04-14 04:14normandcNote Edited: 0006961View Revisions

normandc

2016-04-14 10:55

manager   ~0006962

I added the file debian/freecad-doc.install with the following content:

src/Doc/freecad.qhc usr/share/doc/freecad-doc

The freecad.qhc file is now properly installed, and F1 now opens Qt Assistant, but it is empty of content, with the following message in the main window:

------
      The page could not be found.

'qthelp://org.freecad.usermanual//../doc/Online_Help_Startpage.html'
------

I have the same problem with FreeCAD compiled from master.

wmayer

2016-05-05 08:08

administrator   ~0007044

Is this still a problem? According to http://forum.freecadweb.org/viewtopic.php?t=15290#p121678 it looks like it's resolved now.
2016-05-05 08:08wmayerStatusfeedback => assigned
2016-05-05 08:09wmayerStatusassigned => feedback

sgrogan1

2016-05-05 20:31

developer   ~0007050

Last edited: 2016-05-05 20:34

View 2 revisions

This is fixed for the stable releases PPA
It is still being tested for the daily PPA, and has problems

sgrogan@sgrogan-HP-ZBook-17:~$ sudo apt-get install freecad-daily-doc
[sudo] password for sgrogan:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.13.0-77 linux-headers-3.13.0-77-generic
  linux-headers-3.13.0-79 linux-headers-3.13.0-79-generic
  linux-image-3.13.0-77-generic linux-image-3.13.0-79-generic
  linux-image-extra-3.13.0-77-generic linux-image-extra-3.13.0-79-generic
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  freecad-daily-doc
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 81.4 MB of archives.
After this operation, 82.2 MB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/clhclh/sgrogan/ubuntu/ trusty/main freecad-daily-doc all 0.17~alpha1+git201605032021~ubuntu14.04.1 [81.4 MB]
Fetched 81.4 MB in 8min 51s (153 kB/s)
Selecting previously unselected package freecad-daily-doc.
(Reading database ... 289057 files and directories currently installed.)
Preparing to unpack .../freecad-daily-doc_0.17~alpha1+git201605032021~ubuntu14.04.1_all.deb ...
Unpacking freecad-daily-doc (0.17~alpha1+git201605032021~ubuntu14.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/freecad-daily-doc_0.17~alpha1+git201605032021~ubuntu14.04.1_all.deb (--unpack):
 trying to overwrite '/usr/share/doc-base/freecad-development-documentation', which is also in package freecad-doc 1:0.16.6703-1ppa1~ubuntu14.04.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/freecad-daily-doc_0.17~alpha1+git201605032021~ubuntu14.04.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The daily builds are deployed to my personal PPA for testing
https://launchpad.net/~clhclh/+archive/ubuntu/sgrogan

This is a packing problem, not a FreeCAD problem. When this is working NormandC or sgrogan will make a pull request to update the debian folder in the FreeCAD GitHub repo.

2016-05-05 20:34sgrogan1Note Edited: 0007050View Revisions
2017-01-11 22:12Kunda1Assigned Towmayer => normandc
2017-01-11 22:12Kunda1Statusfeedback => assigned

Kunda1

2017-01-11 22:14

manager   ~0007658

Last edited: 2017-01-11 22:17

View 2 revisions

Assigned to @normandc as per his post in http://forum.freecadweb.org/viewtopic.php?t=15290#p121689
@wmayer issue says fixed in 0.16 should we unset that since there is a pending PR ?

EDIT: my mistake it is actually @sgrogan that will prepare the PR per http://forum.freecadweb.org/viewtopic.php?f=3&t=12532&start=10#p152550

2017-01-11 22:17Kunda1Note Edited: 0007658View Revisions
2017-01-11 22:17Kunda1Assigned Tonormandc => sgrogan

Kunda1

2017-01-12 15:08

manager   ~0007670

Last edited: 2017-01-14 13:28

View 2 revisions

Apologies, I shouldn't have assigned this ticket to anyone. Should I undo and re-assign to @wmayer or keep it as it is now?

Edit: sgrogan is OK with this per http://forum.freecadweb.org/viewtopic.php?f=8&t=19745&p=152500#p153042

2017-01-14 13:28Kunda1Note Edited: 0007670View Revisions
2017-03-24 14:19Kunda1Target Version => 0.17
2017-03-24 14:23Kunda1Fixed in Version0.16 =>
2017-03-24 16:19Kunda1Tag Attached: packaging
2017-03-25 00:40Kunda1Relationship addedrelated to 0002984

Kunda1

2017-03-25 00:43

manager   ~0008701

Per @sgrogan of gitter.im:
sgrogan wrote

I think we should close the issue as fixed. The debian folder in the FreeCAD sources is only tangentially related. We don't use it for the PPA. I don't think anybody uses it. Ideally we could come up with universal debian folder that would work on both debian and ubuntu, that could be included in the sources. If you want you can open a new issue (0002984) to update the debian folder in FreeCAD w/low priority and assign it to me.


Closing ticket and opened 0002984
2017-03-25 00:43Kunda1Statusassigned => closed
2017-03-25 00:43Kunda1Resolutionreopened => fixed
2017-03-25 00:43Kunda1Fixed in Version => 0.17

Issue History

Date Modified Username Field Change
2015-09-20 08:04 wmayer New Issue
2016-03-06 16:32 normandc Note Added: 0006886
2016-03-10 12:05 normandc Note Added: 0006900
2016-03-10 18:28 wmayer Note Added: 0006902
2016-03-11 22:10 wmayer Status new => closed
2016-03-11 22:10 wmayer Assigned To => wmayer
2016-03-11 22:10 wmayer Resolution open => fixed
2016-03-11 22:10 wmayer Fixed in Version => 0.16
2016-04-14 04:14 normandc Note Added: 0006961
2016-04-14 04:14 normandc Status closed => feedback
2016-04-14 04:14 normandc Resolution fixed => reopened
2016-04-14 04:14 normandc Note Edited: 0006961 View Revisions
2016-04-14 10:55 normandc Note Added: 0006962
2016-05-05 08:08 wmayer Note Added: 0007044
2016-05-05 08:08 wmayer Status feedback => assigned
2016-05-05 08:09 wmayer Status assigned => feedback
2016-05-05 20:31 sgrogan1 Note Added: 0007050
2016-05-05 20:34 sgrogan1 Note Edited: 0007050 View Revisions
2017-01-11 22:12 Kunda1 Assigned To wmayer => normandc
2017-01-11 22:12 Kunda1 Status feedback => assigned
2017-01-11 22:14 Kunda1 Note Added: 0007658
2017-01-11 22:17 Kunda1 Note Edited: 0007658 View Revisions
2017-01-11 22:17 Kunda1 Assigned To normandc => sgrogan
2017-01-12 15:08 Kunda1 Note Added: 0007670
2017-01-14 13:28 Kunda1 Note Edited: 0007670 View Revisions
2017-03-24 14:19 Kunda1 Target Version => 0.17
2017-03-24 14:23 Kunda1 Fixed in Version 0.16 =>
2017-03-24 16:19 Kunda1 Tag Attached: packaging
2017-03-25 00:40 Kunda1 Relationship added related to 0002984
2017-03-25 00:43 Kunda1 Status assigned => closed
2017-03-25 00:43 Kunda1 Resolution reopened => fixed
2017-03-25 00:43 Kunda1 Fixed in Version => 0.17
2017-03-25 00:43 Kunda1 Note Added: 0008701