View Issue Details

IDProjectCategoryView StatusLast Update
0002264SketcherBugpublic2017-04-17 20:13
ReporterseverorazAssigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.17 
Summary0002264: Construction lines should be rendered below non-construction lines
DescriptionConstruction lines should be rendered below non-construction lines because their use is secondary and otherwise it becomes difficult to work with sketch lines that overlap construction lines.
Steps To Reproduce1. Draw a line
2. Draw a line on top of the previous line
3. Set either line to be a construction line
4. Observe how the construction line is rendered over the sketch line
Tags#pending

Activities

2015-09-14 06:41severorazNew Issue

Kunda1

2017-01-23 21:29

manager   ~0007927

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20164
2017-01-23 21:30Kunda1Tag Attached: #pending

normandc

2017-01-24 05:02

manager   ~0007945

What I'm getting now is that the first sketched geometry will always stay on top of any other geometry that gets added afterwards, independent of whether the first sketched geometry is construction or non-construction.

Whether the new behaviour is more desirable or intended is another matter...

OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6707 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: 5465bc47c95db45e0be85dc0e2872419efadce0f
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

and

OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9747 (Git)
Build type: None
Branch: master
Hash: f5c0f579cbd7ce668727f8835946e4e9abc0eec6
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-01-25 12:10

manager   ~0007974

@nemesis writes
> [phenomena described is still valid] but maybe construction lines just need to be dot dash lines?
that's maybe more a matter of choice than a bug I guess.
2017-04-16 16:01normandcProjectPartDesign => Sketcher
2017-04-16 16:31abdullahAssigned To => abdullah
2017-04-16 16:31abdullahStatusnew => assigned

abdullah

2017-04-16 16:34

developer   ~0008831

What is drawn on top of what depends on what you want to achieve. Drawing construction on top of normal is as bad a solution as doing it otherwise, just because there are cases where one is needed an other where the other is needed.

I am currently working out a more general solution, so I assign this to myself.
2017-04-17 20:12wmayerChangeset attached => FreeCAD master 937c6179
2017-04-17 20:13wmayerStatusassigned => closed
2017-04-17 20:13wmayerResolutionopen => fixed
2017-04-17 20:13wmayerFixed in Version => 0.17

Related Changesets

FreeCAD: master 937c6179

2017-04-16 19:23:19

abdullah


Committer: wmayer Details Diff
Sketcher: Rendering order widget
mod - src/Mod/Sketcher/Gui/TaskSketcherGeneral.cpp Diff File
mod - src/Mod/Sketcher/Gui/TaskSketcherGeneral.h Diff File
mod - src/Mod/Sketcher/Gui/TaskSketcherGeneral.ui Diff File
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.h Diff File

Issue History

Date Modified Username Field Change
2015-09-14 06:41 severoraz New Issue
2017-01-23 21:29 Kunda1 Note Added: 0007927
2017-01-23 21:30 Kunda1 Tag Attached: #pending
2017-01-24 05:02 normandc Note Added: 0007945
2017-01-25 12:10 Kunda1 Note Added: 0007974
2017-04-16 16:01 normandc Project PartDesign => Sketcher
2017-04-16 16:31 abdullah Assigned To => abdullah
2017-04-16 16:31 abdullah Status new => assigned
2017-04-16 16:34 abdullah Note Added: 0008831
2017-04-17 20:12 wmayer Changeset attached => FreeCAD master 937c6179
2017-04-17 20:13 wmayer Status assigned => closed
2017-04-17 20:13 wmayer Resolution open => fixed
2017-04-17 20:13 wmayer Fixed in Version => 0.17