View Issue Details

IDProjectCategoryView StatusLast Update
0002003PartDesignFeaturepublic2017-04-16 08:46
ReportertriplusAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status feedbackResolutionreopened 
PlatformLinuxOSUbuntuOS Version14.04
Product Version 
Target VersionFixed in Version0.17 
Summary0002003: Embossing/imprinting an FC logo directly to a solid model
DescriptionAn idea came to life while taking on the Logo challenge:

http://forum.freecadweb.org/viewtopic.php?f=8&t=9468&start=40#p79679

There should be a tool in Part/PartDesign WB allowing the user to easily tag the part with FreeCAD logo.
TagsNo tags attached.

Activities

2015-03-12 20:34triplusNew Issue
2015-03-12 20:34triplusFile Added: TAG.png
2017-02-03 22:26wmayerStatusnew => closed
2017-02-03 22:26wmayerResolutionopen => fixed
2017-02-03 22:26wmayerFixed in Version => 0.17

triplus

2015-03-12 20:34

reporter  

TAG.png (17,490 bytes)
TAG.png (17,490 bytes)

normandc

2017-02-04 18:16

manager   ~0008213

This feature request is not related to just closed issue #0002887.

This is about embossing/imprinting a FreeCAD logo directly to a solid model which may be interesting when 3D printing it.

Although this could be easily addressed with a macro, IMO this report should be reopened.

Kunda1

2017-02-04 21:03

manager   ~0008214

Re-opened per @NormandC's request.
2017-02-04 21:03Kunda1Statusclosed => feedback
2017-02-04 21:03Kunda1Resolutionfixed => reopened

Kunda1

2017-02-04 21:06

manager   ~0008215

Renamed ticket for better comprehension
2017-02-04 21:06Kunda1SummaryTagging part with logo => Embossing/imprinting an FC logo directly to a solid model

wmayer

2017-02-04 22:34

administrator   ~0008216

What's the point of having a specialized command for it, then?

normandc

2017-02-04 22:56

manager   ~0008217

Last edited: 2017-02-04 22:59

View 2 revisions

I'm not sure how triplus envisioned this feature.

Yes, a macro could do the job, but a menu entry would be more user-friendly. Arch has a Utilities menu that contains tools that do not immediately appear to be relevant to Arch.

Whether the menu calls a native C++ function or a python macro, or if its place is in the Part workbench or somewhere else is a matter to be discussed.

This tool could behave like a Draft Shapestring and create a single parametric object containing 2 faces (the F and the gear) that you can extrude, pad or pocket (which means it should be possible to attach it to a solid, just like Draft Shapestring). This FC logo object would have a scale property.

It's also not unlike the Involute gear utility in the Part Design menu.

In such form, maybe the best place for it would be the Draft workbench?

Another more involved alternative would be to give it a fully automated creation method including padding/pocketing process, but that is a high-level function that would not be suited to the Part workbench and may be a bit too specialized for the Part Design workbench.

Since this feature would in fact promote FreeCAD it would be useful to offer it natively.

2017-02-04 22:59normandcNote Edited: 0008217View Revisions

Issue History

Date Modified Username Field Change
2015-03-12 20:34 triplus New Issue
2015-03-12 20:34 triplus File Added: TAG.png
2017-02-03 22:26 wmayer Status new => closed
2017-02-03 22:26 wmayer Resolution open => fixed
2017-02-03 22:26 wmayer Fixed in Version => 0.17
2017-02-04 18:16 normandc Note Added: 0008213
2017-02-04 21:03 Kunda1 Note Added: 0008214
2017-02-04 21:03 Kunda1 Status closed => feedback
2017-02-04 21:03 Kunda1 Resolution fixed => reopened
2017-02-04 21:06 Kunda1 Note Added: 0008215
2017-02-04 21:06 Kunda1 Summary Tagging part with logo => Embossing/imprinting an FC logo directly to a solid model
2017-02-04 22:34 wmayer Note Added: 0008216
2017-02-04 22:56 normandc Note Added: 0008217
2017-02-04 22:59 normandc Note Edited: 0008217 View Revisions