View Issue Details

IDProjectCategoryView StatusLast Update
0001952FreeCADFeaturepublic2017-03-02 13:37
Reporterpiffpoof 
Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionno change required 
PlatformMacintoshOSMac OS XOS Version10.6.8
Product Version0.14 
Target VersionFixed in Version 
Summary0001952: feature request for facility to provide files which are downloadable from the Wiki pages
DescriptionNote: This is a feature request for the Wiki software, not FreeCAD itself but there was no 'Wiki' option in the 'Select Project' popup menu.

I am intending to produce some documentation on FreeCAD which would be on the Wiki. This documentation would be focussed on beginners or new-comers to FreeCAD and I want to attach example files for them.

As an indication of size, I have got some example files for a macro I have written and they are about 12 kb each. I don't expect the files to be large. At this point my thought is that the file type would be limited to ".FCStd"
Additional InformationI appreciate the problems with attaching files to the Wiki and so don't like to specify that as the solution, but rather to describe the present short coming:

I would like to be able to provide a link to the Wiki readers which reads something like "Download example 1b". They would then right-click on the link, select Save-As, and the file would be downloaded to their (platform specific) download directory. They would then open that file from FreeCAD.

Some background on present options/work arounds:
- User Mario52 has done something like this by putting files onto the forum. But his files are in Zip format due to (I think) a requirement by the forum software.

- I have tried setting up a Git repository but the downloading individual files requires them to be in Zip format.

- I have tried using DropBox, also a Zip requirement.

- I have tried WordPress and only text or image files are allowed to be uploaded (so they can subsequently be downloaded).

I don't want to sound like a crusade again Zip files here, I really have noting against them, but I am interested in making the "download and open" process as simple for the users as possible as my intention is to focus on users who may not be overly technically competent on computers. I am trying to make the ability to download FCStd example files as simple as saving a JPG image from a webpage.

As mentioned above, my goal is they can right-click on the Wiki page link, select Save-As, and then from FreeCAD do a File->Open.

Also as mentioned earlier, I don't like to suggest a solution, but is there somewhere an area for such files could be set up? I wouldn't expect the files to be overly large and also wouldn't expect the file population to overly dynamic. So a requirement such as an administrator move the files in shouldn't be too onerous.

thanks

Dean

PS if this is unclear in any sense just PM me
Tagsdocumentation

Relationships

Activities

2015-02-05 21:44piffpoofNew Issue
2017-01-11 22:19Kunda1Tag Attached: documentation

Kunda1

2017-02-02 14:21

manager   ~0008172

> - I have tried setting up a Git repository but the downloading individual files requires them to be in Zip format.
I don't think this is true. Example:
https://github.com/FreeCAD/Examples/raw/master/Sketcher_Tutorial_Example_Files/example%201.FCStd
2017-02-02 14:21Kunda1Statusnew => feedback

Kunda1

2017-03-02 13:37

manager   ~0008515

sounds like you also are looking for a CDN to host content on. There are options for that.
Thanks for the ticket. Closing as 'No change required' due to many other options that exist these days.
2017-03-02 13:37Kunda1Statusfeedback => closed
2017-03-02 13:37Kunda1Resolutionopen => no change required

Issue History

Date Modified Username Field Change
2015-02-05 21:44 piffpoof New Issue
2017-01-11 22:19 Kunda1 Tag Attached: documentation
2017-02-02 14:21 Kunda1 Note Added: 0008172
2017-02-02 14:21 Kunda1 Status new => feedback
2017-03-02 13:37 Kunda1 Status feedback => closed
2017-03-02 13:37 Kunda1 Resolution open => no change required
2017-03-02 13:37 Kunda1 Note Added: 0008515